Solved

Webroot preventing from the typing of Vietnamese fonts


Userlevel 1
Hello everyone,

 

I use Webroot. However, it prevents me from typing Vietnamese fonts, which means that I can't type my Vietnamese with marks. I thought my Vietnamese input software had problems until I disabled Webroot and I can type my Vietnamese again. 

 

Can anyone have any idea about this with solution. Thank you!
icon

Best answer by darkyrie 13 November 2016, 14:37

View original

18 replies

Userlevel 7
Hello coffee. Welcome to the Community.



Please check if WSA is blocking the Vietnamese typing software. Open WSA interface and go to Utilites > System Control > Start. Check if the software or any of its processes is listed. If so, allow them.



Also click on the gear icon beside PC Security on the WSA interface and check if the software or any of its processes is listed under 'Quarantine' or 'Block/Allow files'.
Userlevel 1
Thank you very much ams963. I made it to type the Vietnamese fonts again with Webroot enabled. With the path you gave me, I found that the file "igfxpers.exe" (from c:WindowsSystem32) was in "Montor" column. I put it in "Allow" column.

 

I use UNIKEY as a Vietnamese iput software with the EXE file "Unikey.exe" and its processes but no file has the name "igfxpers.exe". That's why I failed to find solution.

 

Once again, thank you for your kind help..
Userlevel 7
You're welcome. If you have any further questions or confusions please feel free to ask.:)
Userlevel 1
Dear ams963,

 

I does not work again after I restarted my PC. My solution is that, I need to disable and enable Webroot. I added UNIKEY.exe to the "Allow" column (though it was not blocked) but it seems the reason is different.

 

If you expect to test the experiment, you can download UNIKEY free.  Download link: http://sourceforge.net/projects/unikey/

 

I'd love to use Webroot, since it protects me from infecting virus very well.

 

Thanks and regards.

 

 

 
Userlevel 7
Badge +56
Hello,

 

Can you please Submit a Support Ticket and they can look at your scan log to see if some files need to be Whitelisted in the Cloud Database and they can help you get it working as it should for you.

 

Thanks,

 

Daniel 😉
Userlevel 1
Thank you Daniel. I have sent the support ticket to the Webroot techincal support team and am looking forward to hearing from their feedback.

 

I installed UNIKEY to my PCs at home and at work but the said problem happened the same.
Userlevel 1
Dear everyone,

 

As per the helpful instruction of the technical support team of Webroot, I found that, these items: 



- iexplore.exe 

- old_chrome.exe 

- new_chrome.exe 



were set to Protect in "Application Protection" (from "Identity Protection" menu to the right)



I tried to set them to Allow. To my nice surprise, the issue does not occur.
Userlevel 1
I forgot to let you know, the issue only happened when I typed Vietnamese on Chrome (I use Chrome) using any online services just like FB, Gmail, Google search, etc. However, on Winword, Excel, Notepad, the issue does not occur. Therefore, 

 

- iexplore.exe 

- old_chrome.exe 

- new_chrome.exe 

 

must be set to Allow, if I wish to type Vietnamese using online services on the browsers Chrome/iexplore/Firefox.
Userlevel 7
Badge +56
Just to let you know when not using UNIKEY I would set your Browsers back to Protect as in Allow mode you are not protected from Identity Shields protection! So I would say it's not a solution but a work around contact them again and link to this thread in the Ticket as there has to be a solution because it's leaving your Browsers unprotected in Allow mode.



Look Here: http://www.webroot.com/En_US/SecureAnywhere/PC/WSA_PC_Help.htm#C6_IDProtection/CH6a_ManagingID.htm and Here: http://www.webroot.com/En_US/SecureAnywhere/PC/WSA_PC_Help.htm#C6_IDProtection/CH6c_ManagingProtectedApps.htm



Thanks,



Daniel 😉
Userlevel 7
@ wrote:

 

I forgot to let you know, the issue only happened when I typed Vietnamese on Chrome (I use Chrome) using any online services just like FB, Gmail, Google search, etc. However, on Winword, Excel, Notepad, the issue does not occur. Therefore, 

 

- iexplore.exe 

- old_chrome.exe 

- new_chrome.exe 

 

must be set to Allow, if I wish to type Vietnamese using online services on the browsers Chrome/iexplore/Firefox.

Ah now it makes sense. I was kind of riddled as to why allowing those processes in the Identity Shield would let you type. It's clearer now.

 

@ wrote:

 

Just to let you know when not using UNIKEY I would set your Browsers back to Protect as in Allow mode you are not protected from Identity Shields protection! So I would say it's not a solution but a work around contact them again and link to this thread in the Ticket as there has to be a solution because it's leaving your Browsers unprotected in Allow mode.



Thanks,



Daniel ;)

I agree. It's still a workaround. You should be able to type in Chrome with the processes at protected mode in the Identity Shield. Otherwise WSA wouldn't protect your browser. And that's not safe.

@ You should follow Daniel's advice and ask the Support team via the trouble ticket for a solution.:)
Userlevel 1
Dear ams963 and Daniel,

 

The techincal support team had the same opinion like yours, so asked me to add any files associated to Unikey to be set to Allow. However, the issue still occurs, this way.
Userlevel 1
Dear everyone,

 

I contacted the Webroot Advanced Malware Removal Team for help, and they are researching for this issue and get back to me as their earliest convenience. Here is my suggestion to the Team and I would like you also to check for the problem for me as follows



I would like to suggest that, you install UNIKEY - download link: http://sourceforge.net/projects/unikey/ to your computer and check the problem. After UNIKEY installed, as default setting, VNI typing (Telex typing also is included) is used to type Vietnamese. For example: If you want to type this word "GÕ" 



- Type G 

- Type O 

- and then type 4. 



After typing, if you see the word like this "GO4", that means the said issue still occurs. 



Thanks and regards.

Coffee
Userlevel 1
Hi everyone,

 

The Webroot team's feedback was that, they will research for the issue and update it on the new update version of Webroot. Temporarily, I need to turn off Identity Shield or set Chrome Browser to Allow, so that I can type my Vietnamese on online serivces on Chrome/IE/Firefox.

 

Jus a few word to let you know.

 

Best regards

 

Coffee
Userlevel 7
Yes that is the process, I was the researcher that looked into your ticket. The normal causes for this issue werent present so it has been sent to the Q&A team with my notes along with the notes from support. 

 

 

 
Userlevel 1
Hi,

 

I'm also a Vietnamese user and also experience this particular problem. Webroot Identity Shield would block all keyboard hook from Unikey (the Vietnamese typing tool) to any web browser so I can't type any Vietnamese at all. However, I found out that if I run Unikey with admin previlege, Webroot allows me to type correctly. There's no need to disable Identity Shield or add Chrome/Firefox to exception list anymore, which is a security vunerability.

 

It's been two years later after the original post but I hope this helps.
Userlevel 7
Badge +54
Welcome to the Community and thank you for the update @
Hi darkyrie,

 

Your advice is helpful, but it only works for a few seconds after I run Unikey As Admin Administration. I was able to type Vietnamese for a few words and it turned back to normal. 

 
Userlevel 7
Badge +62
Hello khoasuperboy,

 

Welcome to the Webroot Community,

 

Please Submit a Support Ticket and they can look check to see if some files need to be Whitelisted in the Cloud Database and they can help you get this working for you.

 

Hope this helps?

Reply