windowssystem32driverswrkrn.sys

  • 6 September 2016
  • 58 replies
  • 22261 views

I have a computer that will not boot and is displaying the error "File:windowssystem32driverswrkrn.sys" on windows 10 OS. All searches point to an error with WebRoot. How do I fix this issue?

58 replies

i renamed the wkrkrn.sys extension and copy the file from a working computer and the issue got resolved.
Userlevel 7
Badge +26
Yeah for me I get into the command prompt mode in the recovery options and to the magic windows commands to delete or rename and it reboots fine, however I hope to see this resolved entirely soon, as I have lots of pressures on me as a beta tester and QA person for 4 companies.
We just had this issue this morning on a 2008 Standard server.  We renamed .sys file and rebooted and everthing is good right now.  I verfied that the Webroot version was 9.0.18.44
Userlevel 7
Badge +31
HI ,
 
Can you confirm that your servers were rebooted since the 9.0.18.38 release and that the sympton you are seeing is a zero byte wrkrn.sys file? 
 
 
thanks
 
 
Jonathan
 
Jonathan, still not working...I've had 2 of my Windows 2008 servers crippled with this isssue. Uninstalled Webroot on both and problem gone. Unlike the other memers in this thread, my problem only started a month ago. I'm running the latest release 9.0.18.38. My company has invested a lot of money with Webroot. Please advise on the way forward.
Userlevel 7
Badge +31
Hi
 
We addressed all known scenarios that lead to this issue with 9.0.18.34 .   
 
Hope that helps
 
Regards,
 
Jonathan.giffard
Senior Product Manager
WSA Business
 
I am looking to purchase Webroot for our company soon. We hae the trial version running (Version 9.0.18.34) does anyone know if the issue in this thread is still a problem on this version?
Hi Razied, 
 
Kindly share the cmd used in deleting mailicious program from your system.
I had the same issue yesterday and luckily my laptop is now properly functioning. I just deleted that file. You could do that by using the cmd. It was really frustrating because I couldn't even access the command prompt. But because of my cleverness, I managed to search the drive using system image recovery option. Just click the add driver button then search the directory folder and delete it and then reboot. And viola! You're good to go.
Going Through this Thread, will this issue happen to client PC with WS Endpoint Security. 
Userlevel 7
Badge +31
There will be a version of WSA that contains a fix for the known causes of this issue out for testing next week.  
 
I'll post links to it as soon as it has been cleared for release.
 
 
Jonathan
 
Thank you for the help. I have already taken my computer into Geek Squad and am picking it up a little later.
If you read what I posted, I was constructively trying to help another user. Please forgive my frustration with your customer service, as this issue is over a year old, and, to be honest, the trouble shooting suggestions that the community has gotten from Webroot reps has not not always been respectful -- my point being is that the respectful thing to do would be to read how sysadmins have described how the problem prevents booting into safemode and not make that the starting point of troubleshooting suggestions.
 
To the point, I don't feel respected as a customer. It's disrespectful to customers to tell us that you will have a solution patched last october, when clearly that has not occured and now the promise is for a patch this coming October. Perhaps you can understand the frustration that I and others feel, and perhaps you cam empathize with feeling disrespected. The fact is that customers have a choice when installing anti-virus and anti-malware, and the purpose of this software is to prevent computer issues that disrupt your life. When antivirus software is itself the reason I cannot boot -- that software is a Trojan Horse: installed for one purpose, but instead locking me out completely.
Userlevel 7
Badge +47
This is a respectful community where we encourage constructive feedback and offer the unique opportunity to have direct access with our developers. Our developers are working hard on many things and this type of language is not constructive or useful in making those changes. To get your issue resolved, please contact our customer support
You really have no idea, do you? We get BSOD the moment Windows starts to load. There is no login screen, there is no opportunity to enter safe mode. There wasn't for me.
It;s become my opinion that webroot is totally inept. Fortunately for me, the machine that this happened to (which no longer has webroot installed, <3), had Ubuntu on another disk. It doesn't sound like you're so lucky.
 
If you have access to ANY other computer, and a thumb drive, jhere's what you do, here's what worked for me but can applied to you since you dont have linux.
 
1) On another machine, download software called Rufus and download Ubuntu 16.04 LTS. These are both free downloads. Use Rufus to make a bootable Ubuntu USB drive. There are guides for this online, but it's very straightforward. In short, you tell Rufus where the ISO for Ubuntu and press go. Default settings are usually correct.
 
2) Boot from usb drive. DO NOT INSTALL UBUNTU. There is an Option called 'Try ubuntu without installing'
 
3). Youre in Ubuntu. Open a terminal by pressing the winkey and find terminal.
 
4) You need to identify the windows data partition. Type sudo blkid. It should be called Basic data partition, and it should be of TYPE="ntfs""
 
5) The second most popular answer described here: https://askubuntu.com/questions/145902/unable-to-mount-windows-ntfs-filesystem-due-to-hibernation?noredirect=1&lq=1 Tells you how to 'repair' the volume so it can be mounted. Because of Webroot's shitty driver, Windows files are in an unclean state and cant be mounted. The ntfsfix command described here fixees this issue and allows Ubuntu to mount the drive by typing sudo mkdir /media/windows and then 
sudo mount -t ntfs-3g -o rw /dev/*DRIVE FROM 4)* /media/windows.
 
*since you're running Ubuntu from a usb, the folder you make may not be /media/windows, make a new folder to use to examine your windows drive wherever you want* *the command to make the folder is the 'sudo mkdir /media/windows', instead use sudo mkdir /path/folder*
 
Navigate to media/windows/ and you will find your windows file structure in read / write mode! Delete webroot's Trojan-ware and you should be good to go.
 
I sincerely hope this helps, it's inane that a Webroot admin doesnt understand that we cant make it into safe mode reliably or at all. They haven't worked on this problem at all, and I would be shocked if a solution comes in October. 
Userlevel 7
@ wrote:
I can't boot into safe mode, I think this requires me to take the hard drive out and put it into another computer to fix, which I'm not doing. I'm just going to take my computer to Geek Squad. Thanks for the help though.
I'll just leave this here.
 
How To Boot Into Safe Mode On Windows 8 or 10 (The Easy Way)
I can't boot into safe mode, I think this requires me to take the hard drive out and put it into another computer to fix, which I'm not doing. I'm just going to take my computer to Geek Squad. Thanks for the help though.
Userlevel 7
Badge +31
Going from memory as I don't have a windows computer to hand at the moment. 
 
Boot your computer into Windows safe mode. 
Delete the  windowssystem32driverswrkrn.sys
Reboot
 
I have just come across this problem 2 days ago. I am VERY unhappy with WebRoot. Is there  a way I can just copy windowssystem32driverswrkrn.sys onto a USB using command prompt? Is there a easier way than having to take out my hard drive and putting it onto a different computer to delete the file? NOT HAPPY.
It looks like this problem was first reported in September of 2016, and it's now September of 2017 and this problem just happened to me. I am a medical researcher in neuroimaging and I utilize webroot on multiple machines, and my environment spans Ubuntu, Mac, Windows, and Fedora systems. I am a client, not a sysadmin, and I am not impressed. I will be uninstalling webroot from all of my machines  and recommending the same for all of my colleagues. A year to fix a driver issue? Sorry. I don't have time to deal with issues like this, nor the inclination to do business with a company that addresses problems on this kind of timescale. I just wanted to inform this company of my feedback.
any way you can just copy the WRkrn.sys through usb without the windows 7 iso? also can i delete the file just through command prompt? I tried renaming it, but it said the file couldnt be found. 
Userlevel 7
Badge +31
We have addressed the known scenarios that can lead to this situation in the next WSA release, 9.0.18.xx.  That is due to be released early October with release candidates for testing soon. 
 
 
Regards
 
 
Jonathan.giffard
Senior Product Manager
WSA Business
Found that simply deleting the Wrkrn.sys file is sufficient rather than replacing....as i have to do EVERY time i reboot my 2008 server.
 
Solid pain in the behind.
 
My web console says the server is on agent  version 9.0.17.28.
 
The WRkrn.sys file version is 9.0.17.25.
 
Could do with this fixed...
Userlevel 7
Badge +31
So long as you can access the USB drive  ( I don't have a Windows 10 system to hand ) you shoud be able to 
 
  • Copy wrkrn.sys from the USB drive to c:windowssystem32wrkrn.sys
  • Reboot computer back into normal startup
 
 

Reply