New

Uninstalling Webroot


Userlevel 6
Badge +19
We keep most of our device policies set to not allow access to the console. Due to this, I have to do everything via the console. This generally isn't a big deal. However, I recently ran into an issue where a PC hadn't checked in with the console for one and half months. I could save a log and see that it was still scanning on the PC, however I couldn't:

  1. Force it to check in with the console.
  2. Change the policy in the console and it update on the PC.
  3. Uninstall it via the console.
With all these options unavailable to me, I tried uninstalling it directly on the PC. It refused to allow me to do this, even when I was logged in as a Domain Admin. I understand not allowing the user to uninstall it, but as a Domain Admin I should be allowed to. There needs to an override that allows Admins to uninstall the software in situations like this.

Sincerely,

3 replies

Userlevel 4
Badge +16
You can still do this with command-line switches for WRSA.exe. You can force agent to check-in with console with "-poll", and uninstall with "-uninstall".

However, it should be polling regularly anyway: mine are set to every 15 min by policy. If the agent can't reach GSM or is somehow broken, manually telling it to poll won't work. You may just need to uninstall/reinstall.

If that doesn't do it, make sure you have the necessary FQDN's allowed through your firewall, content-filters, etc.
Userlevel 6
Badge +19
Thanks for the info on the command line switches. However, my policies are set for every 15 minutes and it wasn't checking in. I couldn't force it to refresh the configuration. I could tell it to, but it wasn't communicating with the console anymore so that was useless. I also couldn't uninstall, even as the Domain Admin. Nothing is blocking it, i.e. firewall, filters, etc. Hence the need for an override that allows an admin to uninstall Webroot.
Userlevel 6
Badge +19
Update on the uninstall issue. I have another endpoint that is a server that is having some issues with Webroot. This one has policies that refresh with the console every 15 minutes, allow access to the GUI on the endpoint, allow Webroot to be shutdown on the endpoint, and had the Webroot firewall is turned off. In an attempt to fix the issue, I tried to uninstall from the server after shutting down Webroot. I was logged in as a Domain Admin and still got the message that I wasn't allowed to uninstall. I then went to the console and sent the command to uninstall. Went back to the server and was going to restart Webroot so it could update with the console and uninstall. However, it apparently uninstalled even though it told me I wasn't allowed to. This obviously wasted my time going through the steps of using the console if the server uninstalled and gave me an inaccurate message.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept or continue browsing you agree to our cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings