Announcing Windows 10 Insider Preview Build 17746 Fast Ring


Userlevel 7
Badge +59
August 24, 2018 10:02 am
 
By Dona Sarkar and Brandon LeBlancHello Windows Insiders!
Today, we are releasing Windows 10 Insider Preview Build 17746 (RS5) to Windows Insiders in the Fast ring.

General changes, improvements, and fixes for PC

  • We fixed an issue where Narrator would incorrectly report some standard combo boxes as “editable combo box” instead of “combo box”.
  • We fixed an issue in Windows Mixed Reality causing motion controllers to need to be re-paired after initial setup before appearing in the headset. If you still experience this, please file feedback in Feedback Hub.
  • We fixed an issue for Japanese and German where when you reset your PC (from Settings > Update & Security > Recovery) the progress percent would be written in the middle of the string rather than at the end.
  • We fixed an issue when using Italian as your display language where the Yes button to confirm file deletion would sometimes disappear when trying to delete a OneDrive file via File Explorer.
  • Thanks for everyone that’s shared feedback about naming the tabs you’ve set aside in Microsoft Edge. We’re evaluating the right approach for this feature and in the meantime, it has been removed from RS5 builds.

Known issues

  • You may experience a bugcheck (GSOD) when logging out of your user profile or shutting down your PC.
  • When you use the Ease of Access Make Text bigger setting, you might see text clipping issues, or find that text is not increasing in size everywhere.
  • Narrator sometimes does not read in the Settings app when you navigate using Tab and arrow keys. Try switching to Narrator Scan mode temporarily. And when you turn Scan mode off again, Narrator will now read when you navigate using Tab and arrows key. Alternatively, you can restart Narrator to work around this issue.

Notable app updates

  • We’re shipping Your Phone app to Insiders in the Release Preview ring, specific to PCs running Windows 10 April 2018 Update (Version 1803, Build 17134). Check it out!
  • If you’re in Skip Ahead we recently flighted version 10.1807.2286.0 of Screen Sketch to you! As mentioned, we’re exploring a new name, so let us know what you think! We’ve also added a delay snip feature, which was one of the top features requests we heard from you. Just click the chevron next to the New button in the app and you’ll now find options to “Snip now”, “Snip in 3 seconds”, and “Snip in 10 seconds”. Oh, and if you have the app open or pinned to your taskbar, you can just right click the icon in the taskbar to get these options, since we’ve added them to the jump list – let us know what you’d like to see next!
No downtime for Hustle-As-A-Service,
Dona <3
Updated August 24, 2018 10:03 am
 
https://blogs.windows.com/windowsexperience/2018/08/24/announcing-windows-10-insider-preview-build-17746/#g9RAYzM72H8wcy7U.97

50 replies

Userlevel 7
Badge +58
Thank you Daniel! 😉
Userlevel 7
Badge +51
Thank you Daniel.
I am having problems doing this one though, it will not install more than 40%, I will try again over the weekend hopefully.
@ wrote:
Thank you Daniel.
I am having problems doing this one though, it will not install more than 40%, I will try again over the weekend hopefully.
You're not alone, Jasper. I'm having trouble, too. Seem to be stuck in a bit of a loop. I thought it said it had installed and needed a restart. But upon restart, I'm now back to "Getting things ready - 72%" were it appears to be hanging yet again. 😞
 


😠 😠 :S 😠 :@
 
Userlevel 7
Badge +51
BD, you said a loop, that is an understatement LOL.
I would get - getting things ready, download, install. gettings things ready etc etc etc, after 5 hours I have given up, left feedback as well.
I tried a clean boot, cleaning out the software distribution folder and no luck.
Just as an experiment I am installing a new and clean VM to try it out on a fresh installation.
Userlevel 7
Badge +59
I haven't tried to install this Build but I will try now.
Userlevel 7
Badge +51
@ wrote:
I haven't tried to install this Build but I will try now.
I appear to be having more luck this time so far! 97% downloaded with no hassle so far with pretty much just the install to do and 2 hours gone.
@ wrote:
@ wrote:
I haven't tried to install this Build but I will try now.
I appear to be having more luck this time so far! 97% downloaded with no hassle so far with pretty much just the install to do and 2 hours gone.
Well, I was at "100% downloading", until it jumped back to "Getting things ready - 77%". https://proxy.duckduckgo.com/iu/?u=http%3A%2F%2Fwww.sherv.net%2Fcm%2Femoticons%2Ffighting%2Fsmack-self-in-the-head.gif&f=1
Userlevel 7
Badge +51
@ wrote:
@ wrote:
@ wrote:
I haven't tried to install this Build but I will try now.
I appear to be having more luck this time so far! 97% downloaded with no hassle so far with pretty much just the install to do and 2 hours gone.
Well, I was at "100% downloading", until it jumped back to "Getting things ready - 77%". https://proxy.duckduckgo.com/iu/?u=http%3A%2F%2Fwww.sherv.net%2Fcm%2Femoticons%2Ffighting%2Fsmack-self-in-the-head.gif&f=1
We will see 😉
Userlevel 7
Badge +59
So far in 11 Minutes on the 32bit version.
 

.
 
And for the 64bit version at this time.
 

Userlevel 7
Badge +51
There are times where I wish I had a much faster download speed and this is one of them.
Userlevel 7
Badge +51
It is certainly going more smoothly this time Preparing to install - 24%
Userlevel 7
Badge +59
@ wrote:
So far in 11 Minutes on the 32bit version.
 

.
 
And for the 64bit version at this time.
 


Still at the same place and hasn't moved since on both???
Userlevel 7
Badge +51
Mine was stuck on 99% for quite a while and then quickly moved on, installing now.
Userlevel 7
Badge +51
Downloading again!!!!!!!!!!!!!!!!!!!!!!
Finally!!!
 


Persistence and patience is the key, I guess. :p
 
 
 
Userlevel 7
Badge +58
Hi Webrooters 
 
Yea @! ;)
 
I'm going to fire up my Alienware and see how far I can go since all of you were/are having issues installing.
Userlevel 7
Badge +51
@ wrote:
Finally!!!
 


Persistence and patience is the key, I guess. :p
 
 
 
Good heavens, it is possible.
The very best of luck to you @, I may try again tomorrow possibly but I will see because right now I feel as if I have wasted too much time with it.
Userlevel 7
Badge +58
@ wrote:
@ wrote:
Finally!!!
 


Persistence and patience is the key, I guess. :p
 
 
 
Good heavens, it is possible.
The very best of luck to you @, I may try again tomorrow possibly but I will see because right now I feel as if I have wasted too much time with it.
 
Thank you Jasper  My patience is going to be thin here if I cant get the WI update to install.  LOL Tomorrow is another day for you Jeff...hopefully you'll get this UD installed.  ;)
 
Userlevel 7
Badge +51
I am not a quitter with these things @ but this time I am coming very close to it.
Userlevel 7
Badge +58
@ wrote:
I am not a quitter with these things @ but this time I am coming very close to it.
I know that Sir Jeff! ;)
Userlevel 7
Badge +58
Sorry guys.. I got this WU installed pretty quickly without issues. It must be my Alienware performance is el supremeo!:D
 

@ wrote:
Sorry guys.. I got this WU installed pretty quickly without issues. It must be my Alienware performance is el supremeo!:D
 


Way to go Sherry. I don't know why it took so many tries for me. Wondering if there wasn't/isn't issues with the source of the updates (high demand, routing problem,server down, etc.). It sure seemed to be confused as to whether it was getting ready, downloading or installing. Hopefully the other guys get it installed soon. 😉
Userlevel 7
Badge +58
@ wrote:
@ wrote:
Sorry guys.. I got this WU installed pretty quickly without issues. It must be my Alienware performance is el supremeo!:D
 


Way to go Sherry. I don't know why it took so many tries for me. Wondering if there wasn't/isn't issues with the source of the updates (high demand, routing problem,server down, etc.). It sure seemed to be confused as to whether it was getting ready, downloading or installing. Hopefully the other guys get it installed soon. ;)
By George BurnDaddy that could be very true and would make sense. An OVERLOAD on the servers.Or/and the other things you mentioned. Of course that seems to be the logical answer to why others are having these issues. Thanks for the input!:D
Userlevel 7
Badge +59
Got both of them installed and I just walked away and came back and they both asked for a reboot and they installed fine and i would say about 2 1/2 hours.
 

Reply