Solved

Firefox Pop Up Warning.


Userlevel 7
I'm using Firefox 21 on Win XP. When I log into my email account at Verizon I get the following pop up:

 



 

This doesn't happen with IE-8. Is there a setting on FF to turn this pop up off and is it safe to turn it off?
icon

Best answer by RetiredTripleHelix 18 July 2013, 17:49

View original

11 replies

Userlevel 7
That means you're sending data from a secure page to a non-secure url. So you're probably starting at an https page and ending up at an http page. Some websites will, for instance, have a login button that takes you to an https login page but redirects you back to an http page once you're logged in. It is a legitimate security issue. The warning can be suppressed, but it's better to try to avoid the issue by signing in from a better link. Last I looked, this was something covered under a user_pref field in about:config. Mozilla may have added an actual control for this in settings by now though.
Userlevel 7
Badge +56
I can't see a setting in Firefox 22 but I posted that Firefox 23 will Block Mixed SSL content. http://community.webroot.com/t5/Security-Industry-News/Mozilla-Firefox-23-Will-Block-Mixed-SSL-Content/td-p/48922#.UecpB23NmSo

 

Daniel
Userlevel 4
Badge +3
Hello ProTruckDriver :)

 

It is completely safe to turn this preference off, many websites use HTTPS and HTTP connections so this can become annoying at times. You can disable these prompts within the Firefox settings. To do so, just take the following steps as in the image:

 

Open Firefox > Tools > Preferences > Security > Settings (under Warning Messages)

Untick the last option for "I'm about to view an encrypted page that contains some unencrypted information." and press OK > OK.

 

Userlevel 7
Badge +56
I don`t have that setting with FF 22?

 

Daniel

 

Userlevel 5
Those boxes don't exist anymore in FF 19+. They might still be in the ESR version as that is based of version 17.

 

I thought I remember reading that all Security Warnings had been removed since 19, might be mistaken though.
Userlevel 4
Badge +3
@ wrote:

I don`t have that setting with FF 22?

 

Daniel

 





Ah I'm only a temporary Mozilla user (Chrome fan) and I didn't realise the preferences had been removed. It turns out it's Firefox trying to force the websites themselves to update their own HTTP methods and more info (with someone also using Verizon email) on the issue can be found here:

 

https://support.mozilla.org/en-US/questions/962465

 

It turns out that if you sign in at the below link instead of mail.verizon.com, the prompt doesn't appear:

 

https://www22.verizon.com/foryourhome/MyAccount/ngen/upr/signin.aspx
Userlevel 7
Badge +56
@ I guess your using an older version? And your correct no prompts on that link.

 

Daniel
Userlevel 7
@ wrote:

@ I guess your using an older version? And your correct no prompts on that link.

 

Daniel

Thanks EamonF for the link. Like Daniel said, this link works without prompts.

Userlevel 7
Badge +56
What version are you on Dave?

 

Daniel
Userlevel 7
Firefox 21, Win XP. I can't upgrade Firefox because I'm having problems with RoboForm with Firefox upgrade. (Roboform support ticket is in).
Userlevel 5
In that case you might wish to use the ESR version instead. It's based of version 17 if I remember correctly, but it's security is up-to-date.

Reply