Not Sure Where to put this one Question about GWX Diagnostic Message


Userlevel 3
  • New Voice
  • 9 replies
 

I am indeed new here so please forgive me # 1 if I've put this post in the wrong Forum.  #2 if this is a dumb question.    LOL

 

I have ran the GWX exe at the suggestion of a dear friend and it has indeed resloved my Win 10 issue.  I have run the Diagnostics and have only one error message.  "Software Protection service=NOT running."  Now I have read some of the methods of fixing this issue.  My question is and please forgive me for asking this but is there a simple solution for fixing this issue?   Instead of trying this and trying that as a possible solution I'd rather do what some one suggests who knows what will definitely fix my problem. 

 

"This is what is stated in the Trouble Shooting Guide for my Problem"

 


  • Try some of Microsoft's Windows Update troubleshooters. The first one I'd try would be the one located at the bottom of this Knowledge Base article. (Look for the "automatic troubleshooter" link.) If that doesn't seem to work for you, proceed to this other troubleshooter.
  • Try a third-party repair tool. While I haven't used this tool personally, I have heard positive reviews from some folks who were able to able to resolve Windows Update issues with Tweaking.com's Windows Repair utility.
Thank-you for any and all replies. 

 

PT

 

9 replies

Userlevel 7
Hi PT

 

Welcome to the Community Forums.

 

Am I correct in thinking that you have TWO issues; (i) something is informing you that the Software Protection Service is not running AND (ii) you have an issue with Windows Update?

 

If so then in the case of the Software Protection Service issue please see this thread from the Microsoft Support Forums which may help.

 

In terms of Windows Update; there are many reasons for issues and so it would be helpful to have some additional information to enable us to try to situate the issue more precisely. Is Windows Updates not running? Is it running but getting stuck when downloading? Are all or some updates failing to install?

 

Please post back with responses to the above & also if the information provided re. the Software Protection Service issue does not help.

 

Regards, Baldrick
Userlevel 3
Ok, beginning at that start of my issue, I was forced into the situation of having to run the GWX10 exe.  I do a lot of computer graphics and the Win10 nag was affecting my sysytem to where some of my graphics proggies were acting squirrely. 

 

I ticked the button in Windows Update Downloads in the GWX10 from accept all to request my permission to download and install.  My initial setting is how I became entangled in this situation originally.  I'm assuming my changing the permissions on my Windows Updates has now created my current one??

 

 After running the exe sure enough my system was back to acting normally.  I found the run diagonistcis and ran it.  Everything was fine except I had the Software Protection error message.  I read the instructions but could not make heads or tails of what I was reading.  ( I think panic mode set in TBH) So I posted here, thinking someone else had seen this issue before. 

 

Now that I've slept on it I have once again read the instructions on how to solve this dilemma and have begun to figure things out.  I have indeed opened

 

(Open up your Services control panel



(services.msc) and locate Software



Protection and Windows Update, then make



sure they're both enabled as "Automatic



(Delayed Start)" and that they're both



running.)

 

I have clicked the Software Protection gear and Start is highlighted  I'm assuming this is indicating that I must click it to start it once again? Seeking instructions before I cause some possibly unwanted repercussions.  As I hate computer issues and do indeed attempt to avoid them at all cost. 

 

Thank-you for your assisitance with this problem.

 

PT

 

 

I have since posting this,  decided to follow the logic and indeed clicked Start.  (What can I say, it's been a LONG TIME since I've had computer issues, LOL)

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

 

New Question,

 

I did indeed start the Start the Software Protection.  Watched the bar as it began operating.  After a while I thought I'd just ck and make sure it was still operating.  I once again ran the Diagnostic Tool in the GWX10.  Once again it stated that the Software Protection was off. 

 

I  again navigated to the Service Control Panel and it was once indeed off.  I turned it on and now am wondering if the Diagnostic Tool is turning off my Software Protection.  ???

 

Anyone else experienced this issue,  is my assumption correct, The GWX10 Diagnostic Tool is the source of my frustration and is turning off my Software Protection?

 

PT

 
Userlevel 7
Hi PT

 

Well, it seems as if you are doing just fine without us...and indeed you are doing the right thing, when you get confused or are unsure, of not rushing in but putting things aside and coming back to them later when ones perspective has changed. That is in fact what I do always in these circumstances. ;) 

 

So well done! :D

 

And if you have any further questions or issues please come back here and let us know as we may be able to offer further advice, etc.

 

Have a great weekend.

 

Regards, Baldrick
Userlevel 3
Thank-you so much for your kind words Baldrick 

 

New Question,

 

I did indeed start the Start the Software Protection.  Watched the bar as it began operating.  After a while I thought I'd just ck and make sure it was still operating.  I once again ran the Diagnostic Tool in the GWX10.  Once again it stated that the Software Protection was off. 

 

I  again navigated to the Service Control Panel and it was once indeed off.  I turned it on and now am wondering if the Diagnostic Tool is turning off my Software Protection.  ???

 

Anyone else experienced this issue,  is my assumption correct, The GWX10 Diagnostic Tool is the source of my frustration and is turning off my Software Protection?

 

PT

 

addendum

 

I currently have GWX10 running in background to monitor any new Win10 activity should I with my new suspicions turn this feature off and simply consider my Win 10 issues solved??? Or keep it on and occasionally navigate manually to ck the status of the Software Protection? 

 

Thank-you for all advice.

 

PT

 

 
Userlevel 7
You are most welcome...and you deserve them. ;)

 

Now as to the Software Protection Service being 'turned off' by the GWX Diagnostic Tool...well, that I cannot commnet on as I do not know and I have not managed to find anything by research that would point to that. I have found the GWX Troubleshooting Guide (HERE)...not sure if that is what you have been using...but nothing in there even hints that GWX might be the cause.

 

Have found this previous thread over at the MS Forums that points to this being a known issue and happening from time to time, and they provide a solution but it is quite technical, and may therefore be too daunting for you to undertake...but you may want to take a look anyway.

 

Reading around the issue it looks like it may also be due to a 'permissions' issues on your system but again the potential 'fix' is quite technical...so I do not really know what to suggest in light of that. HERE is the relevant thread in case you would like to give it a go.

 

Not sure if any of this is of assistance?

 

Regards, Baldrick

 

 

 

 

 

 
Userlevel 3
Thanks for all your help with this one Baldrick.  I manually nav.ed to the SWP and it was indeed once again off.  So I'm thinking with the info you posted I do indeed have the noted " MS known issue" of the SWP problem. 

 

I do remember reading the solution you posted probly on the GWX10 guide.... ~sigh~ I'll take a look and determine if I have the fortitude to deal with this problem, or if I'll simply send it to my comp guy.  At one point in my life I did indeed deal with complicated technical computer issues.  (Started off with WinXP) I'll simply have to go back and reread the steps involved and come to a decision on where to go from there.

 

I guess I should be thankful to GWX10 for bringing this problem to my attention. 

 

Again can't thank you enough for your attention to my issue. 

 

Sincerely,

 

PT
Userlevel 7
Hi PT

 

As I said before...you are most very welcome...always glad to try to assist a fellow Community member. :D

 

Do keep us posted as to how this develops for you/what you decide to do to try to get it resolved...I for one am very interested.

 

Also, if you have any further question on this or other topics then you know where to come...there should always be a few members around/online who will wade in to try to assist.

 

Have a great weekend.

 

Regards, Baldrick
Userlevel 3
?   ?

 

Due to the holiday I here in the states didn't get to speak to my computer guy until today.  It's his feeling as well that the SWP issue is connected to the GWX10 preventing the Win10 update. 

 

He says he feels this is a non-issue for now.   Again can't thank you ? enough for all your help.  If at somepoint this SWP situaiton does indeed become an issue,  I've mentioned to my Comp guy that he'll be the one who gets to address it.  LOL

 

PT
Userlevel 7
Hi PT

 

Many thanks for keeping us posted as to where you are re. this. And as I said before...no need for any thanks...you are most welcome to the assistance. :D

 

If you have any further issues and/or questions then you know where to come; there should always be a member or two available to respond.

 

Regards, Baldrick

Reply