Webshield causing problems with Firefox in multiprocess mode

  • 2 January 2018
  • 4 replies
  • 1157 views

When running Firefox with multi-process and Webroot Webshield enabled, I am experiencing problems whereby CPU spikes although not to 100%. The PC becomes very sluggish including mouse movements. If I can get windows Taskmanager to respond, I can resolve the issue by ending Firefox otherwise a reboot is necessary. It seems to relate to a conflict between scripts and Webshield. Has anyone else experienced this?
 
Windows 8.1
Firefox V52.5 ESR
Webroot 9.0.18.44 - fresh re-install tried.

4 replies

Userlevel 7
Badge +55
Hello, I will ping @ and see if he can add anything to this issue. Or you can Submit a Support Ticket and let them know the issues you are having.
 
Thanks,
 
Daniel
Userlevel 6
Badge +19
I have one laptop on Windows 10, 32-bit and I run Portable Firefox v56.0.2 with the Webroot Filtering Extension manually added.  I also have the Add-on Compatibility Reporter extension which identifies legacy extensions and whether or an extension supports multiprocess;  this helps in identifying which may have issues as Firefox releases version 57 Quantum.
 
The "Webroot Filtering Extension - XUL/XPCOM 1.5.0.6" appears to be identified as "Legacy" and "Not compatible with Multiprocess". 
-Patrick

Userlevel 7
Badge +26
If I were you I'd switch to either Brave or Slimjet browsers. Both are Chrome based and can support the same addons, however without the big brother factor of google and they use a lot less memory/cpu and slimjet even has some built in features such as ad blocking and video downloaders. 
If anyone is interested, after many, many hours I have finally fixed the problem. I have to disable Webroot Webshield BEFORE starting a clean install of Firefox ESR 52 for the FIRST time. I then have to disable accessibility tools in Firefox BEFORE re-enabling Webshield.

If I do not follow this sequence, when I FORCE Firefox to run in multi-process mode (because it objects to Tabmix Plus addon even though it is E10 compliant), I get the problems described in my original post.
 
So it appears to be some sort of conflict between Firefox and Webshield. I must admit I'm a bit surprised no one else has had this problem as it happens for both my PCs - perhaps my setup is more unusual than I think.
 
At one stage I was tempted to ditch Webroot but quickly abandoned the idea after a bit of research - notwithstanding the issue I have described it really is the best out there imo - although the systray icon displaying a warning for a month before renewal is extremely irritating.
 

Reply