Question

AgentStatus endpoint no QueryResults

  • 14 March 2023
  • 2 replies
  • 46 views

Hello,

 

I need to get my client’s Agentstatus data but the queryresults aren't giving me any results when trying to query it. Am I doing something wrong? Thank you!

 


2 replies

Userlevel 1

Hi,

To get your client's Agentstatus data, you can try the following steps:

  1. Log in to your client's Webroot management console.
  2. Go to the "Endpoints" tab and select the endpoint that you want to retrieve the Agentstatus data for.
  3. Click on the "Reports" tab and select "Query Reports."
  4. In the "Query Builder," select "AgentStatus" as the report type.
  5. In the "Data Fields" section, select the fields that you want to include in the report.
  6. Set any filters or parameters that you need to in the "Criteria" section.
  7. Click "Run Query" to generate the report.

If you have already tried this and are not getting any results, you may want to check that the endpoint is currently online and communicating with the Webroot servers. Additionally, you can contact Webroot support for further assistance with troubleshooting the issue.

Regards,

Bricied

Userlevel 3

Hi papabolrome, 

 

Looking at your screenshot, it seems like you’re properly authenticated, and that the site keycode is valid; as I’d expect different outputs if that were not the case. 

I suspect that perhaps there is a mismatch between the site key you are using in this API call and the site key that is actually assigned on the endpoints you wish to get status data about. 

The response in your screenshot is consistent with the response expected from a site that has no endpoints installed with the matching site key code. 

In the GSM console, do you see the endpoints listed under the relevant site?

 

Kind Regards, 

 

Stephen

Reply