Required User-Agent Request Header


Userlevel 4
Badge +9
Hello,
 
There is an upcoming User-Agent header requirement for all Unity API requests, per HTTP/1.1 standards. Please make sure to include this as to prevent blocked requests. From our API documentation:
 
IMPORTANT - Identifying your Application
When using the Unity API you need to specify a valid user agent string for all requests in the corresponding User-Agent request header. The string needs to be made up of one or more name and version pairs separated by a whitespace character (e.g. "MyCustomApplication/1.2.759 ThirdpartyPlatform/1.0.r3"), according to the HTTP/1.1 standard.
Please be aware that Webroot reserves the right to reject Unity API requests that do not follow above requirement anytime in the future. Identifying your application is important and enables Webroot to provide a more targeted and streamlined API experience.
 
Should you have any questions, please let us know.
 
Best regards,
Joseph R.
 

0 replies

Be the first to reply!

Reply