Solved

Webroot Universal Reports folder does not exist

  • 24 May 2021
  • 1 reply
  • 28 views

I am trying to learn how WUR works,

The report runs and returns a ‘Success’ status,

If I click the ‘Open’ link, it opens this folder

C:\Users\fname.lname\OneDrive - MyOrganization Name Services Ltd\Documents\Webroot Reporting\Runs\20210524T0324515876892Z\Output

where I can see a Result.json file.   

But it seems that webroot is not creating the associated excel workbook.

 

When I look at the WebrootReporting.Log it has the following entry.

24/05/2021 12:45:35 PM ResultReadingService: LoadPreviousGeneratedResults failed. Reason: C:\Users\fname.lname\OneDrive - MyOrganization Name Services Ltd\Documents\Webroot Reporting\Runs folder does not exist!

 

The path is exactly the same in both cases. Any idea what is going on here?

icon

Best answer by ngoknel 4 June 2021, 12:54

Hi @Goanna 

The second error in “WebrootReporting.log” is a UI log entry.  It means that the Universal Reporter app tried to check the contents of the user’s Runs folder, but did not find it.  You normally get this, if no report has been generated so far.  If, for example, the UI was started at 12:45 and the first report was run afterwards, there would be an app specific log entry at 12:45, when no Runs folder existed yet.

As for the other observation: there are a lot of reasons why there may be no Excel file in “runs”.  One could be that no templates were selected in the app when triggering the report generation.  Please take a look at the Logs directory underneath the respective Runs directory, in his case that would be:

C:\Users\fname.lname\OneDrive - MyOrganization Name Services Ltd\Documents\Webroot Reporting\Runs\20210524T0324515876892Z\Logs

In this directory, UR scripts usually generate a log file called “WebrootReportingTool.log” which helps to understand what happened during the run. If, for example, no template has been selected, there would be the line:

No templates were selected.

Note: When clicking the “Open” link on the “Report Status” page, the link leads directly to the “Output” directory of the respective run which the user has looked at. You would have to go up to the parent folder (e.g. 20210524T0324515876892Z) and then step down to “Logs”.)

Hope this helps!

View original

1 reply

Userlevel 3
Badge +8

Hi @Goanna 

The second error in “WebrootReporting.log” is a UI log entry.  It means that the Universal Reporter app tried to check the contents of the user’s Runs folder, but did not find it.  You normally get this, if no report has been generated so far.  If, for example, the UI was started at 12:45 and the first report was run afterwards, there would be an app specific log entry at 12:45, when no Runs folder existed yet.

As for the other observation: there are a lot of reasons why there may be no Excel file in “runs”.  One could be that no templates were selected in the app when triggering the report generation.  Please take a look at the Logs directory underneath the respective Runs directory, in his case that would be:

C:\Users\fname.lname\OneDrive - MyOrganization Name Services Ltd\Documents\Webroot Reporting\Runs\20210524T0324515876892Z\Logs

In this directory, UR scripts usually generate a log file called “WebrootReportingTool.log” which helps to understand what happened during the run. If, for example, no template has been selected, there would be the line:

No templates were selected.

Note: When clicking the “Open” link on the “Report Status” page, the link leads directly to the “Output” directory of the respective run which the user has looked at. You would have to go up to the parent folder (e.g. 20210524T0324515876892Z) and then step down to “Logs”.)

Hope this helps!

Reply