Webroot right click on folder or file scan not working

On several installations of Webroot SecureAnywhere (about 2% of clients installed) the option is available to scan a folder or file (right click the folder or file and then click the Scan with Weboot) but then when you do that, nothing happens.  It appears that the scan just never runs.  No scan registers in the scan logs.
- Googling "webroot right click scan not working" clearly shows lots of folks are having this issue.
- I have called support on this and the tech (though very, very green -- I think it was his first day) said Weboot was aware of this issue and was working on a fix.  This was a few months ago and I'm not seeing any changes on these clients as they upgrade agents.
- This is not a policy issue.  All clients run under the same policy (recommended default) and most work.  
- The most cited resolution in Google links is to remove the client and reinstall.  
- I have done that on one client and now, the option to scan with Weboot  is not even available when right clicking a file or folder.
Clients use this feature alot and it would be appreciated to see this resolved.  This occurs too often on too many systems for it to be not a Webroot developer issue.  
Help appreciated.

Best answer by jhartnerd123 6 May 2016, 04:48

View original

4 replies

Userlevel 7
Badge +33
Hey sunny,
To fix this issue:
1. Send an uninstall command to remove the agent from the system
2. Show hidden folders/files on the system in question
3. Go to Program Files, Program Files x86 and Program Data
Here, find and remove any webroot folder or most importantly the WRData folder in the Program Data folder.
Then reboot the system and reinstall the agent, ensuring that all of your browsers are shut down.
This has normally fixed it for me. The crucial part is removing the WRData folder for this to work.
Hope this helps.
Userlevel 5
Badge +19

Can confirm this worked for me. Tech might send you a tool - this didn't work for me. Un-/reinstall didn't fix it either, removing the WRData folder as described by jhartnerd123 above worked. I suspect this issue is related to installing/updating under different accounts.
Thanks for the help guys.  The reinstallation did bring back the "scan with Webroot" option but darned if when I tested things again no Webroot dialog. 
On a hunch, I contacted the end user who works at the computer and asked them to try a scan with Webroot on a folder -- IT WORKED!
So, this is an issue wtih remote connections.  On about 2% of the computers I connect to remotely -- scan with Webroot does not work.
Does anyone have an idea as to how to proceed with this?  Is there a workaround?  Is the Webroot team aware of the issue and is there a proposed fix in the future?
Userlevel 7
Badge +33
I can't see how it's a remote connection issue as all you are doing is controling the keyboard and mouse and aren't exactly issuing commands remotely.
I use GoToAssist and don't have the issue with the context menu disappearing remotely but working locally.
What remote software/service are you using?
Also, contact support if you believe you are still having issues.