Can't reinstall webroot onto Mac

  • 29 May 2020
  • 3 replies

So I purchased webroot 6 months ago at Best Buy and I recently uninstalled it as it was making my laptop very loud, hot and drained the battery. I tried to reinstall it  (on mac) but I could only get to step two of these instructions offered . The only thing that pops up when I click the dmg file is a pop up of the webroot icon and when I click on it I, I briefly see something pop up on the dock but it quickly dissapears. I can’t do anything else from here.

This topic has been closed for comments

3 replies

Userlevel 7
Badge +20

@Omar D  ,

It’s possible your uninstall was not completed fully and may need to be restarted. Can you go through these instructions before doing another full reinstall?


If that doesn’t work, it may be best to contact our SUPPORT TEAM for assistance.

Please let me know if that helps - thanks!


I have almost the exact same problem. 


If you can’t even open the Webroot app, you can’t follow those instructions to uninstall the app.  It’s as if there isn’t an app at all.  I have an icon in my apps and an icon on my toolbar, but nothing opens and there is no webroot symbol in my status bar at the top of the screen.

I contacted the support team for assistance, but it has been five days and I haven’t heard a peep. 

Any other suggestions?  I’ve even tried to use a “clean-up” app to get rid of the bits of the app that didn’t get uninstalled properly, but that didn’t change anything.


Userlevel 7
Badge +20

@mococatx ,

Please give a short time for Support to get back to you and refrain from responding to the support ticket before they respond - this would push your ticket to the bottom of the queue. 

If you don’t hear from them soon, please private message me with the email account attached to your Webroot account.