Solved

Carbonite Keeps Asking for Full Disk Access

  • 29 September 2022
  • 6 replies
  • 56 views

Userlevel 7
Badge +22

I am running Carbonite  Safe CE 22.3 on a MacBook Pro M1 Max, running macOS Monterey Version 12.4 (21F79). About once a week, I am asked to grant it Full Disk Access permission. Except that it already has it. I see that Webroot Secure Anywhere went through this about two years ago in other threads. But I do not see a solution. Any ideas? Just to prove the point, here is a screen shot: 

 



 

icon

Best answer by MajorHavoc 28 October 2022, 03:17

View original

6 replies

Userlevel 7
Badge +4

I’ve yet to install Carbonite on the newer M1 Max chips but I'm having all sorts of other issues with multiple different services and apps with these M1 Max chips. So this might be another issue linked to the way these new processors work.

I can only think of 2 things I would try :

  1. Click the - button and remove Carbonite from Full disk access,. Restart the machine and then manually add it in again but pressing the + button, navigating to /Applications and adding Carbonite back in.
  2. Uninstalling Carbonite, then do everything listed in step 1.

Good luck, let me know if you get any luck.

Userlevel 7
Badge +22

Thanks Russel. I had already tried both of those.  As I work at Apple, I have filed a big report on this issue. Have not seen it for b other programs though. 
 

I’m guessing that something in the enhanced security prevents an app from asking if they have full disk access, so the response they get may be wrong, so they pop up an alert. Might alto be the protections on one or more files not set for access, so Carbonite thinks they don’t have access. 
 

Hopefully this will get worked out. Not a show stopper, but a bit annoying.  
 

Cheers

Userlevel 7
Badge +4

No worries. Be interested to know if you get a solution. 

Userlevel 7
Badge +22

Anyone from Webroot/Carbonite have anything to add? You must be aware of this issue?

Userlevel 7
Badge +22

This has stopped happening. I am not sure what changed, but it has stopped for now. 

Userlevel 7
Badge +4

🤷🏻‍♂️ Weird. Sometimes things fix themselves. Annoying though as it’s nice to know what caused it and what resolved it.

Also sometimes clients ask what you did to fix it and you feel like you need to provide an explanation!

glad it’s sorted though 

Reply