Question

Webroot Mac client deployment with Microsoft Endpoint Manager

  • 24 February 2022
  • 6 replies
  • 102 views

Hi,  

There is a related topic for a Window client.  Was hoping someone could help me with deploying the agent to Macs.  

Thank you,

 

 


6 replies

Looks like the script works and the agent gets installed.  The only issue I am seeing is that I am not able to open the client control panel.  The screen shot below is from a manual install.

 

 

Thanks for the reply.  I will give that a shot and let you know if it works.

Userlevel 2

Hi @goaljnky ,

I’m the product manager for the Mac business side and had a quick chat with the team about this. It looks like the Microsoft Endpoint Manager has an option to not run scripts as the logged in user. The management tool needs root privileges to do that so if you can find out how to set that up, this should be possible. If the agent winds up being installed by root to begin with (in other words, if you get that Microsoft Endpoint Manager option set up correctly) then it won’t ask for passwords at all when it runs into a sudo because it will already be root. You would, of course, need the password to be root for this to work.

Otherwise, you will need to know an admin user password for the endpoints you want to install on as our product requires that to install. There’s no real way around this, due to the nature of the product. That said, if your concern is that it will be prompting for passwords after the script is initially run, you can get around this by proactively sending the script command with a sudo and just send the pass at the start. Every instance of sudo thereafter will execute without asking for a password because of your recent successful sudo at the start of the script.

I hope that helps.

--

Jeremiah

@goaljnky @khumphrey  I’m afraid I don't have the answers to this one, we do have some information on deploying via script which may be useful though?

https://answers.webroot.com/Webroot/ukp.aspx?pid=12&app=vw&vw=1&solutionid=3901

 

Thank you.  I saw the script.  The problem is it has several sudo lines, which require an admin password.  So not ideal if I’m drop-shipping my devices to end users.  Unless there is a way to get around the password need.  Sadly, scripting is not my strong point.

Userlevel 3
Badge +1

@goaljnky @khumphrey  I’m afraid I don't have the answers to this one, we do have some information on deploying via script which may be useful though?

https://answers.webroot.com/Webroot/ukp.aspx?pid=12&app=vw&vw=1&solutionid=3901

 

Userlevel 7
Badge +19

Hey there @goaljnky ,

I’m going to ping a couple of our product experts to see if they can help you out.

@csaunders @Jeremiah Voris - Would either of you be able to help this user out? 

Reply