Definition Update Failed

Show first post

169 replies

Userlevel 3
That's exactly right Jim.  You can get an OOM error while having 100mb free if the garbage collector can not keep up with your requests.
So it is not a matter of requirements. 
My wife has a Droid Razr MAXX and webroot runs fine on it, so it is just some combo of apps installed or running and/or the version of the Garbage Collector that are still having the issue. 
I left WSA for another product a while ago, just after all this started and I'm now certain I was right to do so for my own sake.  The other product has as good a reputation as the Webroot product and it updates reliably.  So if memory management is the same for all Android applications which, of course, it is then I would have to assume that the product I am using is designed and coded differently to avoid such issues or, as you indicate, its developers are limiting the size of its threat register to avoid them by shedding some low risk definitions.  
If it is not shedding threat definitions and is dealing with the same range of threats as WSA, then it looks like it has managed the memory issue in a way that has eluded Webroot so far.   So far as I understand it,all  these security products rely on having a register against which to check for threats and, it seems to me, as the number of threats grows these registers are going to have to grow as well.  It could well end up as a race between these registers and the amount of system memory installed (and its management).  Sooner or later, a brick wall is going to be hit because memory can't be infinite while the number of threats could be in comparison.
WSA and its competing security products are, I guess, sooner or later going to have to undergo a root and branch re-think and re-design to minimise the dependence on an ever growing register/database of risk defintitions.  They are going to have to work differently.  Don't ask me how, I have not idea but it does seem to me to be an impending issue.  At the same time, it also seems that Android itself could do with a massive security overhaul.
I've uninstalled WSA from my phone and installed another provider. My experience of webroot has not been positive. While I believe that the developers etc are struggling to find a fix, me the consumer has been messed around. Being given the expectation that a fix is imminent only to find time after time that nothing has changed is frustrating to put it mildly. The reality is that I haven't changed my phone or operating system for 10months while WSA worked. I didn't have lots of apps working in the background. So something in WSA changed that led to the problems. Coupled with the fact that other apps work fine suggest that WSA is the problem. Having paid for this app, this is a poor experience. Even if I'm one of the very very few that still have problems...
Userlevel 7
We're sorry to see you go Jimbo. 😞 If a potential solution becomes available for the remaining affected users, we'll be sure to update this thread. In the meantime, you'd certainly want to have some protection on your device, so it make sense to do what you're doing for now. We'll continue to do everything we can to try to work around this issue. Just because it's affecting a small number of users doesn't mean we've given up on trying to solve the problem, but waiting for a fix in an unprotected state is inadvisable. So, you're doing the right thing for now. Hopefully we'll have some better news next time we post in this thread.
Userlevel 7
OK, after having monitored behaviour of WSA for a few days on my HTC in relation to definition updates and the OOM error I can draw the following conclusions.
The OOM error occures once a new definition set is released. It means that if there are let's say 2 days before another new definition set is out I am not getting the OOM error. I can check updates manually thousand times and no error observed. However when a new definition set is available I always am getting the OOM error. So it is the sign for me that a new AV definition has been released. So I have to go to Applications Manager and terminate WSA. After that I have to open WSA what triggers WSA to restart. Immediately after restart the orange exclamation jumps out and the definition set is always 373. Afterwards I have to run updates manually what successfuly loads the latest available definition set (today it is 391). Since then I don't have the OOM errors (when checking updates) until a new definition set is released. It is 100% reproducible issue on my end.
Then I have to do all this procedure again to get the latest AV set what makes me indeed mad. This time is tough for me as I am full of temptations to throw out WSA in favour of Avast mobile. Nevertheless later, after having back the green status and a cup of coffee I am fine. I keep WSA yet on my phone thanks to my immense loyalty to Webroot but you, at Webroot, don't rely that this will last forever.
I hope that the above detailed explanation how the OOM error reigns over my HTC will help Webroot techies & developers (Jim & Roloc) to resolve this nasty bug and yes it is a bug regardless what you say.
Userlevel 7
The story continues ...
Yesterday WSA auto updated to AV set 391. It was the first time when it was done automatically without necessity to undergo terrifying terminating/restarting procedure stated in my above post. However today WSA automatically checked for updates (observed notification Last checked for definition update on 22.11.2012 at 7:50) and reverted definition set to 373. It seems that this AV set plays an important role in this OOM error issue. I have checked the web console and again there was last definition update before 42 years. Funny thing, indeed. So then I manually run update and received AV set 393 what is now correctly recorded in the console.
Sorry for bothering with my posts in this thread but I want to give Webroot staff as many information as possible. On the other hand I would appreciate Webroot breaks its silence and begins to again communicate via this thread or PM.
Userlevel 7
@ wrote:
There will be improvements in version 3.1 that may help to address the remainder of the OutOfMemory issues still being experienced.  3.1 should be available soon, but we don't have an exact date since Google still has to go through their QA process.  Roloc or I will reply back again when it's out.  :)
Thanks Jim for the update. Eagerly awaiting 3.1 build that hopefully will resolve the OOM error.
I also have this problem now.  Starts with "Definitions Update Failed".  After clicking through 'fix now', i get a 'network error attempting to access the Webroot servers".  I have verified i'm connected to the internet.  Suggestions?
Userlevel 7
@ wrote:
I also have this problem now.  Starts with "Definitions Update Failed".  After clicking through 'fix now', i get a 'network error attempting to access the Webroot servers".  I have verified i'm connected to the internet.  Suggestions?
Hello lynchrt and welcome to the Webroot Community Forums!
Can you kindly revert with result after upgrade to the latest version ( from the Google Play as Mike suggested? We would like to monitor whether the OOM error has been resolved for all devices. If the upgrade doesn't resolve it for you, could you inform about your Android device?
Thanks & regards,
Userlevel 1
I started getting these OOM errors around a week ago with the WSA Complete app. My last successful definitions update was 468. Before this, it worked fine on my HTC Desire 2.2, even if the phone was fully loaded with other apps.
I've tried everything. I even did a factory reset on my phone and reformatted the SD card, and installed the app again. Now the current definitions are 464 and utdates fail with OMM errors. 
There is only one other third-party app on the phone now, and available RAM seems to be around 100MB + 185MB.
I suspect it has something to do with v. released on March 5.
What a novice like me do find a little strange, is that the amount of RAM the WSA app is using is varying from 15MB to 85MB when the phone is passive (just being monitored).
(What's even stranger, is that nobody else is mentioning this. Do they just uninstall the app and never look back?)
Userlevel 7
There is a mobile update due out on Monday if all goes according to plan. Let's see if the issue persists following the update please. 🙂
Userlevel 1
Will do. Thanks!
Userlevel 7
Thanks for the confirmation Anders! 🙂
Unfortunately, my phone is having this problem again and it won't clear itself like it used to when I run a scan. Please help (see user name). 
Userlevel 7
Hello Frustrated, 
Have you tried to uninstall and then reinstall?  That sometimes helps update problems.  Let us know if that works, as others may have additional ideas and you can also Submit a Trouble Ticket as well.
Userlevel 7
The uninstall/reinstall suggestion or forcing a definition update will most likely resolve the issue.
Force Definition Update: Open SecureAnywhere>tap Security>tap Antivirus>tap Schedule>tap Force Definitions Update Now
Thanks - but it appears that when I renewed, Webroot did not renew my phone. I have submitted a ticket and hopefully this will be resolved quickly.
Userlevel 7
Did you renew to a new suite? For example, from Internet Security Plus to Internet Security Complete? I only see the Complete subscription and if you upgraded the keycode it should have automatically mirrored the new days onto the mobile Complete app.
When I renewed, I assumed my coverage (SecureAnywhere) would continue without any changes. If you notice in my records, the Samsung Galaxy phone is covered, and my HTC should be covered too, because it was previously covered.
I did not add any coverage, nor did I cancel any devices. I merely renewed my contract. I have always had two phones and my computer registered with you.
Please take care of this.
Userlevel 7
They are definitely covered under your Complete subscription. Just open the SecureAnywhere apps and tap register to make sure that they are using the keycode that I just sent you in a private message.
That is the correct keycode and it matches the one I have on my pc as well. I tried using the button on my web console that shows I need to renew my HTC phone, and when I entered the keycode, I got a message that that keycode was already in use.
Not sure what to do now...
Userlevel 7
You can do a fresh uninstall/reinstall of the Complete app on your HTC device and use the keycode that I sent you via PM. Also, the sales number is 1-866-612-4268 if you would like to see if the seats can be adjusted for you. 😃
I uninstalled and reinstalled the app (deleted the device, then added it again as a new one) and this solved the definitions update problem.
I will call the sales number you gave me and see if they can remove that "trial" keycode that shows I still need to renew/update my phone. I don't have any idea where that came from but obviously I don't need to renew that expired keycode.
Thanks for your help.
Userlevel 7
Thank you for the update - I am glad that worked. I removed the trial keycode as well but you can still contact sales to discuss how many seats you would like.
im also having this problem cant update and getting the same message as post 1 here can you help please ???