Definition Update Failed

Show first post

169 replies

Userlevel 7
Hello blueyestim and welcome to the Webroot Community!
First of all, you should try the quickest workaround which helped other users. I mean a clean reinstall of WSA (from Google Play) on your Android device and revert with result.
i tried that and had to remove it again was killing my batt. trying to update was just setting trying so i do not have it installed right now waiting on your reply before i reinstall
Userlevel 7
Hmmm, it's less likely that WSA would be killing battery. WSA is extremely light on resources and batteries. If you're using WSA Premier or Complete, please install it back and go to Battery Monitor under App Inspector where you can check which applications are draining the battery most. If you're using Free version you don't have this App Inspector available and you would have to download other free tool from Google Play which can monitor battery usage.

BTW, what version of Android do you have on your device? Just pondering, how old your battery is? Can't be in the end of its life?
i think it was killing batt from trying to update it would start and get maybe 10% and then just sit trying and trying never timed out or anything i let it try for over 4 hours after i uninstalled it my phone is now ok no more problems with batt..  ok i reinstall and its doing the same as before will not update only this time its not timing out its just keep trying to update until it kills batt. cant cancel or stop it just like its looked up trying but yet i can still use my phone go back to look at webroot and its still trying to update HELP  please i had a paided ver. of the software 
Userlevel 7
Thanks for the feedback. There is really happening something wrong on your device. I suggest you to open a support ticket and pass this issue directly to support. Maybe Mike (Moderator) can have another clue.
i have reinstalled it 4 times now and techs are now trying to find the problem anyway even with a reinstall it just will not download the update
Userlevel 7
Hi blueyestim,
Thanks for trying the solution and I am sorry to hear that you're still having the issue. That said, you're in good hands and I'm glad the support agents are helping you out via the support system as our Community/Social Media support hours are not 24/7 and our coverage is limited on the weekends. However, please update this thread after you have more info from the support agent and please let us know if you're still having problems.
Userlevel 7
Checking in on the support case, it appears blueyestim's issue was resolved by cleaning up some old, non-webroot files off his sd card. That would indicate that it probably wasn't an update Webroot was hung at, but rather a scan, and that Webroot was getting stuck on a corrupt file.
Userlevel 7
@ wrote:
Checking in on the support case, it appears blueyestim's issue was resolved by cleaning up some old, non-webroot files off his sd card. That would indicate that it probably wasn't an update Webroot was hung at, but rather a scan, and that Webroot was getting stuck on a corrupt file.
Jim, this is not the first case when it turned out that such problems are caused not by WSA but in fact by corrupted files on a SD card. So, what about writing a knowledge base article pointing to check SD card files in the first instance before passing on to support.
Userlevel 7
Good idea Pegas. I'll do that. 🙂
Userlevel 7
Thanks Jim and sorry for making up additional work for you :$
I am having the same problem for weeks. I am receiving the same error message even when connected to my wi-fi network or through 3G.  Also I can't update via the play store. My phone is a Galaxy S3. Can someone help me? I have a lot of free space on my phone too!
I am having the same "Definitions Update Failed. Network error attempting to access the Webroot servers". I haven't been able to update for weeks, trying to update using my wi-fi and 3G. I have a Galaxy S3 full of empty space of storage. Also I can't update on play store. Can someone help me?
Userlevel 7
HI grinfocus and welcome to the Webroot Community!
Unless I am mistaken, that phone runs on Android 4.0  I know that OLD versions (2.2 like I have) are no loner supported, but there should not be a problem for yours.
You may want to submit a Trouble Ticket for a bit of troubleshooting.  Normally I would suggest uninstalling and re-installing, but if you cannot access the download in the Google Play store that may not work.  Is it a case of it does not show up in Google Play, or simply it is listed but no updated version available to install?
Webroot is on google play but there in no update button there. And yes my android is 4.0. Should i uninstall my webroot and download another mobile premier webroot?
Userlevel 7
You might try that.. except for downloading the Premier, you can download the Free Version  It should activate as the Paid Premier version when you use your Premier key code.
Keep in mind, there might not be an update available.  Webroot does run differently than other solutions and so it does not need new difinition updates as often as others do.
Userlevel 7
Check This Topic for Android version releases.  It has been quite some time since the last release I believe
EDIT: Link changed to newer release notes
Userlevel 7
Hi grinfocus
I'm using a tablet that only use wifi and its not updating
I'm interesting if will be any different answers for the problem - or will not? if YES, how soon it will be?
Userlevel 7
The logs you had sent did not reflect the errors reported. They were probably gathered too far after the issue occured. When collecting logs, it is important to gather them immediately after recreating the issue and after you receive the errors. I will be sending you another set of instructions on how to reset the definitions via Private Message.
If that does not solve the issue, you will need to send another set of logs immediately after recreating the issue.
Collecting Mobile Logs:
1.  First, replicate the issue you have been experiencing.  Be sure to do this immediately prior to carrying out the rest of these steps.
2.  Open the Webroot SecureAnywhere Mobile application.
3.  From the main screen of the Webroot app, tap the Android Menu button.
4.  Tap General Settings.
5.  Tap Support Options.
6.  Tap Collect and mail logs.
7.  Mail these logs to the email address that I send you in a Private Message
I'm also having this issue "definition update failed" where do I send the logs to?
Userlevel 7
Hi Jimbo,
Mike's out of the office today, so please send the logs to me. I'm going to provide you with the email address to send them to via private message.
Also, the original question asked  by Mike about whether this happens over both cell data and wifi connections is still relevant.  Please try on the other if you've only tried on one.  It should work on both, but if not, we'd still like to know.
Userlevel 7
Very interesting!
I was working with Jimbo via private message after receiving the logs, and I meant to check back in here with the results once we knew what the solution was.  However, after I sent a list of suggestions, I never heard back to know which one ultimately helped him out.
Here were my suggestions:
1. It could be a corrupt definitions file.
Uninstalling and reinstalling the app would clear the definitions.  So we can try that.
2. It could be an issue with the network connection.
Does this happen over ONLY your data plan or ONLY wifi to a router?  Please try the other connectivity method and let us know if it works or not.  It should work over both, so if it's only working over one and not the other, we need to know so we can look into fixing that for you.
3. It could literally be an issue in which the phone is out of memory.  You could try killing some unneeded services.  Anything that you see running at the top left side of the phone that is always on is using memory, so try closing some of that stuff and updating the definitions again.
Number three in my list of suggestions comports well with your own solution.  I don't think it's the storage space you freed up that made the difference (our definitions files are tiny / less than 5K), but rather that in uninstalling a bunch of stuff that was probably running in the background, it freed up resources so the update process itself could take place.
Thanks for posting the solution that worked for you!  🙂
From the last update of the program, I'm not able to update the definitions of WSA Mobile.
When I try to update, the program tell me that I don't have internet acces, which is not true, because I have both WiFi and 3G.
After that I get an error: "OutOfMemoryError processing def update". I check the memory of my phone (HTC Wildfire S) and I have 25Mb free, so I think is not a problem of the phone.
Is there a problem of last update of the program?