Definition Update Failed

Show first post

169 replies

My Sony Ericsson phone updated new definitions today.
I am also having this issue with the error "OutOfMemoryError processing def update"
Phone is a Motorola Droid X  As of right now there is 106MB RAM free
6.01GB free on storage
I have done the folowing:
Shutdown phone, removed battery and restarted - No effect
Removed the App and re-installed - No effect
Removed other apps from phone - removed Webroot app and re-installed - No effect
Just as a note...
I have the same app running on my Motorola Xoom with no issues.
Please help!
Userlevel 3
I would like to clarify.  This is an out of memory error, the amount of space you have on your SDcard or internal storage is not the same as the amount of memory being used.  Not installing updates or otherwise clearing up disk space will not effect the amount of memory that has been used.  The amount of applications you have running at one time will.  
If you stop other applications from running by going into apps and either uninstalling or preventing it from running at a service this will work as a temporary work around in some cases.  
Otherwise the fix is coming and will be out sometime next week. 
I started this thread and the problem has come back despite now having 35-40MB spare. It is also affecting other functions and Apps. My clock and alarm is affected, working intermittently. I set Webroot for auto update on Google Play, to see if that might help. It didn't and also succeeded in turning every App to auto update. which then started downloading all the other App updates I've avoided because "Webroot needs the memory." So had to go back in and manual turn them all back to manual update.
- My renewal is coming up, and if not fixed ASAP my I'll delete Webroot from my phone and PC and go to another product.
That happened to me after updating the program from the google playstore.  Searching for another program to use.
Userlevel 3
In one sense yes it is because of recent updates but probably not how you mean.  It is happening because our definitions get bigger with every virus that we find, thus it could happen to any user at any time who just happens to be running low on memory.  Keep in mind "low" is a very relative term in this case.
The good news is we have a fix in for this today and it is going to our QA team as we speak.  It will be in our next release which should be sometime next week.  
Again I apologize for this issue and we are as anxious to see this resolved as you are. 
If anything changes I will keep you posted.
Is it possible that recent uppdates to Secure Anywhere have resulted in these problem?  I ask this because these problems are a recent change - the program had previously working fine.
While Webroot are trying to fix this, is it possible to roll back to an earlier version in the meantime?
Just thought I would ask!
Hello again YegorP!
Thanks for the reply and the offer of further help if necessary.  So ...
The crash on startup problem is persisting I'm afraid.  Basically, every time I start the phone (Motorola Defy+ using Android 2.3.6), I get the message:
"The application Webroot SeccureAnywhere Mobile Premier (process has stopped unexpectedly.  Please try again"
I click "Force close" and the application appears to re-start itself OK but then, as you know, I have the update problem.  I assume that, after re-starting itself, Secure Anywhere is working as intended and providing protection but I have no means of checking.
Thank you  :)
Hello, I am having a similar problem as blueskyabove webroot mobile crashing and restarting on its own as well as not updating  definition.  I have tried all the recommend action on post with no fix. Could you please update use on the solution to try. Thanks
Userlevel 7
No problem blueskyabove! Again, I do apologize for the delay and will update you as soon as I know more!
In the meantime, please let me know if you have any other questions I can help answer.
Hello YegorP.
Thanks for the quick reply.  It's helpful to see that other people are having the same issue and I completely understand that you are working on it as a matter of urgency so I'm happy to wait.
I've had one crash since reinstallation but I'd like to leavee it for a while to see if that was a on-off before asking for help with this.
Thank you!  🙂
Userlevel 7
Hi blueskyabove,
Welcome to the Webroot Community forums.
I'm sorry about your frustrating experience with the definition updates. As you can see, some other users are having similar issues as well. Unfortunately, at the moment there isn't an immediate solution. However, as Mike mentioned in the previous post, our mobile team and developers are diligently working to get this issue resolved ASAP. In fact, it's their top priority right now. Please continue to be patient and we will let you know as soon as the fix is in place.
Regarding the app crashing, have you since tried uninstalling and reinstalling the app to see if that resolves (at least) the crashing bit? Let me know and I'll assist you accordingly!
I'm getting similar update problems.  I have reinstalled, transferred as many apps as possible to the SD card but Secure Anywhere continues to misbehave.  When I try to update I get either a prompt about not being able to connect to the web (although wifi is working fine for email and browser) or, if I use "Force definitions update now" I get:
"Webroot failed to update the threat definition.  The following error was encountered:"
Also, Seecure anywhere has started crashing and restarting itself as the phone boots up and sometimes crashes when I am navigating through its menus.  This is a recent development.
I would appreciate some advice and/or help please!   🙂
Userlevel 7
Hello everyone,
Our developers are hard at work on new definitions and memory management methods. I apologize for the delay but the testing for the new definitions and memory management is now underway. Please be patient while they are tested and I will update the thread as soon as they are released and if there are any new workarounds.
It is totally unacceptable not being able to update new definitions. What is the point of the programmme if it's not kept up to date, and meanwhile our mobiles are vulnerable to attack.
I experienced the same error message and related problems after I updated the program from the  android play store.  I have plenty of internal and external memory.  I am using the Motorola Razor Max with Android 4.0 OS.
I have tried uninstalling the program several times along with clearing the cache files.
Outside of uninstalling and looking for another program not sure of what other options are left.
Any suggestions would be greatly appreciated.
Thanks for your time with this matter.
I desagree that the phone Error OutOfMemory has been solved. It has not. I suspect that the phone was arrested by the Internet Program Developers. The narrow memory may works as like as time ago for too long encryption process or three-way-man-on-a-middle; I checked the Services and it has the active services for Googles Market and for facebook uploads even it is not presented now. Also, I have too many pictures in my phone and clip for 30 minutes I made while I was visiting the Russian Consulate in New York City. i tried to publish it in Youtube, but they told me I can have the only 20 mibutes clip; i needed it to show how is it hard to get the Consul assisstance for Russian and how it is easy to have the Russian sexual trafficking in New York City for counter intelligence ABUSERS OF DISCRETION. I tried to EDIT the clips from phone but the free Microsoft software erased the sounds file in my computer and I need to hold the 30 minutes clip in the phone memory or I cannot have it at all because of COPYRIGHT ABUSER from Internet Program Developers system. Actually, it is the New York City government psychiatrists, probably, who use to distribute the sexual offers in a half way legally - in new York and New Jersey. Also, they may be the private corporation eather, but they have their COPs cover anyway. They use to program the problems, and I cannot unload the droid memory SD card, so, the extra memory spent for the movies from New York Consulate - the 34 minutes, and the pictures, but the FBI abusers never stop. The ABUSE OF DISCRETION needs to cover the sexual trafficking conditions of America for more that 10 years. After I came back from Russia in 2011 where I tried to study in Economics Institute in October in Moscow, I lost all my files with documents I had fo UN claim; they also erased the backups and memory cards. Actually, I lost my BitLocker key or it was redeveloped or reprogrammed to be unlockable  So, I couldn't have the documents in backups and in computer - they erased it in the Fall 2011. So, I cannot erase the Facebook account with the backup pictures for the United Nations Claim, for the Attorney General Claim, for the Russian Presidential Room claims... So, the Facebook got used for American psychiatrists who need the Internet developing to set me up for paranoya. (I have no idea, may be Reception Room for Eric Holder Professional Responsibility Office was involved in that eather - I made they call and complained, or may be the CIA offisers did it - anyway I lost my work from 2004 to claim in 2010). Then, they began to make the too much encryption and it began too many services in the Droid Operative Memory at the same time. It works as like as the Denail Of Services attack. So, thephone get overloaded. The time for WebRoot Services looks like take forever connection to their Server. Then, If it got connection and update, it is too slow. Then I tried to freeup the Memory, the stop Services, the flash update file or erase everything from SD Card. I tried to get the Advanced Menu for WebRoot and flash the update file or the current scan. Nothing may help too much. I understood, i pay for the phone less then cheap. But I have no money at all. I set in Social Services, and I got deep into College phylosophy to have just one time a day breakfast or lunch. If I would have a little money I may buy the new phone, or the best 4G network Apple or something as like that but I have the only that one. And I have no INCOME for today. So, how can I fix the ROOT problem on my phone?  Should I erase everything from my phone another time or it will not help? I uninstalled and reinstalled the WebRoot several times already. I had the Update reinstallation. I have no idea what I can improove. And I do not think that was the SOLUTION for the old phone. Of cause, I cannot have the instant web access to the Internet, but i used that phone for year and it began be broken the next year. I bought it for 200 dollars. And it is very pity to lose the phone at all.
 I like America sometimes, but sometimes I see the "milky cow" market items and that extort me to through money in the unexpected quantaties. Should I apply for Congress right away, or may be through the phone????? or it may be the real way to get network without paranoya and guesses for?   
The Phone memory has the encryption which holds it in the overloadings.The Droids need more memory for extra encryption??? they better stop use the Root access for the three-way-services. The govs abuse to control the phone for no reason evesdroppings as like as the domestic spy abuse. 
Userlevel 3
this needs to be fixed asap,what good is it if i cant update it.this is unacceptable.
Hi, I can not update my definitions either and it's giving me mixed messages. Help please?
Userlevel 7
Please refer to this post on Definition Updates and an update by one of our developers on why there are currently definition issues.
Definition Update Failed
 Combined post with the Definition Update Failed topic
Userlevel 3
I to am getting this
My Adroid phone tells me I need to update Webroot, but then tells me there is no internet connection, but there is, as I can access websites and emails. I have to re-boot the phone several times to get automatic definition updates.
Userlevel 3
As I mentioned we are hard at work on a fix for older phones or ones with very little memory.  Remember just because you did a wipe does not mean that no other programs are running, the Android opperating system takes up a good chunk of memory itself as well as any other applications that get shipped with a phone which depending on the carrior you use could be substantial. 
As an example my sister has a phone much like yours that out of the box has only 1% memory free.  
In other words, I understand your frustration and we are working on it.  When we get a solution that works for everyone from slow phones to fast we will let you know!
Helo Roloc,
I've tried everything but still not work.
Even I give a "format factory" to the phone. After I install Webroot Mobile as first and only program, I receive the same message as before: "Out of memory..."
In that case I think that the program became useless
Userlevel 3
I just wanted to drop in and let you all know we are looking at ways to improve memory management in the future.  In the next release which is currently slated to come out in a week or so we will be releasing some improvements in memory usage around definition updates.  
The reason this was working and is now causing issues is that our definition files grow over time as we find more viruses out there.  This has outpaced the memory in phones over time so we require a larger chunk of memory now than we have in the past.  Some of you with older phones or that have a lot of applications running that take up memory will begin to see this issue.
As others suggested in here general healthy cleanups of your phone is your best bet to not run into this issue in the meantime.  Things like uninstalling apps that you don't use anymore that may be running background services.  Periodically rebooting your phone will help clean up other apps that may be consuming memory that.  Remember that just because you don't see it doesn't mean it isn't running.  Use the App Inspector that is included in our pay products or the built in Android Apps list and look under "Running" to determine what is actively using memory that you may not want.  
I could go into a long rant about Java, Linux and memory utilization but I think that is best left for another day.  For now, know we are hard at work on better solutions in future releases and we will keep you posted as those become available or if there are any other work arounds.
Thank you,