Definition Update Failed

Webroot failed to update its threat definition. This likely means your device doesn't currently have internet access. You can continue your scan with the current definition set or cancel. Error: OutOfMemoryError processing def update. Continue or Cancel.

Also, DEFINITION UPDATE FAILED. Network error attempting to access the Webroot servers. Please ensure your device is connected to the Internet.

Also, Webroot Secure Anywhere Mobile Premier (process com.webroot.securing full) has stopped unexpectedly. Please try again.


Is somebody know what to do??? The HELP recommended to post on FORUM to get E-mail from MODERATOR to send collected system data from phone for tech support. Or may be it would be solved by itself??? For example, via updates?? But how come, the updates fail to be installed?

Best answer by MikeR 5 August 2013, 18:34

View original

169 replies

Userlevel 7
Please uninstall and reinstall the "Paid" version of the app as TripleHelix has suggested. Also, I see an error for an invalid username on the back end. Please use the email address and keycode I have sent you in a private message when typing your credentials into the app.
Userlevel 7
Badge +56
Hello oneil31 and Welcome to the Webroot Community Forums. 

Are you using the free version? If you are please uninstall the App and go to Google Play and reinstall even if it's the paid version make sure you install the correct one please look at this TKB article:
I'm using a tablet that only use wifi and its not updating
Userlevel 7
Hi grinfocus
Userlevel 7
Check This Topic for Android version releases.  It has been quite some time since the last release I believe
EDIT: Link changed to newer release notes
Userlevel 7
You might try that.. except for downloading the Premier, you can download the Free Version  It should activate as the Paid Premier version when you use your Premier key code.
Keep in mind, there might not be an update available.  Webroot does run differently than other solutions and so it does not need new difinition updates as often as others do.
Webroot is on google play but there in no update button there. And yes my android is 4.0. Should i uninstall my webroot and download another mobile premier webroot?
Userlevel 7
HI grinfocus and welcome to the Webroot Community!
Unless I am mistaken, that phone runs on Android 4.0  I know that OLD versions (2.2 like I have) are no loner supported, but there should not be a problem for yours.
You may want to submit a Trouble Ticket for a bit of troubleshooting.  Normally I would suggest uninstalling and re-installing, but if you cannot access the download in the Google Play store that may not work.  Is it a case of it does not show up in Google Play, or simply it is listed but no updated version available to install?
I am having the same "Definitions Update Failed. Network error attempting to access the Webroot servers". I haven't been able to update for weeks, trying to update using my wi-fi and 3G. I have a Galaxy S3 full of empty space of storage. Also I can't update on play store. Can someone help me?
I am having the same problem for weeks. I am receiving the same error message even when connected to my wi-fi network or through 3G.  Also I can't update via the play store. My phone is a Galaxy S3. Can someone help me? I have a lot of free space on my phone too!
Userlevel 7
Thanks Jim and sorry for making up additional work for you :$
Userlevel 7
Good idea Pegas. I'll do that. 🙂
Userlevel 7
@ wrote:
Checking in on the support case, it appears blueyestim's issue was resolved by cleaning up some old, non-webroot files off his sd card. That would indicate that it probably wasn't an update Webroot was hung at, but rather a scan, and that Webroot was getting stuck on a corrupt file.
Jim, this is not the first case when it turned out that such problems are caused not by WSA but in fact by corrupted files on a SD card. So, what about writing a knowledge base article pointing to check SD card files in the first instance before passing on to support.
Userlevel 7
Checking in on the support case, it appears blueyestim's issue was resolved by cleaning up some old, non-webroot files off his sd card. That would indicate that it probably wasn't an update Webroot was hung at, but rather a scan, and that Webroot was getting stuck on a corrupt file.
Userlevel 7
Hi blueyestim,
Thanks for trying the solution and I am sorry to hear that you're still having the issue. That said, you're in good hands and I'm glad the support agents are helping you out via the support system as our Community/Social Media support hours are not 24/7 and our coverage is limited on the weekends. However, please update this thread after you have more info from the support agent and please let us know if you're still having problems.
i have reinstalled it 4 times now and techs are now trying to find the problem anyway even with a reinstall it just will not download the update
Userlevel 7
Hi blueyestim,
First of all, I'm sorry to hear you're having this issue-it's quite out-of-the ordinary as this definition update failed issue has pretty much been resolved (and the thread has stayed quiet recently) for all but a very few individual cases (with yours falling under this category).
*I looked up your account information and everything does look fine in our system-you do have the paid version and there are 299 days remaining in your subscription.*
Pegas is right in that submitting a support ticket is probably the best way to go about this issue as mobile logs may be required to pinpoint the cause of the update hanging up and killing the battery.
That said, before submitting the support ticket, I would like for you to try a fresh uninstall/reinstall one more time. This time, instead of doing an un/re from Google Play (which I presume is what you've been doing based off Pegas' suggestion), please try uninstalling from the WSA app itself. Open SecureAnywhere, tap your Android Menu button, tap "Uninstall", enter your password to uninstall the app. Afterwards, go back into Google Play and reinstall the app. After it is back on your device, please go back into the app, tap the Android Menu button, tap "About". You will then see some info displayed. Please confirm that you're on the newest version ( Also, can you tell me exactly what make and model device you are having this issue on?
Let me know if this solution changes anything/resolves the issue. If not, please follow the aforementioned link to submit the support ticket.
Thank You!
Userlevel 7
Thanks for the feedback. There is really happening something wrong on your device. I suggest you to open a support ticket and pass this issue directly to support. Maybe Mike (Moderator) can have another clue.
i think it was killing batt from trying to update it would start and get maybe 10% and then just sit trying and trying never timed out or anything i let it try for over 4 hours after i uninstalled it my phone is now ok no more problems with batt..  ok i reinstall and its doing the same as before will not update only this time its not timing out its just keep trying to update until it kills batt. cant cancel or stop it just like its looked up trying but yet i can still use my phone go back to look at webroot and its still trying to update HELP  please i had a paided ver. of the software 
Userlevel 7
Hmmm, it's less likely that WSA would be killing battery. WSA is extremely light on resources and batteries. If you're using WSA Premier or Complete, please install it back and go to Battery Monitor under App Inspector where you can check which applications are draining the battery most. If you're using Free version you don't have this App Inspector available and you would have to download other free tool from Google Play which can monitor battery usage.

BTW, what version of Android do you have on your device? Just pondering, how old your battery is? Can't be in the end of its life?
i tried that and had to remove it again was killing my batt. trying to update was just setting trying so i do not have it installed right now waiting on your reply before i reinstall
Userlevel 7
Hello blueyestim and welcome to the Webroot Community!
First of all, you should try the quickest workaround which helped other users. I mean a clean reinstall of WSA (from Google Play) on your Android device and revert with result.
im also having this problem cant update and getting the same message as post 1 here can you help please ???
Userlevel 7
Thank you for the update - I am glad that worked. I removed the trial keycode as well but you can still contact sales to discuss how many seats you would like.
I uninstalled and reinstalled the app (deleted the device, then added it again as a new one) and this solved the definitions update problem.
I will call the sales number you gave me and see if they can remove that "trial" keycode that shows I still need to renew/update my phone. I don't have any idea where that came from but obviously I don't need to renew that expired keycode.
Thanks for your help.