RAM Usage?

  • 15 May 2013
  • 9 replies

Webroot is using a ridiculous amount of memory on my device and I can't figure it out. I'm running on a Samsung Galaxy Note 2
I've seen it go as high as 70 MB while no scan is taking place. Currently it's at 50 MB just idle, no scan.
I've tried re-installing multiple times, but I get the same results. I'm installing the free version, however I have a security plus subscription so I've also tried activating it on the free version and it enables extra shields, but memory usage remains high. The memory usage is high regardless if I active the security plus features or not.
After a reboot I notice Webroot starts off at 20 MB and it feels like every 5s I notice it climb 1 MB in usage and it just keeps going up and up.
Note, I also opened up a support ticket, but I'm getting no where with the ticket. I keep getting general information on battery usage. I haven't once spoken about battery usage, so it's frustrating when you contact support and all you get is company lines on battery usage. I hope this community/forum can provide some insight on the memory usage.

9 replies

Userlevel 7
Badge +56
Hello alamarco and Welcome to the Webroot Community Forums.
I'm not familiar enough to help you with Android issues but I'm sure someone will be by to help you I just wanted to say hello.
Thanks for the welcome, hopefully you are right. :)

The low memory usage of Webroot on my PC is one of the reasons I love Webroot. It's why I'm shocked to see it so high on my Android device.
Userlevel 7
Badge +56
I'm sure if not tonight they will tomorrow:
7AM to 5PM MST, Monday through Friday
9AM to 6PM MST, Saturday
10AM to 7PM MST, Sunday.
TH ;)
Userlevel 7
Hello alamarco and welcome to the Webroot Community!
I wish I had the answer for you, but I also just wanted to give you a welcome!  I will be watching this thread to see how it is resolved!
Userlevel 7
Hello alamarco and welcome to the Webroot Community!
WSA is using cca 80MB on my HTC Desire S which is comparing to the latest best smartphones a quite underperforming device but I don't have any performance issues. Yes, I agree 80MB is quite a lot and WSA is the the biggest RAM eater on my device, the second one is Viber that uses max. 22MB and the rest of applications uses below 10-15MB.

In the light of above, can I ask you ... are you experiencing any performance or any other issues on your Note 2 being caused by the used RAM or are you just upset that WSA is using quite a big slice of RAM, in your case 70MB?
Userlevel 7
How many running apps do you have alamarco? I have a Galaxy Note 2 as well, and it's using only 22MB on mine. However, mine is almost brand new and doesn't have much loaded on it yet. What is loaded doesn't run all the time. I could see how, if for instance you have many more apps always running, Webroot has to do more to protect the device, and would thus consume more RAM since it's doing more with more processes. This is somewhat speculative on my part, but it would be a good test to kill other running processes to see if Webroot subsequently drops in RAM usage. Let's see if that helps.
Good to see I'm not the only one who noticed high usage.

During normal phone usage the 70 MB isn't a lot, but you notice it when you watch a movie or play a game. If you try and run a program that requires a lot of resources, something that takes up 70 MB becomes a problem.

Just because a phone may have 2 GB of memory, doesn't mean an app can be careless with memory usage. If all apps were like that not even every day usage such as web browsing would be smooth.

I'm not running very many other processes. Besides the stock processes I'm only running the following:
- WhatsApp
- Sportsnet
- TuneIn Radio
- Swype

That's only 4 programs.
Userlevel 7
Alamarco, I've just sent you a private message explaining how to get logs from the device, which should provide some insight into the higher than usual RAM usage.  We'll look into it and see if we can help once you send the logs.  Thanks!
Userlevel 7
We had requested logs in this case, but unfortunately we never received them.  Was this still an issue you wanted to continue to troubleshoot @ ?