renewed subscription for android but keep getting request to update

  • 23 May 2022
  • 7 replies

get an note important update available from secureanywhere.  I click on continueit takes me to get the new app, i click on that shows webroot mobile security.  I select open, then get the option to uninstall old app.  I select that and say ok to unistall app, it doesn’t do anything just sits there

7 replies

Userlevel 7
Badge +23



Everyone on the older android version <6.0 will be upgraded to at least 6.0.

If you have any issues with this upgrade please reach out to support by creating a ticket or over the phone

Userlevel 2
Badge +5

same problem as reported 3 days ago to which I have received NO answer. I keep getting alerts on my phone from Webroot that I need to update but as previously described (see next) the update process doesn't work.

trouble tkt from 5/23:

i got a msg on my cellphone that my old webroot secure anywhere needed to be updated, so i tried to follow the directions but ran into problems. first it said the old version needed to be uninstalled so i selected uninstall and ok but it kept looping back to the same question, so i manually uninstalled it. then got the new one in but it kept saying the old one needed to be uninstalled and when i said ok it said it couldn't find the old one and looped through this sequence. then i managed to get it sort of started but it said my subscr1ption was about to expire, however i know from my desktop webroot that my subscr1ption goes until november. also it asked for a new keycode -i tried my existing keycode, didn't work; tried the new one that the update/install had given, that didn't work either. so i supposedly have webroot on my phone but it doesn't work.

Userlevel 7
Badge +63

Hello @johnvel 


Uninstall the older v5 version and install the v6 version from Google Play: you will need the credentials from your online account  Webroot Identity Portal



I don't think you are listening to the users issues.  I'm having the exact same issues. He said he manually Uninstalled and reinstalled as you suggested ( and I did the same thing) still getting a message stating I need to upgrade. Fix this or provide an actual solution!

Userlevel 2
Badge +5

For what it’s worth, I gave up on Webroot for my phone, installed bitdefender instead. Seems OK so far. I’m still using and plan to keep Webroot for my desktop.

Userlevel 7
Badge +63

Hello @Patrick4250 


See here as Webroot posted an article on how to upgrade:


And @johnvel  we mods are Volunteers and at the time there was no info but there is now!



Userlevel 7
Badge +23

Thanks @TripleHelix 


For those wondering why they still see a notification its because you have yet to uninstall that older app. Have you seen this specific FAQ in the link provided?


Why can’t I uninstall the old Webroot Mobile Security App?

Webroot Mobile Security App uses the Device Administration permission for a few requirements. If the app is linked to your Device Administration Configuration, then you cannot uninstall the app until you Deactivate it from the Device configuration.
To do this please go to your Device Administration Settings> uncheck the SecureAnywhere App from the list >Deactivate the Device Administration and then try to delete the old app.