Trouble upgrading Webroot Mobile Security on Android S22

Userlevel 1

Sent a support ticket 9 days response. After a long wait on hold today I finally got through to someone that verified what I suspected. There is a BUG they are working on specifically with Android Version 12 UI Version 4.1. There is no information on when this BUG will be fixed. 

I hope this post will help or save you some time if you are encountering the same issues. 

10 replies

Userlevel 7
Badge +22

Thanks for sharing @rorowlands 


I looked up your ticket and found that our support didn’t respond for 9 days - I am truly sorry for that as we typically get back to people within 24-48 hours. 


This community will also update when this bug is fixed so feel free to check back here. 

Userlevel 1

Tyler, have you heard of any update regarding my issue upgrading on my Samsung s22? Do you think I should start shopping for a different company to protect my family's Samsung products?

Would appreciate any input you may have.


I sent an email to the webroot customer support on June 21, 2022 and still haven’t heard back from them. I can download the app from the play store, but can’t go any further, gives errors. I have a Samsung Galaxy S22 Ultra as well. I hope it gets fixed soon, I paid for the mobile protection, but can’t use it.

I'm having the same issues with the S22 and it looks like they haven't fixed it in 3 months from the forum. Guess I need to spend even more money and get another virus protection 😒

Userlevel 1



This is an email that I received from Webroot support on of today the app is still not up and running on my S22.



Thank you for bringing the issue you are experiencing to our attention. The Webroot Development team has been notified of this issue and is currently working on a resolution. We currently do not have an ETA to address this issue, however once we have a resolution it will be in an upcoming software version release, which will be downloaded automatically to your device and installed when it is available.

Once the newer version has been installed, check to see if the issue you reported is still occurring. If it is, let us know and we will check the status of the issue. You may contact us by phone by clicking here and choosing the sales number for the location that works best for you, or online at

Thank you,

The Webroot Support Team


Has there been any progress on a resolution for this issue?
I’ve been using Webroot products for more than ten years and recently upgraded to Samsung S22. When attempting to open the app it states “can’t open this page.”

Is there a timeframe when this will be functional again?
I appreciate your time and effort.

This is ridiculous. You changed how your app works and neglect to check against the strongest selling Android-based device? And this was months ago.

Userlevel 1

I gave up hoping for a fix and dumped Webroot. I worry about a security company that can’t figure out how to make their program work  on a Samsung phone. 

Userlevel 2

I tried the same thing. It didn’t work on my Samsung Galaxy s22 android phone, either. I found out that I can use a preloaded app of McAfee from T-Mobile, when I had to purchase a new phone. It’s a free antivirus software program. So, I’m going to try to restart my phone to see if that will help. If not, I’ll just use McAfee. Okay, didn’t work and couldn’t upgrade it either. Just going to stick with McAfee. However,  Webroot works good on my desktop pc (Windows 10).

Userlevel 7
Badge +22

I do apologize everyone, but our devs are still working on Android S22 compatibility and I understand that it’s frustrating