Solved

Can't unistall SecureAnywhere from Mac OSX

  • 20 January 2013
  • 64 replies
  • 4005 views


Show first post

64 replies

Userlevel 7
Welcome to the forums jtemplin!
 
Hopefully you will find an answer quickly, but I would also suggest that you also Submit a Trouble Ticket
Userlevel 7
Please try shutting down SecureAnywhere before dragging it to the Trash.
 
Uninstalling SecureAnywhere from a Mac
 
1.   Shut down SecureAnywhere by clicking the Webroot icon (green W) in the menu bar and selecting Shut Down SecureAnywhere.
2.   If prompted, confirm that you want to shut down SecureAnywhere.     
3.   Open the Finder by clicking the Finder icon in the dock.     
4.   Open the Applications directory.
5.   Click and drag the Webroot SecureAnywhere program icon into the Trash in the dock.
6.   A confirming window appears.  Click Uninstall.
7.   Webroot SecureAnywhere is now uninstalled.  There is no need to restart your computer.
Hi Mike,
Webroot isn't appearing on my menu bar.
As I mentioned above, I've tried multiple ways to shut it down before throwing it in the trash.
Please advise.
BTW, I'm on Mountain Lion if that makes any difference.
Thx
Unconventional solution
 
Hey, I had the same problem. After mucking around for a while, I tried adding ".jpg" to the end of the file name in applications (which changes the file type), which of course it didn't like, and it immediately opened an uninstall prompt that worked. Yay!
Hi all-this is driving me absolutely nuts as well. The window to install is popping up every 50 seconds and I can enter the key and then am told it cang get the update-after the keycode has been verified. No drag and drop unistall to teh trash...no .jpg solution-it wont let me change the extension. I submitted a ticket but am getting really frustrated. tia
Userlevel 7
Hi mmelkers
 
Sorry to hear about your frustration.  May I suggest that you 'bump' your Support Ticket, i.e., add further information to it? 
 
Have to say that in my experience a lack of response from the Support Team is very atypical...but as MikeR has said previously in this thread...an OSX specialist is most likely required.    
 
@ @  is there any way that we can get some focus on this issue for mmelkers...just in case the ticket has slipped through the cracks?  Thanks in advance. ;)
 
Regards
 
 
Baldrick
I as well can not uninstall, trash, modify, etc the WebRoot SA file in the applications folder, anything I attempt to do says "You do not have permission to the item "Webroot SecureAnywhere"  I've even tried terminal's rm command which produced the same restricted access error.
Rebooted numours times, and tried changing the permissions of the app in Get Info... thus far, it's stuck popping up every minute.
Userlevel 7
Hi rcleland
 
Welcome to the Community Forums...:D
 
What you are reporting sounds very much like previous posts regarding some issue with WSA running under OSX.  Given you are unable to uninstall WSA by the prescribed method (there is no separate removal tool) I am afraid that I can suggest at this point is that you too If you Open a Support Ticket and bring this to the Support Team's attention.
 
I will check out some previous thread to see if they reveal any other options but for the moment, as far as I recall from previous threads, the consensus that such issues would be best handled through the Support system, as most likely remote sessions will be needed and the Community is not equipped for that. 
 
I suggest that this is the best course of action. 
 
If however you are more technical then you could take a look at this post from another thread, where another Community member suggests a course of action that resolved, for him, what sounds like the same issue...but I would stress that you should not attempt this unless you have carefully read & understood the actions described AND feel confident of being able to undertake them safely.
 
Post back to keep us updated of the position of your issue, and hopefully what is done to eventually resolve it...such information is useful to have in the Community, to help other users in the future that may have the same issue.
 
Redgards
 
 
Baldrick
So no info about what the solution is when you cannot uninstall an expired version? Why not post the solution and avoid more support calls?
Glad to be here!
I fully agree, this program (Malware?) is a nightmare to remove. I have a full (non-trial) version given to me by a bank and it keeps on opening shutting and reopening over and over. Thus I decided to remove it and it seems impossible to get rid off. Deleting it leaves a plist file in trash that can not be removed.

I've tried everything suggested and really am pretty annoyed that I need to spend so much time removing something that has hijacked my system.
Userlevel 7
Hi Web_Rot2
 
Welcome to the Community Forums...:):)
 
From what you are saying it seems to me that your best course of action would be, as suggested to previous posters to this thread, that you Open a Support Ticket as soon as possible and allow the Support Team to look into this for you.  They are the experts in this area and should be able to assist.
 
Regards
 
 
Baldrick
Userlevel 7
Hi transcendev
 
Further to your reporting your situation I was just wondering what your current status is or isn't ;) in relation to WSA.  I suspect that it is the latter rather than the former...but we always like to know here in the Community...just incase a cause is not lost.
 
It would be good to hear your news.
 
Regards
 
 
Baldrick
Userlevel 7
Hi transcendec
 
Thanks for the feedback.  Are you going to try a reinstall on your Mac or have you given up with WSA on that platform? Reason I ask is because whilst there do seem to be a few more install issues IMHO re. OSC, from what I read, there are many happy users of WSA under that OS.
 
It may therefore be worth any attempt, especially given that yo unow have the failsafe way of removing WSA should the same happen again.  Just a thought.
 
Have a great weekend.
 
Regards
 
 
 
Baldrick
This post helped tremendously; however, I did have to do a few extra things to get the program to reinstall. I noticed that Webroot also had two daemons running, WSDaemon and WFDaemon were the names if I remember correctly. Located at /usr/local/bin. I had to do the exact same thing for both of them in order to get the program to reinstall. If you leave them running, then you will still have a bit of Webroot on your system. Just go to the directory, chmod -x both of them, then kill them and you are good to go. After that I was able to reinstall and get Webroot to activate and update.
Userlevel 7
Hi theblueone4040
 
Welcome to the Community Forums...http://www.forumsextreme.com/images2/sBo_bouncing.gif
 
Thank you so much for your input...I think that this is an very valuable contribution to the Community 'knowledge' about this issue and something that we should certainly asking or advising any future users unfortunate enough to have a similar issue to check for.
 
Again, thanks so much for taking the trouble to feedback...this is just what we need & like iin the Community.
 
Hope to see you around?
 
Regards
 
 
Baldrick
Userlevel 7
Hi MARLOWE
 
Welcome to the Community Forums...http://www.forumsextreme.com/images2/sBo_jumping.gif
 
Sorry to hear that you have a problem...may have missed a post from you but would you be able to describe your problem?  I presume that it relates to being unable to uninstall WSA running under OSX?
 
If you have tried the advice/suggestions made in this thread and they have had no success then I would recommend that you Open a Support Ticket and provide Support with all the information on your issue/what you have tried yourself to resolve it, etc.
 
If however you need further help with the suggestions made in this thread then please post back and we will see what further we can do to help, or PM the poster of the suggestion and see if they can provide you with more detailed information as to their suggestion, ;)
 
Regards
 
 
Baldrick
I have they told me to phone I'm in France if you add the jet lag and the price of the call this is going to be pricy….But do I have the choice? English is not my native language …Really regret having installed this software ...
Userlevel 7
Hi MARLOWE
 
I am not sure I follow what is going here with Support but perhaps we can check with our Community Manager, as to whether he know as to whether there is an alternative to a phone call?  I presonally have never had to call Support, I have just communicated with them via the Support Ticket or by them connecting to my PC to have a look at the issue/carry out some changes to see if they would resolve the issue.
 
Hi Nic @ any other options for MARLOWE to get support for his uninstall issue?  Just wondering if a remote session would be possible (cheeky of me to ask...I know :p)
 
Regards
 
 
Baldrick
 
Userlevel 7
Badge +56
Yeah I would suggest either corresponding by email or by chat, if he's having problems with phone.
Userlevel 7
Hi Nic
 
Thanks...for the confirmation.
 
Hi MARLOWE
 
If you have opened a Support Ticket then please update it to explain to Support your circumstances and to ask them to communicate with you by email or by chat (remote session) as suggested by Nic.
 
Regards
 
 
Baldrick
I did open a ticket support and update it…They told me to call a number but what a number the number doesn't work!!!!???
I'm stuck here, I'm a teacher and work a lot from home but this has become impossible ….this is most annoying! I'm resent installing this programme.
Userlevel 7
Badge +56
I'll put in a request to have them contact you again and figure out a method that works for everyone.  Sorry you had a bad experience!
I also had the issue of getting repeated prompts about "installation failed" and needing to re-enter the code, and being unable to kill/uninstall Webroot Antivirus.
 
I followed the suggestions posted by user Web_Rot a couple of pages back.  In my case, there were three processes running that I had to change permissions on before I could kill them and then uninstall:
  • /usr/local/bin/WFDaemon Webroot Mac Web Filter Daemon
  • /usr/local/bin/WSDaemon Webroot Mac Security Daemon
  • /Applications/Webroot SecureAnywhere.app/Contents/MacOS/Webroot SecureAnywhere
I'm reasonably happy with Webroot on my Windows PC's, but the Mac version is appaling.  I won't be reinstalling it until Webroot demonstrate they have half a clue about OSX.  Officially posting a method to remove the broken software that actually works would be a nice first step.  Developing software that didn't need these sort of hacks in the first place would be vastly better.
I know it's been several months since anyone posted, but I have the same problem so I thought I'd throw in my 2 cents for anyone getting this forum in Google results (as I did this morning).
 
EDIT: I suggest that only ADVANCED users attempt the following.  Serious damage COULD happen if done incorrectly.   For the average user, it would be best to have assistance of a Webroot Support.  (shorTcircuiT)
 
I followed what Web-Rot, Transcendev, gedaso, and theblueone4040 did. Thanks! For you Google searchers, here's the synopsis. As root:
ps aux | grep Webroot  (to find the process #s)
kill process # (kill each number for the daemons too - WSDaemon and WFDaemon)
chmod -x /Applications/Webroot SecureAnywhere.app/
chmod -x /usr/local/bin/WFDaemon
chmod -x /usr/local/bin/WSDaemon
 
So that got the annoying zombie pop-up to stop harrassing my user, but I couldn't delete the files and subdirectories with plain old rm -rf. Crazy to be root and be denied permission to folders (is this a Mac 'nix thing?) So even at the command line, I couldn't get rid of Webroot stuff!
 
But wait! At the suggestion of a learned colleague, I used rsync. Create a tempory empty folder, then rysnc it to /Applications/Webroot SecureAnywhere.app/ using the delete option:
 
rsync -r --delete tempempty/ /Applications/Webroot SecureAnywhere.app/
 
And boom done! Use carefully! I assume if you're following this and understand it, you'll be careful using rsync --delete !
 
So now my user can get back to work until Webroot tech support gets back to me. I submitted a ticket this morning but in the meantime I had to do this so she could work. I can understand earlier poster's frustration. As a sysadmin, to be logged in as an administrator/root, and yet be denied the ability to remove software or delete files/directories is an unpleasant feeling. I feel like when one is root, one should take no guff from software like this. From the GUI, meh, okay, protect users from themselves, but at the command line? Maybe there's a good reason, but it is frustating.
 
All that said, I have no problems with our Windows installations, and will be giving the Mac installations another shot as we upgrade to Yosemite and re-install the latest Webroot for Mac. Will report back if there is good info from tech support.

Reply