Solved

Can't unistall SecureAnywhere from Mac OSX

  • 20 January 2013
  • 64 replies
  • 4008 views


Show first post

64 replies

Hi, 
 
I just had this problem, but none of the methods mentioned so far worked. I had the pop up window telling me that an installation failed and I needed to re-enter the code. After about 15 minuits of interupted PC use, I thought I would find the code to vanquish this beast. After searching 10 minutes through old e-mails - I found it! But it did not satisfy the hunger. It wanted to interupt me more! 
 
Stopping the process of Webroot would not let me delete it. Even with SU priveleges I could not delete it. 
Now tell me - what app has higher priveleges than root?  Webroot somehow does! Probably because it is always running, even when you think it is not. I tried the 'force quit' method in activity monitor. Even then the app would not die. 
 
If it was not for the pop up screen that kept coming up - I would not have been so keen to get rid of it, but it would not leave me alone!
 
I resorted to a command window to attack this monster.
typing 'ps -A'   lists all the processes. In my case the process was 1177. The install directory was layed out, bare to see. 
Typing 'kill 1177' would get rid of it for a while. But it would come back like a hungry zombie. How? I don't know.  
I went to the install directory listed in the ps list. 
Performing a longlist (ls -ll) showed the offending executing file had full privaleges, including execution (obviously). 
I swiftly typed 'chmod -x Webroot SecureAnywhere'
That annoying window could no longer execute itself. Whahahahah!
But I did not stop there. I went in for the kill. 
 
I deleted the webroot app from my Applications and wam! That sucker was gone. 
I just hope there is not a sequal to this drama. Web Rot 2 - The return of Web Rot!
 
I do not mean any disrespect here, but hey - let us have a little talk about respect. Since when does a security program act like the malware programs or viruses I installed it to prevent? To be honest I only installed it because it was free with my iPad. 
I feel like a victim here. I just wasted an hour trying to get rid of this! An hour I will never see again. I can only hope this message will help others that are victims to this interupting annoying window pop-up thing. 
 
 
 
 
 
 
 
Userlevel 7
Hi DivaFixIt
 
Welcome to the Community Forums...:D
 
Many thanks for posting such a valuable method...and so clearly done too.  This is exactly what the Community Forums are here for and how we hope that users will use them for...to help fellow users and to learn also.
 
I shall bookmark this post for potential use as and when other users come here suffering from the same or similar issues.
 
Hope that you stay around and join in we you see the opportunity...or just drop by for a bit of fun.;)
 
Have a great weekend.
 
Regards
 
 
Baldrick
 
 
I am running Mavericks on my iMac (10.9.1) and found a very simple way to uninstall it. I first shut it down completely. If you are not sure if it is shutdown to be certain:
  1. Open the program
  2. Click on the Apple on the top left of your screen
  3. Select "Force Quit" on the menu, select Webroot from the choices provided, and force quit. You may be prompted by the program to confirm you really meant to shut it down and just confirm.
After doing that I tried (unsuccessfully) to drag and drop the program from the Applications menu to the trash. Didn't work. So instead I did the following:
  1. Select "Go" in the Finder menu (its the default menu that appears at the top left of your Mac when you first log in).
  2. Click on "Applications"
  3. Scroll the list until you find Webroot
  4. Right click over Webroot and a drop-down menu will appear.
  5. Select  "Move to Trash"
  6. The program will confirm that you want to uninstall and voila it's gone!
So no info about what the solution is when you cannot uninstall an expired version? Why not post the solution and avoid more support calls?
Userlevel 7
Badge +35
Hi mmelkers and rcleland,
 
I checked on your tickets, and it looks like our support team responded but you have not yet read the response. Please check your ticket by entering your email address here: https://www.webrootanywhere.com/servicewelcome.asp. Let us know if you have any trouble accessing it.
Userlevel 7
Hi rcleland
 
Welcome to the Community Forums...:D
 
What you are reporting sounds very much like previous posts regarding some issue with WSA running under OSX.  Given you are unable to uninstall WSA by the prescribed method (there is no separate removal tool) I am afraid that I can suggest at this point is that you too If you Open a Support Ticket and bring this to the Support Team's attention.
 
I will check out some previous thread to see if they reveal any other options but for the moment, as far as I recall from previous threads, the consensus that such issues would be best handled through the Support system, as most likely remote sessions will be needed and the Community is not equipped for that. 
 
I suggest that this is the best course of action. 
 
If however you are more technical then you could take a look at this post from another thread, where another Community member suggests a course of action that resolved, for him, what sounds like the same issue...but I would stress that you should not attempt this unless you have carefully read & understood the actions described AND feel confident of being able to undertake them safely.
 
Post back to keep us updated of the position of your issue, and hopefully what is done to eventually resolve it...such information is useful to have in the Community, to help other users in the future that may have the same issue.
 
Redgards
 
 
Baldrick
I as well can not uninstall, trash, modify, etc the WebRoot SA file in the applications folder, anything I attempt to do says "You do not have permission to the item "Webroot SecureAnywhere"  I've even tried terminal's rm command which produced the same restricted access error.
Rebooted numours times, and tried changing the permissions of the app in Get Info... thus far, it's stuck popping up every minute.
Userlevel 7
Hi mmelkers
 
Sorry to hear about your frustration.  May I suggest that you 'bump' your Support Ticket, i.e., add further information to it? 
 
Have to say that in my experience a lack of response from the Support Team is very atypical...but as MikeR has said previously in this thread...an OSX specialist is most likely required.    
 
@ @  is there any way that we can get some focus on this issue for mmelkers...just in case the ticket has slipped through the cracks?  Thanks in advance. ;)
 
Regards
 
 
Baldrick
Hi all-this is driving me absolutely nuts as well. The window to install is popping up every 50 seconds and I can enter the key and then am told it cang get the update-after the keycode has been verified. No drag and drop unistall to teh trash...no .jpg solution-it wont let me change the extension. I submitted a ticket but am getting really frustrated. tia
Unconventional solution
 
Hey, I had the same problem. After mucking around for a while, I tried adding ".jpg" to the end of the file name in applications (which changes the file type), which of course it didn't like, and it immediately opened an uninstall prompt that worked. Yay!
Userlevel 7
Have you rebooted the machine since uninstalling SecureAnywhere?
 
We have Engineers that specialize in the Mac OS that will be back in the office tomorrow. One of them may need to take a closer look to see if remnants of the software are not uninstalling properly. If you Open a Support Ticket they will be able to help you further.
Hi Mike,
Webroot isn't appearing on my menu bar.
As I mentioned above, I've tried multiple ways to shut it down before throwing it in the trash.
Please advise.
BTW, I'm on Mountain Lion if that makes any difference.
Thx
Userlevel 7
Please try shutting down SecureAnywhere before dragging it to the Trash.
 
Uninstalling SecureAnywhere from a Mac
 
1.   Shut down SecureAnywhere by clicking the Webroot icon (green W) in the menu bar and selecting Shut Down SecureAnywhere.
2.   If prompted, confirm that you want to shut down SecureAnywhere.     
3.   Open the Finder by clicking the Finder icon in the dock.     
4.   Open the Applications directory.
5.   Click and drag the Webroot SecureAnywhere program icon into the Trash in the dock.
6.   A confirming window appears.  Click Uninstall.
7.   Webroot SecureAnywhere is now uninstalled.  There is no need to restart your computer.
Userlevel 7
Welcome to the forums jtemplin!
 
Hopefully you will find an answer quickly, but I would also suggest that you also Submit a Trouble Ticket

Reply