Solved

Can't unistall SecureAnywhere from Mac OSX

  • 20 January 2013
  • 64 replies
  • 3971 views

Hello,
I've been trying for hours to uninstall an expired trial of SecureAnywhere that keeps annoyingly prompting me to register.
 
Every time I drag to the Trash or try a tool like AppZapper, it says I can't uninstall because SecureAnywhere is running.
 
So then I go to Activity Monitor to kill the process. That seems to work for a moment, but then SecureAnywhere is running again.
 
Please help.
 
Thanks,
Jack
icon

Best answer by akim 24 January 2014, 18:54

View original

64 replies

Userlevel 7
Have you rebooted the machine since uninstalling SecureAnywhere?
 
We have Engineers that specialize in the Mac OS that will be back in the office tomorrow. One of them may need to take a closer look to see if remnants of the software are not uninstalling properly. If you Open a Support Ticket they will be able to help you further.
Userlevel 7
Badge +35
Hi mmelkers and rcleland,
 
I checked on your tickets, and it looks like our support team responded but you have not yet read the response. Please check your ticket by entering your email address here: https://www.webrootanywhere.com/servicewelcome.asp. Let us know if you have any trouble accessing it.
Hi, 
 
I just had this problem, but none of the methods mentioned so far worked. I had the pop up window telling me that an installation failed and I needed to re-enter the code. After about 15 minuits of interupted PC use, I thought I would find the code to vanquish this beast. After searching 10 minutes through old e-mails - I found it! But it did not satisfy the hunger. It wanted to interupt me more! 
 
Stopping the process of Webroot would not let me delete it. Even with SU priveleges I could not delete it. 
Now tell me - what app has higher priveleges than root?  Webroot somehow does! Probably because it is always running, even when you think it is not. I tried the 'force quit' method in activity monitor. Even then the app would not die. 
 
If it was not for the pop up screen that kept coming up - I would not have been so keen to get rid of it, but it would not leave me alone!
 
I resorted to a command window to attack this monster.
typing 'ps -A'   lists all the processes. In my case the process was 1177. The install directory was layed out, bare to see. 
Typing 'kill 1177' would get rid of it for a while. But it would come back like a hungry zombie. How? I don't know.  
I went to the install directory listed in the ps list. 
Performing a longlist (ls -ll) showed the offending executing file had full privaleges, including execution (obviously). 
I swiftly typed 'chmod -x Webroot SecureAnywhere'
That annoying window could no longer execute itself. Whahahahah!
But I did not stop there. I went in for the kill. 
 
I deleted the webroot app from my Applications and wam! That sucker was gone. 
I just hope there is not a sequal to this drama. Web Rot 2 - The return of Web Rot!
 
I do not mean any disrespect here, but hey - let us have a little talk about respect. Since when does a security program act like the malware programs or viruses I installed it to prevent? To be honest I only installed it because it was free with my iPad. 
I feel like a victim here. I just wasted an hour trying to get rid of this! An hour I will never see again. I can only hope this message will help others that are victims to this interupting annoying window pop-up thing. 
 
 
 
 
 
 
 
Userlevel 7
Hi. Well thanks for such a dramatic account of an attempt to uninstall an app! :D
 
I'd say if the usual ways of install/uninstall are not working for you, then you should contact support: the official Webroot support system
Userlevel 7
Badge +56
@ wrote:
And another thing. Any legitimate self-respecting company that had any respect for its customer base (paying customer, in my case), would simply post a solution to the forum and not require the trouble ticket BS and keep the fix a secret from their users. I could have dug the activation code out of my files and re-entered it, or re-upped online, but tolerating this behavior in an application was against my principles.
Support is usually more on top of all the technical ins and outs than anyone else - we do make an effort to document all known solutions in our knowledge base but there are some that get missed.  I think in this case we can apply Hanlon's Razor 🙂
Userlevel 7
Badge +56
Hello ? and Welcome to the Webroot Community!
 
Well this is an old thread and things probably have changed since ? posted his suggestion in 2013. If you like please contact Webroot Support and talk to one of the Mac experts!
 
Via the Ticket System: Webroot Customer Service Ticket
 
By Phone in the US:
 
Call 1-866-612-4227
M-F 7am?6pm MT
 
Or from another country: https://www.webroot.com/us/en/support/contact
 
Thanks,
 
Daniel
I am running Mavericks on my iMac (10.9.1) and found a very simple way to uninstall it. I first shut it down completely. If you are not sure if it is shutdown to be certain:
  1. Open the program
  2. Click on the Apple on the top left of your screen
  3. Select "Force Quit" on the menu, select Webroot from the choices provided, and force quit. You may be prompted by the program to confirm you really meant to shut it down and just confirm.
After doing that I tried (unsuccessfully) to drag and drop the program from the Applications menu to the trash. Didn't work. So instead I did the following:
  1. Select "Go" in the Finder menu (its the default menu that appears at the top left of your Mac when you first log in).
  2. Click on "Applications"
  3. Scroll the list until you find Webroot
  4. Right click over Webroot and a drop-down menu will appear.
  5. Select  "Move to Trash"
  6. The program will confirm that you want to uninstall and voila it's gone!
Userlevel 7
Hi DivaFixIt
 
Welcome to the Community Forums...:D
 
Many thanks for posting such a valuable method...and so clearly done too.  This is exactly what the Community Forums are here for and how we hope that users will use them for...to help fellow users and to learn also.
 
I shall bookmark this post for potential use as and when other users come here suffering from the same or similar issues.
 
Hope that you stay around and join in we you see the opportunity...or just drop by for a bit of fun.;)
 
Have a great weekend.
 
Regards
 
 
Baldrick
 
 
Userlevel 7
Hi Web_Rot
 
Welcome to the Community Fora...http://www.forumsextreme.com/images2/sBo_bouncing2.gif
 
I have to agree with Dermot on this one...and say well done for your patience...and do make sure that you either replciate the above in your Support Ticket Submission or better still (and to save you time) include a url link to your post so they can pick up on what you have outlined to us.
 
Keep us posted on how things go re. this issue as feedback, either way, is helpful to us in helping users in the future with the same or similar issues.
 
Many thanks in anticipation.
 
Regards
 
 
Baldrick
This Works!!!
 
My wife's Mac was unusable becasue of this problem, and I could not even kill this S.O.B. from a command line.
So I resorted to a tried and true method that could not fail.  
 
Target Disk Mode.
 
You need another Mac (both of them Firewire equipped) to do it. Connect the two Macs using a firewire cable and reboot the infected Mac while holding down the T key.  It will come up as a firewire hard drive on the uninfected Mac (might even work with a PC as the other computer, but I have never tried that).  
 
Then you just navigate to the Webroot application container int he Applications folder, drag it to the trash, and then empty the trash.
 
When you reboot again, voila!  Webroot is dead and gone. Finito. Kaput. Good riddance.
And another thing. Any legitimate self-respecting company that had any respect for its customer base (paying customer, in my case), would simply post a solution to the forum and not require the trouble ticket BS and keep the fix a secret from their users. I could have dug the activation code out of my files and re-entered it, or re-upped online, but tolerating this behavior in an application was against my principles.
Userlevel 7
Hi Nic
 
I think that you are spot on with your comment here...and for those who don't know it, and to stop them overloading the search engines...en masse...;)
 
It states "Never attribute to malice that which is adequately explained by stupidity"
 
Think about it...think about it! http://www.forumsextreme.com/images2/sCo_hmmthink.gif
 
Regards
 
 
Baldrick
"Never attribute to malice that which is adequately explained by stupidity."
That's Hanlon's Razor?  I like that.
Userlevel 7
Badge +56
@ wrote:
"Never attribute to malice that which is adequately explained by stupidity."
That's Hanlon's Razor?  I like that.
Yeah, I try to remember that one frequently.  It helps stop me from getting so mad when things go wrong 🙂
My status wrt WSA?  I had purchased a three-seat license.  It is still active on the two (Windows) machines on which it has not yet misbehaved as it did on the Mac.
same problem that keeps annoying me …every 50 seconds can't get my work done and the suppress process doesn't work !!!How do I uninstall that????
I'm glad you found a way, as for me I haven't yet and I don't really understand how you did what you did….I'm so upset by this thing …:(
Userlevel 7
Badge +62
:DHello,https:///t5/user/viewprofilepage/user-id/20596, I also have an Mac with WSAC installed on it. You can launch Activity Monitor and shut down the Webroot down first and Drag and drop files associated with Webroot to the trash.
 
But mostly my advice would be to issue a support ticket right away with support remotely handling this uninstall and reinstall. If you've really want to handle it correctly without frustrations let Webroot Support do it for you.
 
Don't give up yet they are your best bet for uninstalling Webroot properly, via install.
 
So sorry for your issues here, My WSAC is running without a hitch with Mavericks OS,
 
Best Regards, Sherry
 
Sorry forgot to mention Welcome to the Webroot Forum Community where we all are here to help and support.
Userlevel 7
Badge +62
Hello ehumphrey,
 
Welcome to the Community!
 
Sorry to hear about your frustrations.
 
I'm not an expert with Mac commands. But I had to uninstall Webroot recently and I was able to uninstall Webroot from the safe mode without any problems. I am also running Yosemite with WSAC. without any issues.
 
Please do let us know what Support does for you for this would help alot of Mac users,
 
 
Best Regards,
 
Thank you,:D
Sherry,
We're still on Mavericks but moving to Yosemite later this week. Yay, I'll finally be rid of thes SMB/Windows share problems!
 
I had the same problem as others-- the persisten pop-up that would just report an error after entering the license key, the inability to uninistall via the desktop methods-- right-clicking on Webroot in the Applications folder>send to trash, nor by dragging to the trash. Trying to open the Webroot application to see if there was anything I could do there just resulted in the pop-up coming back.
 
As I noted, I will attempt to uninstall now that I have the processes stopped and reinstall after updating to Yosemite. I'll report results as I get them!
Userlevel 7
Badge +62
Hello beck,

Do you have Webroot icon in your upper right hand corner of your desktop? Are you able to right click to open Webroot and click shutdown? Then follow my instructions below or go here http://www5.nohold.net/Webroot/ukp.aspx?pid=12&app=vw&vw=1&login=1&json=1&solutionid=1992&

If you still can't uninstall Webroot then I'd advise that you issue a Support Ticket and they will sort this out for you. I've uninstal Webroot in safe mode before but I wou recommend this if you are not familiar with your Mac. Here's the link for Support
https://www.webrootanywhere.com/servicewelcome.asp

We don't mean the Dock which is usually located at the bottom of your screen. You want the menu bar in right hand corner.

Hope this helps,

Kind Regards,
Userlevel 7
Hello everyone!
I am sorry that you all are having a hard time with uninstalling Webroot.  Unfortunatly I cannot give out the uninstall terminal commands online as this would be a huge security issue.  However,  Please feel free to call us or setup a support ticket.  If anyone has any other questions please do not hesitate to ask.
Thanks,
 
@ wrote:
.... Unfortunatly I cannot give out the uninstall terminal commands online as this would be a huge security issue.  ....
 
Not to mention a mistyped "sudo" and waive bye-bye to the wrong kernal extension!  ;)  (says the voice of inexperience! 😛 )
Userlevel 7
Tony,
I was writing a program for us to use at work and mistyped one... everything on my Desktop was deleted including the program I was writing lol.  Luckily I had a Time Machine backup or i would have been really upset.
 
Userlevel 7
that method is going to leave behind parts of the software.  Please do not remove webroot in this manner.  There are a lot of files that are located on the machine not in the application folder and the application support folder.  If you are having trouble removing WSA then please contact our support team as we have the correct method and commands to remove all of the program.
Thanks,
 

Reply