Question

Cannot deleting files from iCloud

  • 25 February 2020
  • 4 replies
  • 214 views

Badge +1

There seems to be an issue deleting files from iCloud (the version delivered through the Microsoft Store) that uses “Files on Demand” (similar technology to OneDrive).

 

The service creates a "file" that is attribute tagged as a SparseFile (which lets it take up 0 bytes but seem to be X bytes big), ReparsePoint (likely to trigger the filter driver), and Offline (the same tag used by the old Offline Files, and used in the same way to denote the file isn't locally present). Then, when a program attempts to open said file, access to the file goes through the FS filter list, hits "CldFlt" which checks if it's tagged "Offline". If yes, then the filter asks the OneDrive sync service to hydrate the file before handing it off to the next filter.

 

Thought to be related to:
https://community.webroot.com/business-product-releases-26/windows-10-fall-creator-update-bug-fix-305469

 

I believe Webroot is preventing deletion of this through explorer, but I do seem to be able to delete through command line.


Any thoughts?

 

 


4 replies

Userlevel 7
Badge +17

Hey @tommylux ,

Welcome to the community!

 

Have you tried disabling Webroot and then deleting? To troubleshoot if Webroot is the cause? 

Either way, I recommend you reach out to our Support Team  - They should be able to help with troubleshooting why this is happening!

 

Let us know how that goes

-Keenan

Badge +1

Yes, disabling webroot does resolve the issue.

When I try and turn off all shields manually, you still get the invalid file handle. Only when you right click on the Webroot toolbar and choose to stop protection does deleting work.

Been able to replicate this on a second machine in a VMware environment running fresh Win 10 with latest patch. iCloud from Windows Store that uses the files on demand, rather than the legacy iCloud install.

Enabling webroot seems to work afterward till you restart the computer.

Is there any hope for weboot to look into this and resolve?

Regards

Tom

Userlevel 7
Badge +17

Hey @tommylux ,

Thanks for all of the additional info! 

It’s possible that our SUPPORT TEAM knows more about this and has a fix. I’d recommend reaching out to them and troubleshooting. I haven’t heard about this specific problem yet so it’s possible you’re one of the first to report it. Please reach out to them and come back to this thread to report on any updates!

 

-Keenan

Yes, disabling webroot does resolve the issue.

When I try and turn off all shields manually, you still get the invalid file handle. Only when you right click on the Webroot toolbar and choose to stop protection does deleting work.

Been able to replicate this on a second machine in a VMware environment running fresh Win 10 with latest patch. iCloud from Windows Store that uses the files on demand, rather than the legacy iCloud install.

Enabling webroot seems to work afterward till you restart the computer.

Is there any hope for weboot to look into this and resolve?

Regards

Tom

 

 

i m ones having problem like this.

Reply