Solved

Error code: ERR_SSL_PROTOCOL_ERROR

  • 26 January 2014
  • 30 replies
  • 261 views

Userlevel 7
Badge +26
I've been having this error in google chrome since 2 weeks ago when there was an update for the browser.
 
Error code: ERR_SSL_PROTOCOL_ERROR 
 
People say it's related to the new SSL modifications google is doing.
 
People on other forums are saying to disable SSL scanning in anti virus software from another brand and I do not see this option in Webroot.
 
There was someone that didn't have the other brand was mentioned and they had yet another brand that had the same issue.
 
Anyone here on Google chrome that has this error? 
icon

Best answer by remixedcat 28 January 2014, 03:50

View original

30 replies

Userlevel 7
I personally wouldnt advise people go uninstalling IE its far too messy and can cause issues. Since we have two blank messages with no actual information and the original posters havent come back I would wait until they come back. For all we know it could be a number of issues. 
Userlevel 7
Badge +26
Well I haven't seen this error in quite some time so that's why I haven't really came back to this thread.
Badge +1
The error message ERR_SSL_PROTOCOL_ERROR error indicates that the browser is not able to initiate the secured communication at the moment. It's almost impossible to pin it down to a single cause, it could be almost anything. There is no definite guide for managing this error. However, there are few changes or settings which help you to get rid you of this error.

  • Configure Correct Date and Time
  • Clear Browsing Data
  • Clear Your SSL State
  • Disable QUIC Protocol of Chrome
  • Disable your Internet Browser Extensions
  • Adjust Your Internet Security and Privacy Level
  • Remove your system's hosts file
  • Check Your Antivirus Settings
  • Check Your Firewall
Badge +1
If you already have the correct date & time, it’s time to clear Chrome’s cache and cookies. To do so, press Ctrl + Shift + Delete and erase your browsing data. Even if this hasn't fixed the "This site can’t provide a secure connection" error, we recommend clearing your browsing data on a regular basis. Fix ERR_SSL_PROTOCOL_ERROR by clearing your SSL State.

Reply