Question

Log In Fail with correct information

  • 9 August 2019
  • 4 replies
  • 175 views

Badge +3
Hello,

i recently bought Webroot a month ago for my newly built PC.. I ran into issues and had to reinstall windows 10, I go to log into webroot to get my keycode so I can reinstall webroot and I provided my correct email address and password and got a log in fail. I then tried to reset my password and I never even get an email to reset password. I was given a new password through the support email and when I try to log in with the correct email given and new password that was given, I still get a log in fail. Can someone please help?

4 replies

Userlevel 7
Badge +55
Hello @Gabella19 ,

Welcome to the Webroot Community.

Sorry to hear you are having issues.

If you want to request your keycode to be emailed to you, click here to fill out the request form.

You can also Submit a Support Ticket free of charge and they can help you. Or call them directly
during business hours. 1-866-612-4227.

Hope this helps?
Badge +3
Hello @Gabella19 ,

Welcome to the Webroot Community.

Sorry to hear you are having issues.

If you want to request your keycode to be emailed to you, click here to fill out the request form.

You can also Submit a Support Ticket free of charge and they can help you. Or call them directly
during business hours. 1-866-612-4227.

Hope this helps?


Sadly I’ve tried to get it emailed to me and when I put in my last name, email and check the box and then click download it does nothing and I don’t receive any email.. I’ve been trying it for two days.
Userlevel 7
Badge +55

Hello @Gabella19 ,

Welcome to the Webroot Community.

Sorry to hear you are having issues.

If you want to request your keycode to be emailed to you, click here to fill out the request form.

You can also Submit a Support Ticket free of charge and they can help you. Or call them directly
during business hours. 1-866-612-4227.

Hope this helps?
Sadly I’ve tried to get it emailed to me and when I put in my last name, email and check the box and then click download it does nothing and I don’t receive any email.. I’ve been trying it for two days.


So sorry to hear of this inconvience. Let me ping our Administrator @LLiddell and see if she can assist here to esculate this issue. Okay? She'll be in around 10 MST. I am sure this will get resolved with her help.
Userlevel 7
Badge +55
Hi again @Gabella19

I was thinking have you tried different Browsers?

Reply