Password Vault not working???

  • 2 October 2018
  • 0 replies
  • 12 views

Userlevel 1
So, I have been using this thing (Password Vault) for more than a year without any issues, been a customer for more than 5...  Suddenly, last night, I go to log into it and it says it does not recoginize my email address?  I get on the phone with Geek Squad (bought it along with my new laptop from Best Buy) and they jump through some hoops (I don't think the details much matter).  Next it recoginizes my email but then not my password.  Once the online, 2nd tier guy, gets past that it gets better, much better; now I can get in but....  Nothing there!  They tell me at 10:30 pm on a Sunday night I will need to contact WebRoot directly.  I go online and fill out an issue and wait for contact back.  I called them today and basically the same thing, I am "waiting" to get back all my personal and financial log on information for an apparent unknown amount of time?  Cannot help but say that something like this (anything like this) they should at least be able to set my expectations as to when I should hear back.  Another guy had the same issue years ago.  He said they never responded via the information they sent via the web page, but, he finally did get to call them and work through it and get it resolved.  Regardless it is less than a useful product if one doen't have constant on demand to this information.  So now I wait......................
 
Just curious: anyone else suffering or has suffered from the same affliction and/or what was the outcome?  How long did it take them to address the issue?  Any insite will at least passify me (somewhat?) in the meantime.
 
Thanks in advance for any input you are willing to share.

0 replies

Be the first to reply!

Reply