Question

Support Numbers not working

  • 2 July 2020
  • 9 replies
  • 1102 views

Userlevel 2

Hi

Could I please confirm the correct support number we are to call from Australia for support with Endpoint Protection? As per https://www.webroot.com/us/en/business/support/contact I have dialed 1 800 848 307, selected option 1 (the only option) and get informed the number is invalid / incomplete. My collegue over the last month has tried every number he can find for Webroot support online, and none of them connect. HE even tried the overseas number with no luck.

Could you please confirm.

Marty

 


9 replies

Userlevel 7

Hello @Marty1 

 

It does look correct but try the one in the US during Business hours US Mountain Time.

United States:

Tel: 1-866-254-8400

 

Or you can Submit a Business Support Ticket and that is 24/7.

 

Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue and support can take up to 48 hours to reply or a little longer because of COVID-19.

 

Thanks,

Userlevel 7

Also if you happen to be a Consumer user you can try this number: https://www.webroot.com/us/en/support/contact

Userlevel 2

Thanks.

I would prefer to be able to call someone within my own timezone, but i’ll give that a go.

We are a business customer, so it may be worth passing on that your phone system needs fixing up :)

I had logged a support case, and was told to call that Aus number, which then failed.

Cheers

 

Userlevel 7

Thanks.

I would prefer to be able to call someone within my own timezone, but i’ll give that a go.

We are a business customer, so it may be worth passing on that your phone system needs fixing up :)

I had logged a support case, and was told to call that Aus number, which then failed.

Cheers

 


I will ping the Community Staff to let them see that the number is broken! @khumphrey  @freydrew and @coscooper 

 

Thanks,

Userlevel 6
Badge +17

@TripleHelix @Marty1 ,

Sorry for my late response! I’m informing the higher ups about this - I’ll let you know when we have it resolved!

Userlevel 6
Badge +17

@Marty1 ,

Please try dialing as follows: 901 161 180 084 8307

Userlevel 7

Thanks @khumphrey  and hope it works for @Marty1 ! That’s allot of numbers...lol

 

:wink:

Userlevel 2

Ok i’ll give that a go to test later today. 

I was able to get hold of a local contact I had met at a conference, so was able to resolve the issue for now, but i’ll test the number above.

Marty

Userlevel 2

Hi, I called the number supplied (which is just an international dialing sequence for 180 084 8307 - which is the same number I dialled originally and got the error). 

I was presented with the same original IVR of ‘press 1 for support’ as was then transferred to someone based in the UK. She said she assumes the reason for that, is the AUS based team must all be on calls?

Marty

Reply