Question

Webroot blocking Firefox 97.0 64-bit

  • 9 February 2022
  • 50 replies
  • 6462 views

Userlevel 2

Today Firefox updated to 97.0 on my windows 10 machine.  When I restarted my computer, nothing works in firefox anymore.  I can load it once, but I can’t browse to any webpage or even pull up the settings or about Firefox menu.  When I close it I cannot open Firefox again.

I tried uninstalling and reinstalling Firefox.  I eventually tried installing the 32-bit version and it worked.  I reinstalled the 64-bit version and found that if I close out of Webroot completely it would work normally.  It only works if I shut down webroot completely.  If I turn off individual shields (or all the shields) it won’t work, but exiting webroot causes firefox to instantly start working again.

Webroot gives no indication that it is blocking anything.  Any ideas as to why this is happening and how I can fix it?


50 replies

Same issue… for my customers

 

Userlevel 2

We also have this issue, where Firefox 97 will not respond at all, until Webroot is disabled.

Userlevel 2

I have a partial fix for this.  The issue is outlined in here but the important bit is that WRusr.dll is ccalling SHGetFolderPathW in DllMain.

 

The partial fix is to install Firefox 98 Beta Nightly that was released last night.  Once I installed that Firefox 64-bit would load once again.  The reason I’m calling this a partial fix is because you’re having to use a nightly build and because Firefox is patching a work around for a larger issue that Webroot needs to address to prevent issues with other programs.

 

The very reason I switched to firefox a year ago was because this kept happening with Chrome, other software making workarounds for a webroot issue is not good.

Userlevel 7
Badge +63

Hello @abishur  @pflumingo  @Michael-D 

 

Please contact support directly to let them know and they might have a work around. I have Firefox 97 and is having some hiccups so I don’t know if it’s because of Windows Patches from yesterday or Firefox 97 or Webroot?

 

Webroot Support:

Submit a ticket

Call 1-866-612-4227 during the week Mon - Fri 7 AM to 5:30 PM (MDT)

 

Thanks,

Userlevel 7
Badge +63

@abishur  yes I see!

 

https://support.mozilla.org/en-US/questions/1367248

 

I will contact Webroot Support as well!

Userlevel 2

I’m unsure why some of my comment disappeared.

 

My client who was running Win 10 Pro (21H1) was having the same issue with Firefox 97.0 (64-bit) hanging / not showing anything other than a blank page. Updating Windows 10 to 21H2, plus a couple of waiting updates made no difference.

 

Disabling Webroot did allow Firefox to work. Finally I re-enabled Webroot, uninstalled Firefox, renamed the Firefox folders in C:\Program Files and C:\Users\Username\AppData\Local and Roaming; and installed the previous version of Firefox (96.0.3 64-bit). That has worked, although Firefox now constantly prompts the client to update.

 

She uses Firefox because she was having so many problems with Chrome. I’m now thinking that neither Firefox nor Chrome are the issue, but Webroot is.

I will contact Webroot Support to ask the question, but if anyone else finds an answer I’d appreciate it.

 

Interestingly, I use Firefox and Webroot on my own PC and it’s fine. I have just updated Firefox to 97.0 and it is still working. The main difference between my PC and the client is that I am running Win 11 and she is on Win 10.

Userlevel 7
Badge +63

@Michael-D I don’t see any missing comments of yours just the 2 in this thread. When you contact support put the link to this thread in the Ticket.

Userlevel 2

@TripleHelix You wouldn’t see the missing comments. They’re, err, missing! :yum:

I have added the missing bits to my previous comment.

Userlevel 7
Badge +63

I will ask the Community Staff to chat with support about this issue. @khumphrey  @TylerM then they can give us some feedback.

Userlevel 1

Hi, my name is Ryan and I’m a Release Manager for Mozilla. I was directed to this thread by way of the bug filed on our end for these issues. Please feel free to reach out to me directly or in the bug as needed so we can coordinate on getting this issue resolved for our users. Thanks!

Userlevel 7
Badge +63

Hello @rvandermeulen maybe you can contact Webroot Support yourself and work with them.

 

Webroot Support:

Submit a ticket

Call 1-866-612-4227 during the week Mon - Fri 7 AM to 5:30 PM (MDT)

 

Thanks,

Just FYI - same problem, running Win 11, when FF updated to 97 this am it crashed and wouldn’t reopen, tried the various reinstall fixes, etc, tried disabling Webroot, no help. 

Until I uninstalled Webroot completely - and Firefox reopened immediately, problem solved.  

So, as a diagnostic, this seems to narrow the problem to Webroot, if that’s any help. 

 

Userlevel 7
Badge +18

Hey everyone,

I just reached out to support about this issue. They said that as of right now, they have not been able to reproduce the issue but are actively looking into it. If you’re being affected by this issue, please send in a support ticket so that they can gather more data about the affected systems. 

Thanks!

Userlevel 1

Just got off the phone with the support engineer - Webroot team doesn’t have any ETA for a fix or anything in progress at this stage. Workaround is to uninstall - reboot - reinstall and somehow it begins to work, even if the version is the same as before. Or disabling Web Shield only and restarting - i haven’t tested that workaround.

Shutting down Webroot completely obviously works, but that’s a bit radical.

 

Thanks,

Mike

Userlevel 7
Badge +63

Yes @b2_mike  as I did a clean reinstall and it seems to work for what ever reason so time will tell and support with development is looking at it as we speak, This is the best way to do a clean reinstall of WSA.

 

Please follow the steps closely!

  • Make sure you have a copy of your 20 Character Alphanumeric Keycode! Example: SA69-AAAA-A783-DE78-XXXX
  • Be sure you add your Keycode to your Online Console: Webroot SecureAnywhere Online Console
  • KEEP the computer online for Uninstall and Reinstall to make sure it works correctly
  • Download a Copy Here (Best Buy Geek Squad Subscription PC users click HERE) Let us know if it is the Mac version you need
  • Uninstall WSA and Reboot
  • Go into Safe Mode and Delete these Folders if they are there!
  • C:\Program Files\Webroot Folder
  • C:\ProgramData\WRData Folder (Hidden Folder)
  • C:\ProgramData\WRCore Folder (Hidden Folder)
  • Boot back into normal mode
  • Install with the new installer, enter your Keycode
  • Let it finish it's install scan
  • Reboot once again
  • DO NOT import any old settings as you can set it up as you like once it's done

Info in case you don’t know how to go into Safe Mode: https://support.microsoft.com/en-us/windows/start-your-pc-in-safe-mode-in-windows-10-92c27cff-db89-8644-1ce4-b3e5e56fe234

 

Please let us know if that resolves your issue?

Thanks,

Userlevel 1

As my machines are remote, Safe Mode isn’t an option.

Userlevel 7
Badge +63

As my machines are remote, Safe Mode isn’t an option.

That’s fine most times during uninstall they are gone but at times the files remain so no worries. So you can skip that part in your case. You can use an Uninstaller like Revo Free version as I use the Pro Portable version and I don’t need to go into Safe Mode. Reboot after Uninstall is the most important!

Userlevel 1

But just a WSA uninstall, reboot, then install worked on all three affected machines. So far.

Userlevel 7
Badge +63

But just a WSA uninstall, reboot, then install worked on all three affected machines. So far.

Great to hear! Thanks for the info and feedback!

Userlevel 1

I have a partial fix for this.  The issue is outlined in here but the important bit is that WRusr.dll is ccalling SHGetFolderPathW in DllMain.

 

The partial fix is to install Firefox 98 Beta Nightly that was released last night.  Once I installed that Firefox 64-bit would load once again.  The reason I’m calling this a partial fix is because you’re having to use a nightly build and because Firefox is patching a work around for a larger issue that Webroot needs to address to prevent issues with other programs.

 

The very reason I switched to firefox a year ago was because this kept happening with Chrome, other software making workarounds for a webroot issue is not good.

The other fix is to put Firefox into compatibility mode. Right click on Firefox desktop icon > Properties > Compatibility tab > Check off “Run this program in compatibility with: > Chose Windows 8 from the dropdown.

 

I just worked with a customer today and she has had no issue in the 3 hours she has been working.

Userlevel 2

@TripleHelix Uninstalling and reinstalling Webroot has worked on my clients with this issue.

I’m hoping that subsequent Firefox updates don’t have the same problems, although it appears to be an underlying Webroot issue rather than a Firefox problem.

Userlevel 1

Firefox needs to be set to open in compatibility mode. Google Chrome has/had the same issue a month ago and having it open in compatibility mode was the only thing that worked until Chrome released a new update or Webroot did. 

Unfortunately that is the only fix I have found that works for my customers without all of the somewhat complicated mess that was suggested above - respect due where needed, not shaming the work and person whom suggested.

Userlevel 2

I had to completely uninstall Webroot Security from Laptop. “Disabling it”  (turning off realtime Shield, Web Shield, Firewall) didn’t work. I could open Firefox, but would sit there idle, with a blank screen.

 

I wanted to “downgrade” Firefox back to version 96.0.2 (or whatever it was previously) but finding and downloading the exact link is not as easy as I remember. It will be easier to just wait until Webroot fixes this.

 

I’ll use Windows antivirus until Webroot fixes :thumbsdown:

Userlevel 7
Badge +22

Hey everyone,

I’ve got the eyes of our Product Managers on this.

 

@rvandermeulen Thanks for stopping by our community thread on this and please be on the look out for a direct message from one of our PMs

Userlevel 1

Feb. 10 2022

I had the same problem that as soon as I updated Firefox to 97 it stopped working and I do have webroot and I am running Window 10 64-bit. 

I fixed this by opening Webroot, going to Identity Protection => Application Protection. Firefox was listed.  First thing to try is click on the Allow radio button.  Close webroot then see if firefox works. 

If not then go back into Webroot Identity Protection => Application Protection and right click on the firefox entry and delete it. Then click Add protection at the bottom and  navigate to firefox.exe and add this.  Finally  click the Allow radio button.

My Firefox started working immediately after this change.

I hope this makes sense and helps.

Reply