Question

Webroot blocking Firefox 97.0 64-bit

  • 9 February 2022
  • 50 replies
  • 6730 views


Show first post

50 replies

Userlevel 7
Badge +63

As my machines are remote, Safe Mode isn’t an option.

That’s fine most times during uninstall they are gone but at times the files remain so no worries. So you can skip that part in your case. You can use an Uninstaller like Revo Free version as I use the Pro Portable version and I don’t need to go into Safe Mode. Reboot after Uninstall is the most important!

Userlevel 1

But just a WSA uninstall, reboot, then install worked on all three affected machines. So far.

Userlevel 1

I have a partial fix for this.  The issue is outlined in here but the important bit is that WRusr.dll is ccalling SHGetFolderPathW in DllMain.

 

The partial fix is to install Firefox 98 Beta Nightly that was released last night.  Once I installed that Firefox 64-bit would load once again.  The reason I’m calling this a partial fix is because you’re having to use a nightly build and because Firefox is patching a work around for a larger issue that Webroot needs to address to prevent issues with other programs.

 

The very reason I switched to firefox a year ago was because this kept happening with Chrome, other software making workarounds for a webroot issue is not good.

The other fix is to put Firefox into compatibility mode. Right click on Firefox desktop icon > Properties > Compatibility tab > Check off “Run this program in compatibility with: > Chose Windows 8 from the dropdown.

 

I just worked with a customer today and she has had no issue in the 3 hours she has been working.

Userlevel 2

But just a WSA uninstall, reboot, then install worked on all three affected machines. So far.

 

YES! That worked! A simple uninstall of Webroot, then reinstall.  And yes, a reboot after uninstall/reinstall is always a good procedure when having any software problems.

<<<<CAUTION>>>> Make Sure you have your Webroot Keycode before you uninstall.  You can view it by opening Webroot, click on My Account, it should show under the keycode tab.

Hope that helps for everyone

Webroot Uninstall/Reinstall worked for me

Issue only raised its head after win11 cumulative update for me Firefox was already updated beforehand and working fine

FWIW the win11 update also cruelled Authy but several restarts later Authy was ok

Have not heard from customers at this point, fingers crossed

Userlevel 3
Badge

Feb. 10 2022

I had the same problem that as soon as I updated Firefox to 97 it stopped working and I do have webroot and I am running Window 10 64-bit. 

I fixed this by opening Webroot, going to Identity Protection => Application Protection. Firefox was listed.  First thing to try is click on the Allow radio button.  Close webroot then see if firefox works. 

If not then go back into Webroot Identity Protection => Application Protection and right click on the firefox entry and delete it. Then click Add protection at the bottom and  navigate to firefox.exe and add this.  Finally  click the Allow radio button.

My Firefox started working immediately after this change.

I hope this makes sense and helps.

 

After you uninstall and reinstall Webroot, what does the Application Protection entries for Firefox look like in Webroot Identity Protection → Application Protection?  I did the solution above and it worked without uninstalling Firefox or Webroot.  But, I’m wondering, does changing the application setting from Protect to Allow open to any threats?  This is certainly a simpler fix then an uninstall/reinstall.  It also fixed my problem with Chrome that I’ve had for a year.

 

 

Userlevel 2

On my 64 bit windows 10 there is no problem as stated above. I even have a second browser opened.

Userlevel 2

On my 64 bit windows 10 there is no problem as stated above. I even have a second browser opened.

 

Thanks. It’s working now……...magically lol. Stupid computers!!  I simple reboot seemed to have remedied the problem.

Userlevel 3
Badge

I followed the uninstall/reinstall and it seems to be working okay.  When I go into the Identity Protection, there is only one item, Firefox listed.  Neither Chrome or Edge are listed, but appear to be working.

 

 

When I reinstalled Webroot following the instructions, I also noticed a duplicate entry in the Webroot Console for my PC.  I just removed the older item.

 

 

Hopefully this will be resolved completely this time.  Last year I had problems with Chrome and I sent an ticket to Google and they couldn’t identify or resolve the issue, so I uninstalled Chrome and stopped using it.

 

I had the same problem. Tried uninstalling Firefox and reinstalling. Tried running in compatability mode. Contacted Geek Squad. They found a large number of temporary internet files and deleted them. They also said they found that a page I had visited had hung and they updated my settings to avoid that. Firefox now runs fine.

Userlevel 3
Badge

This evening Webroot started blocking FireFox from loading again.  Just prior, my PC installed two updates:

I had used Firefox for several hours today without any problems until my PC installed the above updates.  I can’t tell if Webroot installed an update.

I verified that FireFox was still listed under the Application Protection as “Protect” under the Identity Protection tab.  I removed the line for FireFox, it still wouldn’t load.  I re-added it manually with the “Protect” button set and wouldn’t load.  When I changed the status to “Allow”, it would load.

 

Also, I have Chrome and Edge installed and they still function fine.  However, they weren’t automatically added to the Identity Protection → Application Protection by the reinstall of Webroot when this was identified 3 days ago.  I also didn’t manually add them.

I didn’t try to uninstall and reinstall Webroot, because my guess is that it would work only temporarily.

Is there still a problem that Webroot hasn’t fixed permanently?

Userlevel 3
Badge

Hello everyone!

 

Firefox released a new update 97.0.1 so update ASAP and let us know how things go!

 

Fixed

  • Fixed an issue where TikTok videos would fail to load when selected from a user's profile page (bug 1750973)

  • Fixed an issue which led to Picture-in-Picture mode being unable to be toggled on Hulu (bug 1753401)

  • Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations (bug 1752466)

  • Fixed an issue causing users to see the Restore Session screen unexpectedly when starting Firefox (bug 1749996)

Thanks  @TripleHelix , It appears to be working for me now.

On Tuesday, after my PC installed a Windows 10 update, Firefox stopped working again.  I had to set the Identity Protection → Application Protection to “Allow” for Firefox to work.  Webroot Support said to uninstall and reinstall again to fix.  Hopefully this fix from Firefox will continue to work after subsequent updates from both Webroot and Firefox.

if history is anything to go by, the Chrome and Identity Shield issue took far too long to resolve. we couldn’t work out why it affected only some users and not others. we thought this was a Chrome issue until eventually we discovered it was a Webroot issue.

this issue was reported back in January 2021 and we didn’t have the new build available to push out via Webroot Anywhere until November 2021. that’s way too long to fix a reported issue.

During 2021 we simply changed over anyone who called our helpdesk from Chrome to Edge. it was such a pain.

 

Userlevel 7
Badge +63

Hello @wizdude 

 

I agree and in the end Webroot stopped injecting itself into Chrome, we don’t get details since Webroot is now part of Opentext a public traded company but hopefully Webroot working with Mozilla and I find the issue gone since 97.0.1 came out.

 

HTH,

Userlevel 2

We also have this issue, where Firefox 97 will not respond at all, until Webroot is disabled.

Userlevel 1

Firefox needs to be set to open in compatibility mode. Google Chrome has/had the same issue a month ago and having it open in compatibility mode was the only thing that worked until Chrome released a new update or Webroot did. 

Unfortunately that is the only fix I have found that works for my customers without all of the somewhat complicated mess that was suggested above - respect due where needed, not shaming the work and person whom suggested.

Userlevel 2

 

 

I did a clean reinstall of WSA and so far FF 97 is working fine.

 

I added Edge and Zoom manually.

 

 

 

How did you add the applications manually? When I click the “Add Application” button, it does nothing. it just sits there. I tried reading through websites and the Webroot manual, but it simply says click the add application button. But for me it doesn’t work. Only application listed for me is  Firefox, I would like to add a few others.

 

Userlevel 1

Update to Firefox 97.0.1 followed by restart of laptop does not change anything here…. Still have to change compability mode to Windows 8.

 

perjak

We just started having issues with Microsoft Edge.  Been having issues with Firefox for a few weeks now.  The only solution we’ve found that actually lets the browser either open or successfully access websites is putting the browser in Compatibility Mode (Windows 😎.  Yes, we’ve cleared browsing history, temp files, Firefox profiles, Edge profiles, uninstalled and reinstalled Firefox

Our experience has been spotty but all issues seem to dovetail with Windows 21H2, Firefox 97+, Edge 99, and Webroot 9.0+.

Since I’ve got 18 customers with upwards of 500 computers in play, the idea of removing Webroot and reinstalling it so I can get past this issue is not desirable.  Does Webroot have any version releases in the works?  The idea of removing application protection from the browsers in each company’s policy concerns me that I’m opening up the possibility of threats via the Internet browsing these customers do daily.

Firefox browser won’t run on Dell laptop running Windows 10 unless “compatible with Windows 8 is checked”.

Mozilla Firefox tech support said there is a problem with Webroot and the lastest version of Firefox.

Is there a fix for this issue?

Userlevel 1

Firefox is now ver. 98.0.1. I still have to choose ‘Windows 8 compability’ to make it work…

The problem persists, now after a month. Amateurish.

I have been a Webroot customer for many years. Will not resubscribe when this subscription ends.

Maybe I will opt out before...

Userlevel 1

Maybe not, but I do.

Userlevel 2

I had to completely uninstall Webroot Security from Laptop. “Disabling it”  (turning off realtime Shield, Web Shield, Firewall) didn’t work. I could open Firefox, but would sit there idle, with a blank screen.

 

I wanted to “downgrade” Firefox back to version 96.0.2 (or whatever it was previously) but finding and downloading the exact link is not as easy as I remember. It will be easier to just wait until Webroot fixes this.

 

I’ll use Windows antivirus until Webroot fixes :thumbsdown:

Userlevel 1

Since I’ve got 18 customers with upwards of 500 computers in play, the idea of removing Webroot and reinstalling

Hello,

500 computers???

Out of curiosity, is there anywhere a list with big players /large companies using Webroot???

Will make me feel much better.

Thanks.

but hopefully Webroot working with Mozilla and I find the issue gone since 97.0.1 came out.

 

My understanding is that Mozilla fixed the problem with no assistance from Webroot. You can read the Mozilla bug ticket 1752466 where Toshi installed Webroot and analysed its behaviour and debugged the issue. He (and others) then approved for WRusr.dll to be added to the blocklist in Firefox to work around the problem.

They also noted that “this block only applies to the current version of WRusr.dll. Newer releases should be unaffected by this change”.

What this means is the bug still exists in Webroot and if they release a new version of WRusr.dll without the bug being fixed that this same issue may reoccur.

I hope that it doesn’t take another 10 months for Webroot to fix this bug as well. I’m kind of over this level of support. This is what you would expect for a free product, not something we are paying for.

a comment in the Mozilla thread by “Dalacor”: I must admit I am a bit surprised at the very slow response and lack of communication from Webroot in addressing this issue given the severity of the impact on Firefox and as result the Internet. It has been over a week [now over 2 weeks] since this was reported to Webroot. I would have thought that they would have made this a priority to address.

a comment in the Mozilla thread by “Marcel”: Everyone using Webroot should open tickets, this is what I just did, if they get zillion tickets on the same subjets, they might put a bit more efffort in handing their product.

 

Reply