Question

Webroot Not Allowing Apache to Access Port 80


Good morning.

Today, and out of the blue, the localhost Apache server stopped working and left error messages that Port 80 was in use. I rebooted the machine. No cigar. I did check after check with netstat and it was, and is, very clear that Port 80 is not and was not in use.

Since the port was not in use, on a hunch I shutdown WR and bingo Apache on Port 80 worked fine. What confuses is that I did not touch WR prior to these messages. They just started happening and I've no idea how to get this to stop.

2 replies

Userlevel 7
Badge +55
Good Morning @wolfiejunk,

Welcome to the Webroot Community

Please have look here and see if this helps.. https://answers.webroot.com/Webroot/ukp.aspx?pid=17&vw=1&app=vw&solutionid=1601
and here https://community.webroot.com/knowledge-base-76/recommended-proxy-firewall-bypass-list-55156

Let me ping @TripleHelix or @Baldrick for added assistance.

You can also Contact the Webroot Support Team by Submitting a Support Ticket and they can certainly fix this issue for you ASAP.
Many thanks for the links... WR was indeed blocking the connection to httpd.exe for Apache,and when told to allow the connection the problem was solved.

Because of the error, "Port 80 in use", thrown by Apache, it was a very long morning looking for some hidden devil that was in fact using that port while somehow masking its presence.

For FYI and that of the devs, it is still a mystery why this occurred; why WR thought it needed to block that process.

The localhost server, Largon, has been running along quite nicely for some months with nary a peep and much faster than others. Nothing was done this morning under that localhost other than to install another instance of Word Press, which worked fine.

Then, for no reason it all fell apart and now we know why, if not how that occurred. If folks have information on the cause then please share.

Thanks again for the links. It was a difficult little bug to squash and let's hope it was, unlike cockroaches which will always prevail, gone for good.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept or continue browsing you agree to our cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings