Question

Win10 BSOD - KeePass and Webroot - cldflt.sys

  • 21 October 2019
  • 8 replies
  • 1692 views

Badge +3

Hi team,

I’ve been troubleshooting an issue that’s propped up on my laptop. Context:

  • Windows 10 x64 - patched up with all available updates
  • Surface Pro 5 - i5/8Gb/256
  • Dropbox
  • Office 365, including all Office apps
  • OneDrive configured to sync a number of libraries. Files On Demand enabled.
  • Keepass (any version)
  • Keepass database file stored in the Dropbox folder
  • Webroot SecureAnywhere 9.0.26.61

 

 

 

Previously everything worked fine. The process I’m about to describe is something I would use multiple times a day (sometimes, multiple times an hour) and it would work perfectly. About 2 weeks ago, I started getting BSOD from Windows - completely repeatable.

  • Open KeePass, and open the database file stored in the Dropbox folder. 
  • Keepass opens fine, and decrypts the password vault. I can see / add / change password entries or anything else within the database file.
  • If I SAVE the file, or if I CLOSE the Keepass app, this now triggers a BSOD within windows - faulting module is cdflt.sys (the OneDrive Cloud Filter driver file).
  • HOWEVER! If I open the file and SAVE AS to a different file name (either in Dropbox, or OneDrive, or a local folder on the PC) - no problems. Until I try to SAVE *that* file, and it blue-screens straight away.

I’ve rebuilt the PC a number of times now from scratch, and the problem does not occur at all until I install WebRoot. As mentioned, up until a couple of weeks ago this was bulletproof. I’ve not updated Keepass itself, but obviously somethign is getting triggered by the way it does it’s file operations. 

I’ve tried:

  • Disabling the Real Time Shield in Webroot via the policy console (and updating the config of the local agent). Real Time Shield turns off in the local Webroot app. Problem still exists.
  • Disabling the Identity Shield in Webroot via the policy console. Problem still exists
  • Adding the c:\Windows\System32\drivers\cldflt.sys file to the Overrides section in the policy console. Hard to tell if the local agent picks up this change - the date/time stamp on the c:\ProgramData\WRData\Ovr.db file does change. Problem still exists.
  • Adding the C:\Program Files (x86)\KeePass\*.* files to the Overrides section in the policy console. Problem still exists.

As a workaround, I’ve installed the alternate KeepassXC app, which is working seamlessly. That said, I’d rather go back to the official app if I can get this sorted. 

Is anyone else seeing this behaviour with Keepass and WebRoot? What can I do to either fix this, or bypass the webroot protection for this scenario?

Cheers,

Matt

 


8 replies

Userlevel 7
Badge +55

Hello @Matt_Ignites ,

 

Welcome to the Webroot Community,

 

Sorry to hear that you are having issues and for all the inconveniences related. As of late I have not heard of this issue with Keepass and Webroot.

 

I would first do a clean Uninstall/Reinstall of Webroot to see if that resolves the issue. If it does not then please reach out to the Webroot Support Team so they can gather logs and to investigate.

 

Support Number 1-866-612-4227 M-F 7am - 6pm (MT)

Submit a Support Ticket HERE.

 

Hope this helps?

Badge +3

Hi @Ssherjj ,

Thanks for helping.

I’ve done a number of complete rebuilds/re-images on this device, so we’re already checked off the uninstall/reinstall path unfortunately.

I’ve got a support ticket in the system now, but unfortunately the logs don’t capture the actual event.  I’ll keep working with the team, and hopefully we’ll get a resolution soon. I’ll post back when we do.

Thanks!

Matt

Userlevel 7
Badge +55

You're most welcome Matt,

 

Good luck and please do keep us posted. We'd be curious to know if this was resolved for you or not.😊

Badge +1

I want to echo Matt’s concerns and issue.  I have the same problem.  Win10 Pro, KeePass saves results in BSoD.

 

I’ve done the uninstall/reinstall cycle as well.

 

--

DaveN

Running Windows 10 build 1903, I'm very often getting a BSOD when closing keepass.
System Service Exception is pointing to cldflt.sys [...]

FWIW ~ https://sourceforge.net/p/keepass/discussion/329221/thread/924b94ea48/#8698

Badge +3

I think bjm_ has it here. In the interveening days, I’b been sent this on reddit across this which seems to be the same issue:

https://sourceforge.net/p/keepass/bugs/1891/

That thread claims that the Microsoft patch kb4522355  resolves the issue. I’m going to install it now and see how we go. 

Cheers,

Matt

Badge +1

I began having these same problems around the same time as the OP. I’ve been going crazy trying to troubleshoot this issue because, until this began happening, my system was as stable as a rock. However, I do not use Keepass; I use a different password manager (LastPass). I’ve been uninstalling/reinstalling various drivers, 3rd party applications, and everything else I could think of to pinpoint the source of the instability. I’ve been selectively disabling/re-enabling various cloud-service applications, too, since many search results point to this cldflt.sys system service error stemming from an update of OneDrive as the culprit.

But none of my troubleshooting attempts made the least bit of difference, including stopping the OneDrive service or preventing it starting up upon boot. My system would randomly crash on occasion, but ALWAYS after it’d been left alone for some time (even with all power-saving items enabled). 

Yesterday, I found a Microsoft article suggesting that these errors are occasionally created by a conflict with antivirus software. At my wits end, I thought I’d give uninstalling Webroot a try. 

Since uninstalling Webroot, the system has been stable and remained running last night without rebooting for the first time in almost a month (before these problems started, my system would commonly go without rebooting for months at a time, unless an update forced one).

I’m currently watching and waiting for another day to see if the removal of Webroot indeed fixed this problem.  If so, I’ll try to reinstall with the most current version, to see if the system remains stable.

Badge +1

As a follow up, with Webroot uninstalled, I re-enabled the OneDrive service and continued to have no problems with system stability. Currently up to date with Windows 10 v1909 build 18363.476.

After a day without a problem once I uninstalled Webroot SecureAnywhere, I tried to reinstall it using the latest version from the Webroot web site. Within two hours, my system generated a SYSTEM SERVICE ERROR stopcode, pointing to cldflt.sys. It happened while I was playing a game, and again later sometime after I left my system unattended for a couple hours.

Uninstalling Webroot again has returned my system to a stable state. At the moment, I’m using only the Windows 10 native Defender AV (which is not optimal!). I have not yet tried installing a different AV software (I’ve used Webroot for 10 years or so and hate to migrate away, but...).

FWIW, I use Webroot on multiple systems. One of my laptops generated this same cldflt.sys BSOD one time, a couple of weeks ago, but since then has had no further problems. I cannot say why my desktop became incompatible with Webroot after one of the Oct 2019 Windows updates, but I’m happy to help provide logs if it’ll help the Webroot folks identify what might be causing the conflict.

Reply