NVIDIA GeForce Game Ready Driver 375.63

  • 23 October 2016
  • 33 replies
  • 350 views

Userlevel 7
Badge +51
NVIDIA GeForce Game Ready Driver 375.63http://us.download.nvidia.com/Windows/375.63/375.63-win10-win8-win7-desktop-release-notes.pdfDownloadhttp://www.nvidia.com/Download/Find.aspx?lang=en-us

33 replies

Userlevel 7
Badge +62
Thank you Petr. I think my Nvidia Driver on my desktop is 375.58. So good to know! 🙂
Userlevel 7
Badge +62
Hi Daniel and BurDaddy!
 
I won't worry about it then! 
 
Thanks to both of you for your help! I learned a lot from this! 😉
Userlevel 7
Badge +56
@ wrote:
Thank you Petr. I think my Nvidia Driver on my desktop is 375.58. So good to know! :)
These two will not install on my Laptop so I'm still on:
 
?
Userlevel 7
Badge +62
Well Daniel...Ill check what version I have on my laptop when I get home. But I do know that the desktop won't install the latest driver...for some reason.
Userlevel 7
Badge +62
Daniel this is what I have: Fort some reason it won't install this driver: 375.57
 
?
 I haven't tried these newer drivers yet. Should I? ?
 
?
 
 
 
Userlevel 7
Badge +56
@ wrote:
Daniel this is what I have: Fort some reason it won't install this driver: 375.57
 
?
 I haven't tried these newer drivers yet. Should I? @
 
?
 
 
 
I don't see 375.57 listed?
Userlevel 7
Badge +62
I did an automatic GeForce update and it gave me the 375.57 which is paused and won't install so I did a manual like you've told me before awhile back and it gives me these updated drivers now. Should I try 375.63?
Userlevel 7
Badge +62
Daniel I am going to try and install it. I'll be right back!
Userlevel 7
Badge +56
I had to shut down WSA for it to install but the Monitoring isn't that high? 4 is nothing and shouldn't affect installing this Driver.
 
Sun 2016-10-23 21:25:59.0158 Monitoring process C:Program FilesNVIDIA CorporationDisplay.NvContainerNVDisplay.Container.exe [E655DE6F499E7645C7ACBD580D01A9AE]. Type: 3 (8907)
Sun 2016-10-23 21:25:59.0158 Monitoring process C:Program FilesNVIDIA CorporationDisplay.NvContainerNVDisplay.Container.exe [E655DE6F499E7645C7ACBD580D01A9AE]. Type: 4 (8907)
Sun 2016-10-23 21:25:59.0158 Monitoring process C:Program FilesNVIDIA CorporationDisplayvxdsync.exe [0DC88E3DAC34BF89DCB7FF58AF092322]. Type: 2 (8909)
 
But 6 to 8 is high!
 
Sun 2016-10-23 21:05:19.0412 Monitoring process C:WindowsSysWoW64grpconv.exe [09C1AB402E7B63EDDA6D7A83E05EA76F]. Type: 3 (8923)
Sun 2016-10-23 21:05:19.0412 Monitoring process C:WindowsSysWoW64grpconv.exe [09C1AB402E7B63EDDA6D7A83E05EA76F]. Type: 4 (8923)
Sun 2016-10-23 21:05:19.0412 Monitoring process C:WindowsSysWoW64grpconv.exe [09C1AB402E7B63EDDA6D7A83E05EA76F]. Type: 5 (8923)
Sun 2016-10-23 21:05:19.0412 Monitoring process C:WindowsSysWoW64grpconv.exe [09C1AB402E7B63EDDA6D7A83E05EA76F]. Type: 7 (8923)
Sun 2016-10-23 21:05:19.0412 Monitoring process C:WindowsSysWoW64grpconv.exe [09C1AB402E7B63EDDA6D7A83E05EA76F]. Type: 8 (8923)
Sun 2016-10-23 21:05:39.0489 Monitoring process C:Program Files (x86)NVIDIA Corporation3D Visionvstlink.exe [0B1EE57699586E3E7E4F5DE50DE93272]. Type: 3 (8906)
Sun 2016-10-23 21:05:39.0489 Monitoring process C:Program Files (x86)NVIDIA Corporation3D Visionvstlink.exe [0B1EE57699586E3E7E4F5DE50DE93272]. Type: 4 (8906)
Sun 2016-10-23 21:05:39.0504 Monitoring process C:Program Files (x86)NVIDIA Corporation3D Visionvstlink.exe [0B1EE57699586E3E7E4F5DE50DE93272]. Type: 8 (8906)
Sun 2016-10-23 21:05:44.0194 User process connected successfully from PID 10872, Session 0
Sun 2016-10-23 21:06:05.0979 Monitoring process C:Program Files (x86)NVIDIA Corporation3D Visionvstlink.exe [0B1EE57699586E3E7E4F5DE50DE93272]. Type: 3 (8906)
Sun 2016-10-23 21:06:05.0979 Monitoring process C:Program Files (x86)NVIDIA Corporation3D Visionvstlink.exe [0B1EE57699586E3E7E4F5DE50DE93272]. Type: 4 (8906)
Sun 2016-10-23 21:06:05.0995 Monitoring process C:Program Files (x86)NVIDIA Corporation3D Visionvstlink.exe [0B1EE57699586E3E7E4F5DE50DE93272]. Type: 8 (8906)
 
?
Userlevel 7
Badge +62
I don't understand what you mean by 6 to 8 is high?
 
I just noticed my 3D driver failed? It always does for some reason.
Hi Guys,
 
You only need the 3D driver if you have a 3D monitor, and the HD driver if you use an HDMI cable for audio. I use neither and therefore don't have either installed. That said, the 375.63 graphics driver installed without issue.
 
http://www.ghacks.net/2012/12/26/make-sure-you-only-install-nvidia-drivers-you-need/
 
Hope this info helps,
 
BD
Userlevel 7
Badge +56
@ wrote:
I don't understand what you mean by 6 to 8 is high?
 
I just noticed my 3D driver failed? It always does for some reason.
Try it again with WSA disabled! And look in the PUG about levels!
Userlevel 7
Badge +62
TripleHelix wrote
Try it again with WSA disabled! And look in the PUG about levels!
I disabled everything and 3D Vision Driver still failed. Should I of done a clean install (custom)?
Userlevel 7
Badge +62
@ wrote:
Hi Sherry,

I was still able to install all of the drivers, they installed with Nvidia Vision Experience. But I uninstalled that and all of the other drivers except the graphics driver. I don't play games on my PC so I don't use the PhysX driver, either.

BD
Okay Thanks ...I don't play many games but I do have some on here...Steam games
Userlevel 7
Badge +62
Hi BurnDaddy! 
 
This system i have isnt finding the 3D Vision Driver application...error is telling me to locate the folder/file. It's just not on the system. I am having issues with this PC as I'm still waiting from Dell to get my second replacement. So I'll save my energy for my newer system that should be here sometime this week. As I feel I'd need to do a clean reinstall and I'm not going to do that on a system that I am returning anyways. I have to wipe it out before sending back as well. 
 
Thanks for your help! 
Userlevel 7
Badge +56
@ wrote:
Hi BurnDaddy! 
 
This system i have isnt finding the 3D Vision Driver application...error is telling me to locate the folder/file. It's just not on the system. I am having issues with this PC as I'm still waiting from Dell to get my second replacement. So I'll save my energy for my newer system that should be here sometime this week. As I feel I'd need to do a clean reinstall and I'm not going to do that on a system that I am returning anyways. I have to wipe it out before sending back as well. 
 
Thanks for your help! 
Yea don't worry about it as I'm very concerned about NVIDIA drivers over the past year and we don't need updated drivers unless we are hard gamers.
Hi Sherry,
 
Like Daniel said, I wouldn't worry about it. Especially if you don't have a 3D capable monitor. You don't even need it. :)
 
BD
Userlevel 7
Badge +56
See I tried this version maybe I need to do a clean reinstall?
 
?
Userlevel 7
Badge +62
Wow weird...that isn't good at all. Well I'll try to install it and let you know. Sometime tonight....
Userlevel 7
Badge +56
@ wrote:
Wow weird...that isn't good at all. Well I'll try to install it and let you know. Sometime tonight....
Make sure it's the laptop version!
Userlevel 7
Badge +62
@ wrote:
@ wrote:
Wow weird...that isn't good at all. Well I'll try to install it and let you know. Sometime tonight....
Make sure it's the laptop version!
Okay I'll make note of that. ;) 
Userlevel 7
Badge +56
Mine is screwed up some how and I got it installed in Safe Mode but it's not working correctly. There was something wrong with my install of the older one? Maybe need to do a clean reinstall of the OS again. 😠
Userlevel 7
Badge +62
I got it installed! Cool! I didn't have to disable Webroot..
 
?
Userlevel 7
Badge +62
@ wrote:
Hi Guys,
 
You only need the 3D driver if you have a 3D monitor, and the HD driver if you use an HDMI cable for audio. I use neither and therefore don't have either installed. That said, the 375.63 graphics driver installed without issue.
 
http://www.ghacks.net/2012/12/26/make-sure-you-only-install-nvidia-drivers-you-need/
 
Hope this info helps,
 
BD
Thanks @ for that tidbit! Now I know why! LOLs I thought I had a 3D monitor for games...
Userlevel 7
Badge +62
@ wrote:
@ wrote:
I don't understand what you mean by 6 to 8 is high?
 
I just noticed my 3D driver failed? It always does for some reason.
Try it again with WSA disabled! And look in the PUG about levels!
Okay will do right now and install GeForce driver again!

Reply