Solved

Copy/Paste Stops Working in some applications

  • 15 January 2013
  • 55 replies
  • 839 views


Show first post

55 replies

Userlevel 6
Hello @ and welcome to the community!

 

Sorry you have had an unpleasant experience. I am however happy to hear that you found this thread to solve your issue.

 

The reason it is set by default is to protect you by blocking applications that it does not recognize from accessing your personal and sensitive information. 

 

Very few people have had an issue with this setting. The link explaining this setting including instructions on how to manage application protection is in this thread. You can find that information here as well.

 

There is a wealth of information in the community. Feel free to browse our Knowledge Base

 and the Help and Product Guides.

 

Should you need further assistance in the future, feel free to ask, we are here to help. Our top notch tech support team is available as well. You can send a message to them here 24/7. If you prefer to reach them by phone, they are available  Monday thru Friday from 7am?6pm Mountain Time at 1-866-612-4227.

 

I hope that helps!

 

Beth

 
I had paste feature break in my development environment and was blaming it on many other programs before I found this option to disable inside of Webroot:

 

Advanced Settings -> Shields

"Silently and automatically block untrusted access to user data"

 

PLEASE, for every one else's sanity - this should not be checked by default.

When I unchecked it, I got a popup about accessing the clipboard and I approved it.

Without the popup, I had no idea why my paste stopped working.

Sometimes it would start working if I closed all my web browsers.

I even tried switching web browsers and reinstalling my entire development suite several times.

I also opened a bug with Scintilla which is the editor I was using.

 

The fact that it blocked me from copying and pasting from inside of a single app is also confusing.

How could you consider an app to not trust the data that the app already has?

 

I would be switching all my computers to Bitdefender if I hadn't been a victim of their boot bug problem on several PCs.

It is disapointing to see that there have been many other compaints about this issue and it's still not fixed.
Userlevel 6
Badge +24
Journal and Evernote works fine by me with WSAC running.
Userlevel 7
Much as I dislike saying so, the identity shield has been a pain in my side since beta years ago. I finally decided to look at some of the raw stuff going on and it turns out that most of the pain it creates is caused by other programs not handling things properly.

 

As a good example, in beta Outlook was blocked from accessing just one little bit of Internet Explorer via the DLL system (Outlook uses IE functionality to display email messages, pretty much). This bit was never anticipated by Outlook coders to ever be restricted, so Outlook's thread would block and stop running, waiting forever for a reply from the IE subsystem that it would never receive. The same thread handled mail fetching. So incoming mail from the exchange server would stop arriving. The bit that was blocked would not cause any other problems in Outlook, but the coding on Outlook caused it to hang forever because it received no response at all.

 

Even now at my current work, I see all kinds of odd effects from the identity shield. One fun one I've seen is when it blocks the Dell Touchpad software's ability to interact with the mouse pointer in rare circumstances after copying data from a browser and trying to paste it somewhere.  I want the ID shield to be an awesome and clean thing, but until other programmers put error traps in EVERYTHING (even things that "should not be capable of failing, ever"), it's a messy situation. 😞
Well, this one was quite the anomaly.  The application was The Journal, which is, well, journal software.  As such, it's basically word processor tailored to writing journals.  I've never seen that particular situation before or since in any program; although, on occasion it will deny pasting to something that had been allowed before, and, as I said, for no reason I can discern.  I can't intentionally make it happen.
Userlevel 7
Hi mikespeir, 

@ wrote:

The weird thing is I cut and paste all the time and I have NEVER come across this issue...which suggests that there is some very specific cause to it.  

Well..., I can fully confirm this! 

I haven't noticed the described issues on any of my machines, where WSA is the first as well as the only line of defence against threats.

 

 

Oh..., by the way... 

@ wrote:

Rant noted...but at the risk of annoying you further you are ranting in the wrong place.  We are mainly volunteers here with no commercial affiliation to Webroot

A Big Kudo for you Baldrick!

 

Regards,

 

Mike

 
Userlevel 7
Hi mikespeir

 

Thanks for the feedback.  The weird thing is I cut and paste all the time and I have NEVER come across this issue...which suggests that there is some very specific cause to it.  Can you reappraise me as to exactly where the application was 'Deny'ed?

 

Cheers

 

 

Baldrick
I just realized I never got back to anybody on this.  The reason is that I can't find any predictability to the problem.  The other day I had an application open and pasted something into it.  Keeping the application open all this time, mind you, I came back a few minutes later and tried pasting again.  No go.  I couldn't believe it!  I went into identity shield and, sure enough, that application was set to Deny.  Again, I hadn't even closed the application between pastes.

 

As a former developer myself, I know that there has to be some predictability to a problem before you can fix it.  But I haven't found any rhyme no reason to it. 
Userlevel 7
Hi Ohzman

 

Rant noted...but at the risk of annoying you further you are ranting in the wrong place.  We are mainly volunteers here with no commercial affiliation to Webroot.

 

And if you are looking for a refund then again, you are looking for it in the wrong place...you should be contacting Sales Support (please see this link which outlines such thinkgs and provides contact detail, etc.) 

 

Hope that helps a little.

 

Regards

 

 

Baldrick
Userlevel 7
Badge +51
"You can provide additional security for software applications that may contain confidential information, such as Instant Messaging clients or tax preparation software. By protecting these applications, you secure them against information-stealing Trojans like keyloggers, man-in-the-middle attacks, and clipboard stealers. You can add any applications to the Protected Applications list and assign them to one of the protection levels"

http://www.webroot.com/En_US/SecureAnywhere/PC/WSA_PC_Help.htm#C6_IDProtection/CH6c_ManagingProtectedApps.htm

You need to allow the application which is connected with the problem

What you want to do is access the Identiy Shield tab and click on the Protected Applications link.  This will open the section that configures the apps that you want to "Protect" from data stealers and to "Allow" access to system data.  Change your  program to "Allow".  

 
You can't even imagine how frustrating you made my life for the past few days and just by pure luck, i gave a thought to this and solved my problem by turning off the identity shield.

 

I am a translator and constantly use Sisulizer 3 translation software. I had to rush a translation that had many copy/paste situations that i could benefit from but NOOOO. Your precious anti-virus was silently HINDERING all the paste actions that are done partially within cells but whereas letting me paste the cell alltogether to another one just to confuse me more on finding the root of the problem.

 

If it wasn't just for some crappy windows support site that is filled with spam that i see sb glabbering about webroot hindering any copy/paste in his comp.

 

And do you know that the best part is ? Secure Anywhere actually prompt me to ALLOW the application, to seemingly let me choose if the software is allowed or not: And here the plot thickens as i select allow always and the identity shield is actually the my evil step-brother that loaths to hurt me discretely everytime i trust him and turn my head around.

 

In 2004-5 you were a great company, cool software, no slowing down, no crashes or unwanted infections. Somewhere around 2008 you started to degenerate and it wasn't for 3 pc license that i also use on my parents computers, you would have been long gone, guys. Believe me.

 

Btw this is purely to rant about how bad you have become and how actually your anti-virus did cost me hours of more manual work on the keyboard grinding the same sentences over and over again + the frustration of trying to find the root cause.

 

Shame on you.

 

Now take a step back and see the picturesque view of my hatred towards your software. If you want to show any kind of remorse whatsoever just offer me a FULL refund and i will gladly take it back.

 

Otherwise you may just as well reply me as " SUCK IT" because you are already on my untouchables list.

 

This was a tutorial on "how cheaply hard-coded lame anti-virus may cripple your soul and secretly wishes you to die in agony"

 

Thanks for nothing.

 

Bah !
Userlevel 7
Hi mikespeir

 

Thanks...that would be useful...and I for one a prepared to try to corroborate what you are seeing.  So please posted back here even if you open that Support Ticket.

 

What OS/version are you running, as a matter of interest? ;)

 

Regards

 

 

 

Baldrick
I'll do some experimenting and see if I can identify more of the particulars of when it's happening.
Userlevel 7
Hi mikespeir

 

Apologies if I was trying to teach 'my granny to suck eggs' so to speak. :$  Nt know what level of knowledge that you have of WSA I thought it best to start with the basics.

 

As dtouch says...it would be interesting to understand when this settings 'reset' may have happened?  I have never come across it on my own systems...but that does not mean that it does not happen.

 

May I suggest that you set the settings as you want them/prefer them...and then periodically check to see if there has been any change...as and when there are further changes then I would suggest that you Submit a Support Ticket with all the information so that the Support Team can take a look.

 

Regards

 

 

 

Baldrick
I work doing I.T. and this feature was supposed to be fixed on and update and it wasnt, so unfortuantly I had to uninstall it to be able to read my tickets from my company.

I installed the free bitdefender and have no issues with this.
Userlevel 6
Badge +24
When do you observe such change in settings? Does it happen only for a certain application or many?

Following program updates certain apps settings gets reset.

 
Well, thanks, but that's what I already do.  For some reason (and it may be a variety of reasons) the setting gets changed back unexpectedly.  I'm just having trouble seeing the need for that.  Granted, it's something that could be exploited.  But I used Norton (Symantec) for years and I don't remember it ever doing anything like that.  (On the other hand, if I'd been happy with it, I would've stuck with it, right?)  WebRoot, I think, employs a fairly unusual approach to combating malware and shareware, and it's served me well so far.  If not for this one annoyance, I'd have no real gripe at all.
Userlevel 7
Hi mikespeir

 

Welcome to the Community Forums...:D

 

dtouch is quite correct re. what he says and all you should need to do is to set the app concerned to 'Allow' under 'Application Protection' tab in the advanced settings for the Identity Protection section (click on grea/cog to the right of the section heading in the main WSA panel).  Of course, you should make very sure that you trust the app that you 'Allow' before allowing it.

 

And for more information & guidance in relation to this and similar areas of WSA, that can confuse users, please see this KB Article which should explain all that you need to know, but the section entitled 2. Identity & Privacy > Protected Applications is most pertinent to you OP.

 

Hope that helps?

 

Regards

 

 

Baldrick
Userlevel 6
Badge +24
I have never had an issue with it after allowing certain programs under application protection list, unless maybe after an update, wsa detect it altogether as new program and you have to allow it again in application protection list under identity shield.
Userlevel 7
Badge +56
Sorry for the aggravation.  The problem is that a new program, especially one you might have written yourself, won't be recognized and will block by default.  You can't turn off just that feature - you'd have to turn off the Identity Shield function.  You could submit a Feature Request for more granularity on that feature.
This is getting really aggravating.  Anytime I install a new program it iniitially isn't allowed to receive pastes.  I've never seen another malware or virus protection program do that.  Of course, I can then go into Indentity Shield and fix it.  But sometime it surfaces again, for reasons I don't understand, and for the very same programs.

 

Most annoying is that I do some programming myself.  Very often, a newly compiled program will be denied receiving pastes.  And it happens over and over.  Even if I fix it in identity Shield, a new compile will often result in the same problem again, for the same program.

 

Is there some way to turn off this feature and this feature only?
Userlevel 7
O.o

 

True, I may not reply.  Or I might...

 

Setting the browser to Allow as a whole does remove specifically a few parts of ID shield protection from the browser, but is useful for troubleshooting. Turning off the ID shield completely turns all of it off.

 

A better way to do it is to look for anything you recognize as safe that is marked as "Deny" in the ID Shield and set it to allow. Also get Unknowns of stuff you run while working with the tickets to Rak for determination, since Unknown things can get silently blocked by the ID shield in some configurations.
Userlevel 7
Are you using a 3rd party app to interact with the browser? If so I could whitelist any 3rd party apps. As for leaving the browser on allow you are still protected from threats that are downloaded to your PC. The malware engine and threat detection is still running regardless of the setting. The entire browser shield is being completely reworked for our next realise and should elimate this type of issue.
I work for a company and I have to use my browser to see customer tickets, but when I attempt to copy and paste, webroot is blocking that functionality I have went into that area described above and checked "Allow" for I.E., Chrome and Firefox. Is there some other way to tweak this in Webroot instead of that option so that it is actually protecting the browsers ? or no?.
Userlevel 7
Hi peacefl,

Kit is no longer with Webroot, so he might not reply (though he's more than welcome to!). However, this topic is six months old, and the issue in question may not even be an issue any longer. Are you encountering a problem with copy/paste? Does the problem go away when you disable the Identity Shield? Which program is having the issue?



To answer your question, if you were to choose to allow for a browser, yes it would make the browser vulnerable at least insofar as the protection offered by the Identity Shield specifically is concerned. You would still be protected against malicious executables trying to target a browser because of Webroot's other shields, but certain other avenues could be open to attack at that point.



If you can specify some details about the problem you're running into, I'm sure we can help.

Reply