Copy/Paste Stops Working in some applications

  • 15 January 2013
  • 55 replies

I have an issue with a couple of users who have Webroot Secure Anywhere Complete installed.
I have been using your products for over 5 years now and recommend them to anyone and everyone, however the exclusion issue may be going to cause me a problem today!
These users are using a database application and intermittently they lose the Copy/Paste functionality in this application and indeed on the whole PC, one is Windows 7 the other Windows XP.
The database support department have been approached and we were advised to turn off Webroot and see what happened.  Turns out that turning Webroot off alleviates the Copy/Paste functionality not working, so it looks as if Webroot is the root cause.  I will say that my investigations have uncovered plenty of noise on the Internet of users with similar issues where other applications and functionality have been highlighted as possible causes ie RDPclient.exe etc.
Anyway, the DB vendor has advised that we exclude a couple of folders from the realtime scanning and see if that fixes the issue with Webroot turned on....
...over to you 🙂, before I take the decision to find an alternative.
Edit: Split off into new topic - Kit

Best answer by Kit 15 January 2013, 17:22

View original

55 replies

Well, this one was quite the anomaly.  The application was The Journal, which is, well, journal software.  As such, it's basically word processor tailored to writing journals.  I've never seen that particular situation before or since in any program; although, on occasion it will deny pasting to something that had been allowed before, and, as I said, for no reason I can discern.  I can't intentionally make it happen.
Userlevel 7
Much as I dislike saying so, the identity shield has been a pain in my side since beta years ago. I finally decided to look at some of the raw stuff going on and it turns out that most of the pain it creates is caused by other programs not handling things properly.
As a good example, in beta Outlook was blocked from accessing just one little bit of Internet Explorer via the DLL system (Outlook uses IE functionality to display email messages, pretty much). This bit was never anticipated by Outlook coders to ever be restricted, so Outlook's thread would block and stop running, waiting forever for a reply from the IE subsystem that it would never receive. The same thread handled mail fetching. So incoming mail from the exchange server would stop arriving. The bit that was blocked would not cause any other problems in Outlook, but the coding on Outlook caused it to hang forever because it received no response at all.
Even now at my current work, I see all kinds of odd effects from the identity shield. One fun one I've seen is when it blocks the Dell Touchpad software's ability to interact with the mouse pointer in rare circumstances after copying data from a browser and trying to paste it somewhere.  I want the ID shield to be an awesome and clean thing, but until other programmers put error traps in EVERYTHING (even things that "should not be capable of failing, ever"), it's a messy situation. 😞
Userlevel 5
Badge +24
Journal and Evernote works fine by me with WSAC running.
I had paste feature break in my development environment and was blaming it on many other programs before I found this option to disable inside of Webroot:
Advanced Settings -> Shields
"Silently and automatically block untrusted access to user data"
PLEASE, for every one else's sanity - this should not be checked by default.
When I unchecked it, I got a popup about accessing the clipboard and I approved it.
Without the popup, I had no idea why my paste stopped working.
Sometimes it would start working if I closed all my web browsers.
I even tried switching web browsers and reinstalling my entire development suite several times.
I also opened a bug with Scintilla which is the editor I was using.
The fact that it blocked me from copying and pasting from inside of a single app is also confusing.
How could you consider an app to not trust the data that the app already has?
I would be switching all my computers to Bitdefender if I hadn't been a victim of their boot bug problem on several PCs.
It is disapointing to see that there have been many other compaints about this issue and it's still not fixed.
Userlevel 6
Hello @ and welcome to the community!
Sorry you have had an unpleasant experience. I am however happy to hear that you found this thread to solve your issue.
The reason it is set by default is to protect you by blocking applications that it does not recognize from accessing your personal and sensitive information. 
Very few people have had an issue with this setting. The link explaining this setting including instructions on how to manage application protection is in this thread. You can find that information here as well.
There is a wealth of information in the community. Feel free to browse our Knowledge Base
 and the Help and Product Guides.
Should you need further assistance in the future, feel free to ask, we are here to help. Our top notch tech support team is available as well. You can send a message to them here 24/7. If you prefer to reach them by phone, they are available  Monday thru Friday from 7am?6pm Mountain Time at 1-866-612-4227.
I hope that helps!
Wow, finally figured out why several applications could not paste. Spent hours and hours trying to find a solution. Even returned a brand new computer because of this, thinking it was faulty. The company certainally lost money on that. I HIGHLY recommend turning this "feature" off by default. It was extremely aggrivating. 
Userlevel 7
EDIT:  Apologies, BoQu...I should have first welcomed you to the Community Forums...which I now do...belatedly.
Personally I have not had any real issues with this setting as it is set by default...given the protection implication of not setting it on by default I cannot see Webroot going for the less secure option.  Therefore I think that the only other alternative is to make it an installer time option...whether it should be checked or not.
"Silently and automatically block untrusted access to user data"
Just to be clear can somebody please clarify if you lose protection with this setting or does it just now prompt you  with every instance of  untrusted access to user data?  
Userlevel 7
Badge +56
I'm passing this feedback along to the dev team.  I'll update you when I hear back.
Userlevel 7
Hi MadeMeCry,

If you uncheck this setting, it will prompt you when an untrusted process tries to access data, but only the first time. For example if an untrusted application tries to take a screenshot, and you say "no", then when it attempts again in the future Webroot will automatically deny it since you said "no" the first time. Likewise, if you say "yes", it will allow it in future instances.

Hope this helps,
@_GoSpursGo wrote:
Hi MadeMeCry,

If you uncheck this setting, it will prompt you when an untrusted process tries to access data, but only the first time. For example if an untrusted application tries to take a screenshot, and you say "no", then when it attempts again in the future Webroot will automatically deny it since you said "no" the first time. Likewise, if you say "yes", it will allow it in future instances.

Hope this helps,
Thanks, that clarifies that it is the "Silently and automatically" part of the phrase that the option toggles (rather than toggle the actual ability to"block untrusted access to user data").  The description in the online help was no clearer as it just reworded this to "Automatically prevents unknown programs from accessing user data".
Userlevel 7
Happy to help 😃
Badge +3
@BB613 wrote:
Very few people have had an issue with this setting. 
It's quite possible that MANY people have an issue with this setting, but they simply don't know that Webroot is the culprit.  I've had the problem for a couple of years now and always thought that it was FIrefox, because when I'd close that, the problem would go away.  I searched forever on Firefox forums with no luck.  Today I happened upon someone who mentioned Webroot, which ultimately led me to this thread.
I think that having Webroot block pasting without telling you that it's doing it is simply wrong.
FWIW, it was blocking on these applications:
Userlevel 7
Badge +56
Yeah we do get this question on a semi-regular basis, so you aren't the only one who gets caught by this issue.  I'll pass along the feedback about better messaging to the escalation folks here.
Userlevel 1
I'd like to recommend keeping a list of programs within the Webroot client that are being blocked by this. I believe this would allow the end-user to pick and choose which programs that they would like to be affected and in-turn, keep customers happy. We purchased a 3-year plan with Webroot last year. Unfortunately if this behavior keeps up and I have no way to remedy it I will be recommending that we find another provider. Today alone my director had to reboot his computer 3 times to get copy/paste to function again (even though the checkbox next to "Silently and automatically block untrusted access to user data." is unchecked). This is preventing users from working within our main ERP/CRM program.
Userlevel 7
Badge +56
You should be able to whitelist those - are you running the consumer version or the business version?
Userlevel 1
Business version I would think. We're running EndPoint Protection. If you could provide directions I would highly appreciate it.
Userlevel 7
Badge +56
Sure thing - for endpoint, here's how you do it:
1. Go to the Group Management tab in the console
2. Check off the computers you want this to apply to
3. Select Agent Commands->Identity Shield->Allow application and then enter the MD5 and click Submit.
The agents will pick it up at the next poll interval.
Let me know if that works!
Userlevel 1
Thank you. I have applied the recommendation. I will keep the forum updated with my results as soon as I can verify.
Userlevel 7
Badge +56
Thanks, let us know how it goes!  If this is an ERP application used by other companies, then you can also put in a ticket with our support to have it whitelisted for everyone, which will save some headache for another sysadmin who manages that software.
Userlevel 1
Preliminary results say that this solution worked. I would like to give this 24 hours to confirm to be working as intended. Our ERP/CRM solution is Microsoft Dynamics AX 2012 R3.
Userlevel 7
Badge +56
Cool glad that did the trick.  If you want to PM me any of the MD5 info I can pass that along to the threat research team to see about getting it whitelisted globally.
Userlevel 1
This morning the disabling of copy/paste has occurred again within our ERP software.
Userlevel 7
Badge +56
Strange - did the ERP software undergo an update, perchance?  If not, then this shouldn't be happening and we should get support to investigate and find out what is going on.
Userlevel 1
No updates occurred. That is something that is handled manually.