Game fails to launch after being set to "allow"


So I tried to launch Game Stock Car 2013 Extreme and I get this error message:

The application was unable to start correctly (0xc0000018). Click OK to close the application.

I had no idea what was causing this to happen. I had just finished spending several hours reinstalling a racing simulator game along with about 30 gigs of modified tracks, car skins and just a ton of modified files, so reinstalling the game was the last thing I going to attempt to do to try to remedy this error. I decided to install a second clean copy of the game into a different directory and when I tried to launch that game - the same error popped up.

I tried researching the error, but I found no helpful information at all. I almost paid a lot of money for some error fixing scam program. I decided to start to end process on all other applications that were currently running and each time I ended process on an application I would try launching the game and the error kept popping up - until I ended process on Webroot. As soon as I ended process on Webroot I was then able to launch the game without any problems. So obviously Webroot was somehow blocking the program. After a bit of confusion trying to find the correct area to see a list of block programs, I finally found the game listed, but it was already set to "Allow".
 
So what do I do now? I read a lot of messages in this forum regarding how to allow a program, but nothing seems to be working for me. What do I need to do exactly?

43 replies

Userlevel 7
I forgot one item
 
6) if you have time to download and install over 30 gb of game and so many add-ons, etc and configure it, and have time to play the game, my guess is that you do have time to file a trouble ticket.
Userlevel 7
No one wants you to remove Webroot.  Support is usually able to resolve false positives, though it sometimes takes longer than overnight.  Have a little patience and please help Support help you.... it is worth some time and email exchanges to get the problem fixed and fixed for all the other users you quoted as well.
 
:-) 
Userlevel 7
Badge +51
Hello Fergus and welcome to the Webroot Community!
 


 Source
 
Managing active connections
http://www.webroot.com/En_US/SecureAnywhere/PC/WSA_PC_Help.htm#C4_Firewall/CH4c_ManagingActiveConnections.htm
Thank you
Petr.
I'm still getting the 0xc0000018 error after restarting the computer. The only thing that seems to allow this game to launch is if I shutdown Webroot completely, which is not a big problem, but I am mostly worried about what might happen later when I am no longer playing the game and I forget to turn webroot back on again. I don't want to leave the computer exposed.

The game offers a 60 minute trial and can be downloaded from their main website here: http://game-stockcar.com.br/?lang=en

There are also mirror links to download it from this page too:
http://www.racedepartment.com/forum/threads/game-stock-car-extreme-v1-15-officially-released.84839

You are more than welcome to download and install the game for free and use the 60 minutes to try to figure out what is causing the problem. I was able to sucessfully download, install and launch the game, but after I restarted my computer, the error message popped up and there seems to be no way around it without ending process on Webroot. I've tried everything.
Userlevel 7
See Petrovic's post above regarding the Webroot firewall.  You may be able to find the problem there
Userlevel 7
I'm jumping off right now so I'm going to leave this for others to help you out with (sorry) - but have you looked at the scan log?
99% of the time shows when Webroot is interdicting and causing things to not work. It may not be the process you're thinking that's failing, bootstraping a game can be several hand-offs before the real thing actually launches.
Userlevel 7
Games can be a number of programs that work together. Looking in the Webroot GUI is unfortunately not always adequate to solve issues, you need to look at the raw WSA activity logs to see what's really going on in the tough cases.
 
I have submitted a detailed request to Webroot to help remediate this, but in the meantime that is what you will have to do. Otherwise contact support, where they will gather logs from your machine and find the issue for you.
 
https://community.webroot.com/t5/Ideas-Exchange/Control-inactive-processes-and-journaling/idi-p/92654
Userlevel 7
Badge +51
@ wrote:
A ticket? Seriously? I really don't have the time for this. You guys get paid to find the solution, nobody is paying me right now.
We are here on a voluntary basis and us do not pay)
If we can't help you - Best to contact support
 
Userlevel 7
Badge +56
Well we can't help you then only the support inbox can so have a great day! Maybe you can come back on Monday daytime MDT.
 
TH  ;)
Userlevel 7
Hello Fergus and welcome to the Webroot Community!
 
Let me recap, to make sure I understand correctly.  The program is properly set to Allow in Webroot.  You have tried all combinations, but the game only starts when Webroot is disabled.  Am I correct?
 
If so, it sounds to me like maybe one of the library files or add-ons is being blocked.  Look again in Webroot and see if you can find anything set to Monitor or Block that might be related to the game other than the main executable.
 
Let us know if you see anything or not 🙂
Well, currently nothing is being blocked at all, everything is set to "Allow". Nothing is in my quarantine. All active processes are currently set to "Allow". When I launch the game, it fails to launch and gives the error popup as described above, but it suddenly appears on the active process list as being allowed. I'm going to restart my pc again and see if that helps at all.
Userlevel 7
Yet with Webroot disabled it runs OK... Odd.  Let us know how the restart does!
Userlevel 7
Excellent catch Petrovic!  
 
So... does that help?
I can upload screenshots of all of the menus that shows the game as being allowed. And as I said before, I don't have anything being blocked right now, except for FTP Voyager, IE and FireFox, which are all set as "Protect" under "Identity Protection - Application Protection".

What doesn't make sense to me is... why is the (0xc0000018) error appearing? Is that something that would be expected if the game was being blocked? Because it doesn't seem right to me. I mean, when I first saw the error, it looked a bit scary, and I had no idea that it had anything to do with Webroot at all. I searched the internet for like 2 hours trying to find a solution to the error and fix my game, a game wich turned out wasn't broken at all, and like I mentioned before, I almost paid for a error fixing scam program. And the whole time, Webroot was the cause of the problem. I mean really, if Webroot is going to block the game (even though it is not set to be blocked), then when I launch the game  - the only pop-up message I should be seeing should be a Webroot pop-up message telling me that I can't launch the game because it is currently being blocked by Webroot, right? What's up with the (0xc0000018) error message? That's a scary thing to see on your screen, expecially when maybe like 5 people on this planet might even know what an error like that even means.
 
I really appreciate any help I can get with this, but please, don't anybody post any replies unless you got a definite solution.
 
I shared links above to download the 60 minute demo of the game. Install the game, try to allow it succesfully without getting the 0xc0000018 error message. I don't know what racing game you were talking about up above, but it has nothing to do with this game and your fix doesn't halp at all in my case, because my firewall was never blocking the game to start with.
Userlevel 7
Try this:  Open WSA and then:
 
1) Click the Gear Tool next to PC Security.  Click Block/Allow Files.  Check for anything here.
 
2) Click the Gear Tool next to Utilities.  Click the System Control tab.  Locate Control Active Processes, and click the Start button below.  Look for anything related to the game in here.  If set to Monitor or Block, change to Allow.
 
Please let us know what you find.
 
(There simply is no way to post ONLY a definite solution as troubleshooting is just that.. trying different things until we find the answer)
Userlevel 7
Badge +51
Fergus wrote: I shared links above to download the 60 minute demo of the game. Install the game, try to allow it succesfully without getting the 0xc0000018 error message.


"Full v1.15 links below - now a 5-part 5.64GB installer"
It can take a lot of time
 
Best to contact Webroot support:
Support Number: 1-866-612-4227
Support Ticket: https://www.webrootanywhere.com/servicewelcome.asp
 
Thank you
Petr.
Like I said, nothing is being blocked.
I have a 120 down and 20 up connection and used a free download manager to download the entire game in like 7 minutes, but yeah, if you guys have a slow network, I can understand not wanting to bother downloading the game.
 
odaly.com/files/misc/01.jpg
Userlevel 7
Did you check the other one, Control Active Processes too?
Userlevel 7
Badge +51
If you have win 7
managing active connection
http://www.webroot.com/En_US/SecureAnywhere/PC/WSA_PC_Help.htm#C4_Firewall/CH4c_ManagingActiveConnections.htm
Yes, I did check under "active connections" too, but the problem is, it's not even on that list because the game fails to launch before it even has the chance to become active at all. It does appear on the "active processes" for a recorded time of 1s and shows as being allowed, but the moment I close the 0xc0000018 error message pop-up window, it vanished from that list.

So just to confirm, we have checked every possible list and the game shows as being allowed. None of my programs are being blocked at all expecpt for my browsers and FTP software. My guess is that the game is simply conflicting with webroot engine somehow and has nothing to do with any of the webroot settings at all.
Userlevel 7
OK, lets try something.
 
Open WSA
Click the gear tool for PC Security
Go to Block Allow files
Click the ADD button, and add the game exe
 
See if that makes any difference
David, did you see the text link I posted above? it's already added and set to allowed. It is the only thing on the firewall list. I have also tried removing it completely. I have also tried adding it and setting it to be blocked. I have tried restarting my computer between the different settings, but no matter what I do, the error keeps popping up. Currently the game exe is on the list as being allowed, just like in the image.
Userlevel 7
Some of your replies were ambiguous, so yes I did see it but I wanted to be sure that is where you were meaning.
 
I would suggest you file a Trouble Ticket
Userlevel 4
You can submit a ticket.
A ticket? Seriously? I really don't have the time for this. You guys get paid to find the solution, nobody is paying me right now.
 
Install the game. You don't have to stand there and do nothing and stare at the download progress bar. You can start the download and work on other stuff while it is downloading and check on it later to see if it is done. It takes like 2 minutes to install the game, then all you have to do is launch it, and when you get the 0xc0000018 error, you can ask a techi guy to take a deeper look into what's causing the problem, because it's not any kind of setting, it's a conflict of some kind. The game launches instantly, bam error. No webroot messages at all, just a very scary error. This is something that should never occur. Again, I almost bought an error fixing scam program after 2 hours of trying to fix the problem. There was no wWebroot message at all, but there should have beenm because Webroot caused the problem. I never had problems with the game before, and the game runs fun when I end process on Webroot.

Reply