How do I stop the renewal nag popup when my computer starts?

  • 26 November 2014
  • 8 replies

Userlevel 2
I just renewed webroot, through Geek Squad.  I still get the renewal nag popup when my computer starts.  It shows expiration in 363 days, which is right.  I'd rather not get the nag until it gets closer to next year.  How can I fix that?

8 replies

Userlevel 7
Hello there!
Did your credit card get charged already?  (It sounds like it).  What day did it charge?  Lastly, did you renew, or did you end up purchasing a new key code?
Let me know and we will fix it 🙂
Userlevel 2
I renewed through Geek Squad.  Replied to a link in their e-mail maybe a month ago..  The reply after I gave them my cc was that they'd bill when renewed.
The transaction was 11/24, posted 11/25.  My subscription was through 11/23.  I got an e-mail from Geek on 11/24 saying it was renewed.
Yesterday the nag screen (or a link from it) showed 363 days left, and webroot is still on the job, so it went through, and all the dates tally.  I just have the nag screen coming up kind of prematurely.
Userlevel 7
If the nag screen is still comging up, the following:
Open WSA
Click the gear tool next to My Account
Re-enter your same key code in the white box
Click Activate
REBOOT the computer.
See if that helps!
Userlevel 2
Whatever you did fixed it.  Thank you!
Userlevel 7
Ken, AWESOME.  Glad to hear that things are fixed!
I have noticed an occasional problem in which for some reason, while everything LOOKS correct in the software, it still gives the renewal due notices.  It seems like there is something, a registry entry or text file, something, that sometimes fails to update correctly when the subscription has been changed.  Simply re-entering the key code forces the data to be over-written :)
As always, please let us know any time you have a problem or question.  We are always happy to try to help!
TYTY fixed mine, too--that pop up is annoying!  If this is happening to a lot of us, maybe this easy fix ought to be attached to  the instructions for buying update?
Same problem (may or may not have been fixed by the above - I haven't rebooted yet, but I am hopeful). I have a suspicion that the problem has been caused by the fact that I renewed via Windows 10's renewal prompt rather than Webroot's. I didn't particularly want to, but when Windows decided my antivirus had expired the prompt quite literally wouldn't get out of my face so I could do something else until I either renewed it or turned on Windows Defender (and all I wanted to do was renew via WR itself, because I didn't trust Windows to do it correctly - with good reason, it turns out!). Anyway, may or may not be useful for diagnosis.
Just to say that my problem wasn't fixed by the above after all, the popup is still appearing.