Solved

I just got the notice about the Webroot Mobile Security App


Userlevel 6
I just received an email from Webroot stating that I need to check and see if I need to add the app onto my Android phone.  In the last week I have gotten three yellow shields that said that I needed to get updated on my system and to fix it tap the button, which I did and everything is green ( yahoo! :D  )
 
However, this new email that just arrived said that I need to go to the Google Play store to check on the app and when I did, it appears that I have to purchase the app to add to my phone.
 
Why isn't this part of my subscription?   I'm confused because I thought that the app I have on my phone to keep my phone safe and secure automatically updates by touching base with Webroot hourly when it does my scans.  Is that not correct?
 
Sorry if I sound like a dork here but I don't get tech stuff at all and I thought I was styling when I added the app to my new phone that I just got, having forgotten how I had done it on my last phone 2 years ago... 😳
icon

Best answer by Ssherjj 22 April 2018, 00:08

 
Hello elliottrva,
 
I am just wondering if you have installed WebrootSecureAnywhere Complete version which is the old version of Webroot Mobile shown here https://play.google.com/store/apps/details?id=com.webroot.security.complete
 
If so I would uninstall your old version of Webroot and install this version here https://play.google.com/store/apps/details?id=com.webroot.security
 
Your Keycode will determine what version of Webroot that you have.
 
If you need instructions on how to uninstall/reinstall I would gladly provide them.
View original

22 replies

Userlevel 7
Hi gr8auntteffie
 
Hope that you are well?
 
I received the same and did the check to find that I need to update. The confusion may be that what you are speaking about when you say "I thought that the app I have on my phone to keep my phone safe and secure automatically updates by touching base with Webroot hourly when it does my scans.  Is that not correct?" is as far as I know not correct...but has nothing to do with the email you received.
 
As I understand it the mobile app is much like the desktop app; that does not have hourly scanning (you can only schedule a scan to occur once a day at a time of your choice) as the whole concept around Webroot apps is that they focus on active malware detection & elimination and therefore there is no need to scan hourly...the apps watch and whenever they detect something suspicious or indeed a piece of malware they jump into action.
 
The email was about updating the app itself (which I have done and it is really easy & quick to do), and that is altogether and different matter.
 
Hope that helps some?
 
Regards, Baldrick.
 
Userlevel 6
@  I downloaded the new app and got a jolt when it gave me a warning that the two apps were in conflict and i had to dump one, which kinda made me nervous but tech support said that the new app will do everything the old ones did before, just faster and better, so with trepidation I tapped my way into installing the new app! :D
 
So proud of myself and so grateful to you and everyone who is so patient with my being so tech challenged!
 
Thank you!
Userlevel 4
Badge +14
Is this upgrade for SecureAnywhere Mobile Complete as well?
Userlevel 7
@ wrote:
@  I downloaded the new app and got a jolt when it gave me a warning that the two apps were in conflict and i had to dump one, which kinda made me nervous but tech support said that the new app will do everything the old ones did before, just faster and better, so with trepidation I tapped my way into installing the new app! :D
 
So proud of myself and so grateful to you and everyone who is so patient with my being so tech challenged!
 
Thank you!
Hi gr8auntteffie
 
You are most welcome. Glad that the concerns have been 'dissipated'.
 
The Community is here to help members...all members however deep or not their own knowledge...and we all do our bit as best we can. That is what is so great about the Community.
 
Have a great weekend.
 
Regards, Baldrick
Userlevel 7
@ wrote:
Is this upgrade for SecureAnywhere Mobile Complete as well?
Yes, it is. I run Complete and have successfully updated as per the instructions in the email.
 
Regards, Baldrick
Userlevel 1
Hi,
I registered for the community today to try to understand what is going on with the official-looking notice about the Webroot Android app requiring an essential update.  
I had some initial doubts about this mail, that it might be phishing etc.  So, I didn't follow any links and logged into my web console instead.  I see no notifications on the console that in fact an Android Device update is needed; everything shows as up-to-date at version 3.7 Build 7668.
Then, looking for assistance, I come to the community to find that this is an apparently legitimate update.
Why, if this is a legitimate update, is it not notified either on the device (it is setup for automated updates) or on the console?
Thank you for any assistance.  This is an excellent product and I don't want to screw it up!
 
elliottrva
Userlevel 7
Hi elliottrva
 
Welcome to the Community Forums.
 
I too was suspicious at first but then checking out Goggle Play everything seemed to line up so gave it a whirl and so far no indications of anything untoward.
 
Have to say though that I am surprised when you say "everything shows as up-to-date at version 3.7 Build 7668". Are you referring to the build of Android or of WRSA Mobile?
 
Reason I ask is because the latest build of WRSA Mobile is v5.0.1.14849 (Updated 3 April 2018) & is only compatible with Android 4.4 and up.
 
So looks like something is somewhat amiss with versions here which might explain why you are not seeing any notification in your online console.
 
Please let us know what versions of WRSA Mobile & Android you are running.
 
Regards, Baldrick
 
Userlevel 4
Badge +14
Thanks Baldrick:D
Edit:- Got a message that both cannot run at the same time. Had to uninstall.
Userlevel 1
Hi Baldrick
The version I gave, 3.7.1.7688, is the version of Webroot Secure Anywhere on my mobile phone.  The version of android on the phone is 7.0.
 
I renewed about four months ago, so hard to understand how I'm that far back versionwise.  This version of WRSA is on my wife's phone as well, which is on android 8.10.
 
I'll probably try the update tomorrow, let you know how it goes.
 
Thanks.
elliottrva
Userlevel 7
Hi elliottrva
 
Hmmmm...yes, would seem that you are somewhat behind the 'curve' so to speak. Have to say that I was languishing on a prior version and am not sure if and/or how WRSA Mobile checks periodically for updates. I can find no evidence of this but best to ask an expert; one of our Android & WRSA Mobile gurus @ ;) for some guidance on this matter.
 
Regards, Baldrick
 
PS: Will await your update about your update tomorrow. 
Userlevel 7
Badge +55
Hello @,,
 
Welcome to the Community, 
 
To update Webroot on my Samsung Mobile I just go to the Google Play Store and look for Webroot Mobile Security  that is installed in my apps from the Store and it'll say Webroot/update. And version seems to be 5.0.1.14849. Sometimes you might have to force an update if Webroot doesn't update within the app.
 
Here are Webroot's Update instructions:
If you are trying to update the Webroot Mobile Security app for Android, please follow the steps below:
  1. Open the Google Play Store app.
  2. Tap Menu (three lines in the top left) then select “My apps & games.”
  3. Look for the Mobile Security app (green icon with a white lock).
  4. Tap Update beside the Mobile Security app.
 
 
EDITED: Please look here: https://community.webroot.com/t5/Product-Releases/Product-Update-Android-version-5-0-1-14849/m-p/317529#M1011
 
 @ Thank you for the ping!:D
 
Hope this helps. 
 
Userlevel 7
Badge +55
 
Hello elliottrva,
 
I am just wondering if you have installed WebrootSecureAnywhere Complete version which is the old version of Webroot Mobile shown here https://play.google.com/store/apps/details?id=com.webroot.security.complete
 
If so I would uninstall your old version of Webroot and install this version here https://play.google.com/store/apps/details?id=com.webroot.security
 
Your Keycode will determine what version of Webroot that you have.
 
If you need instructions on how to uninstall/reinstall I would gladly provide them.
Userlevel 7
Badge +55
Hello Webrooters,
 
I recieved this in my email and it is legit. As I updated yesterday. :)
 

Hi!
I got the email too and I updated, had to uninstall the conflicting app (I'm on Complete). So far so good. 
When I opened the new app I was told the Lost Device Protection was off for my phone but when I go to fix it, I get an error message while trying to log in to my account saying " Account creation failed. The license check server returned an invalid response. Unexpected: 1 No String to decode [FailureTye=UnexpectedError(-1)] " ... even though I clicked on "I already have a webroot account"!
I can log in the console from my laptop so I'm sure the password is not wrong. What is going on??
I'm on a Galaxy J7 mobile.
 
Thanks for any help you can provide!
Userlevel 7
@ wrote:
Hello Webrooters,
 
I recieved this in my email and it is legit. As I updated yesterday. :)
 


Hi Sherry
 
Thanks for wading in.
 
That is the email I got day before yesterday and (after checking it out) based my responses on.
 
Regards, Baldrick
Userlevel 7
Badge +55
@ wrote:
Hi!
I got the email too and I updated, had to uninstall the conflicting app (I'm on Complete). So far so good. 
When I opened the new app I was told the Lost Device Protection was off for my phone but when I go to fix it, I get an error message while trying to log in to my account saying " Account creation failed. The license check server returned an invalid response. Unexpected: 1 No String to decode [FailureTye=UnexpectedError(-1)] " ... even though I clicked on "I already have a webroot account"!
I can log in the console from my laptop so I'm sure the password is not wrong. What is going on??
I'm on a Galaxy J7 mobile.
 
Thanks for any help you can provide!
Sorry you are having this issue. May I direct you to this KB Article? Maybe a uninstall/reinstall again but restart your device after uninstalling. But you must deactivate Device Administartor first, before uninstalling. You can find instructions to do that HERE.
 
I recommend installing the Free version of Webroot Mobile available HERE, and then registering it with your keycode, which will then upgrade your Mobile version from Free to Complete. You can find directions to do that HERE.
 
 
Otherwise this might need to be checked out with the Support Team.
 
Please let us know how that goes or if this was resolved.
Userlevel 1
Hi Ssherjj,
Thanks for your advice.  In fact, you were exactly right - I had the old version of Webroot Secure Anywhere Mobile on my phones.  Uninstalling from the application itself, then installing the new Webroot Mobile worked like a champ.  I didn't even have to re-enter my Keycode, only had to sign in to my existing account to validate the install.
 
I'm a bit surprised that there was no previous notification from Webroot regarding the redone Mobile App.  It's possible I just missed it.  It is also surprising to me that the web console did not complain that I was using an outdated version of the app.
 
All's good now.  I just need to do the same on my wife's phone, and I'll be good to go.
 
Thanks again Ssherjj!  
 
elliottrva
Userlevel 7
Badge +55
Hello @,
 
You are most welcome...
 
That's really great that you have this all sorted and it was a smooth transition.  I'm not sure how to answer your questions about why you weren't notified about the older Webroot version and the Console would not be that informative either and maybe it should be. Sorry about that. Maybe the developers can address a notification somewhere within the Console.Webroot still works and protects you regardless. The Webroot email that was sent out to the Mobile users is unusual and that's why others were questioning it. Maybe it was Webroot's way of telling everyone to be on this new Mobile version ..perhaps?  Also updating is for better security as well. Hope all goes smooth with your wife's phone.
 
Just the same thank you for letting us know that all is good now. 
 
Have a great day! 🙂
@ wrote:. The Webroot email that was sent out to the Mobile users is unusual and that's why others were questioning it. Maybe it was Webroot's way of telling everyone to be on this new Mobile version ..perhaps?I thought I'd just chime in to say that I agree with you Sherry. I think Webroot sent out this email to be sure everyone was updated to the correct version. It appears they don't offer the seperate 'Complete' version, like in the past, even though some appear to still be using it. I'm glad they went to just the one app. Now all users can start with the same app and upgrade through that.
 
I don't know what makes my settings different from some users, but I didn't have to do anything with my Webroot Mobile Security app. After receiving the email I checked my version and it had already updated to the newest version automatically. I think that it is for this reason that Webroot wanted to be sure, since not everyone received the update automatically and/or were running an outdated version of the app.;)
Userlevel 7
Badge +55
Hi BurnDaddy!
 
Thank you for your added help/opinion. Much appreciated!:D
 
I think it's great that everyone can be on the same Webroot Mobile version. It makes alot of sense that the Webroot email was to get everybody on the same page. So i believe you are right about that.
 
Maybe the idea of having the Online Account Console to mention an update or the latest version to be displayed? This would be a good idea for the Ideas Exchange?
 
Again thanks for chiming in. TEAMWORK at it's best @
@ wrote:

 
Maybe the idea of having the Online Account Console to mention an update or the latest version to be displayed? This would be a good idea for the Ideas Exchange?
There will also be some Console testing going on soon that I'm going to be taking part in. I will be sure to bring this topic up if I get the chance. I think that sounds like a great idea if it is possible.
It took a while .. I needed to change my console password .. but it finally worked out.
Thanks for the help 🙂

Reply