Solved

iTunes store and Webroot

  • 4 July 2019
  • 3 replies
  • 154 views

Userlevel 5
Badge +19
Is anyone having trouble connecting to the itunes store for the past week? It seems like I can connect, but very, very slowly. Like 5 minutes to load. And then if you click on anything, you wait another 5 minutes. Impossible to look at anything. I can log out and back in, but that takes an eternity too. If I click on Check available downloads, it starts downloading some songs, (but I think I already have them.) so there is some slow connectivity.

I have been through all the troubleshooting tips but nothing things to work. They say to add iTunes to the firewall, but it is impossible to do that now. iTunes gets installed by the Microsoft store now and it is placed in a protected folder that I am not allowed access to, even if I say give it to me. And it won't let it even add it to the firewall because I don't have access. Denied. Denied. Denied.

I see that the iTunes app is listed in listed in Webroot in the active connections in that protected location. But it is not listed as far as I can tell in the Windows firewall. Should that matter?

When I highlight the entry in Webroot under active connections, there will be some entries in the window below...like listening for 5 minutes. A couple of times now, I have noticed that when I have the entry selected, htat suddenly the itunes store will start to load. Maybe it's just a coincidence, or maybe webroot isn't allowing the connection for some reason? Or really monitoring it for some reason and slowing it down.

I just tried installing itunes on my second machine. This is the first time itunes has been on it, but the same thing happens. Impossibly slow connection.

Anyway to test if Webroot is blocking the store for some reason?

I don't seem to be having trouble with anything but the itunes store.

Just wanted to add that I upgraded to Windows 10 1903. But it was doing this under the previous build too. Just slarted in the past week.

Thanks
icon

Best answer by Kev914 8 July 2019, 21:42

Thanks for your reply, Sherry.

I have managed to solve my issue...by replacing my router.

Not sure I understand why the old one didn't work. Ut seemed to work with everything but iTunes. But I bought a Netgear Nighthawk to replace my Linksys router which was only a couple of years old.
All I did was go through the set up for the Nighthawk and iTunes started working again.

No changes were made to the Linksys. It worked last week but suddenly this week it would work for iTunes only.
View original

3 replies

Userlevel 7
Badge +55
Hi @Kev914,

Sorry to hear you are having these issues. I have just downloaded and installed iTunes from the Miocrosoft Store on my laptop and I am not having any slow downs. I am running Windows v1903 and haven't any Firewall issues.

EDITED: Have you tried the TroubleShooting in Windows Settings and clicked on Windows Store Apps?



May I suggest that you uninstall/reinstall Webroot? But first shut down Webroot and see if Webroot could be causing a block or slow downs with iTunes? If so then a uninstall of Webroot should fix this and then proceed back to iTunes and see if the problem still exits.

Finally, and for interest sakes, you might find this article from the Apple Support forums a good read.

I hope that something above will be of assistance. If not then you should Open a Support Ticket, so that the Support Team can take a look for you.
Userlevel 5
Badge +19
Thanks for your reply, Sherry.

I have managed to solve my issue...by replacing my router.

Not sure I understand why the old one didn't work. Ut seemed to work with everything but iTunes. But I bought a Netgear Nighthawk to replace my Linksys router which was only a couple of years old.
All I did was go through the set up for the Nighthawk and iTunes started working again.

No changes were made to the Linksys. It worked last week but suddenly this week it would work for iTunes only.
Userlevel 7
Badge +55
HI there @Kev914

You are certainly welcome!

That's great news that you found the problem. I didnt think about asking you about your internet connection. 🙃

Nice to have a new Router though! It's just an added expense and sounds like it was a breeze to set that Nighthawk up!

Reply