Question

Making whole

  • 8 February 2019
  • 7 replies
  • 155 views

Userlevel 7
Badge +23
As the PW fiasco enters its umpteenth Month of non existence, has it entered the minds of the suits and skirts in the front office, just exactly how they plan on"making whole" their thousands upon thousands of paying customers who are to this day, still disgusted due to the lack of this " feature " still being touted on the Webroot website?

Offering a " feature " in a paid subscription that hasn't been available for Months is pretty rude Webroot!

7 replies

Userlevel 7
Hi ROBERT1725

Hope that you are keeping well?

Whilst I for one understand where you are coming from on this I have to point out that whilst it is a lamentable state of affairs no business is going to stop 'touting' a feature in a product just because there is a serious issue. When you have skin in the software area issues and even serious issues are a operational hazard that one tries hard to avoid but which do occur.

If every manufacture of software stopped 'touting' functionality with which there was an issue the relevant websites would be exceedingly bare.

Please also note that not everyone is so affected by the issue...and, yes, it is taking time to resolve...which as I understand it is in most part due to the Webroot PWM being based on an now deprecated version of LastPass which LastPass does not support...which complicates getting things fixed when the core product has moved on, and may well be the reason for the lengthy fix timescale that is being experienced.

Or it may be that Webroot are having to to 'create' a whole new PWM to resolve the issue, and that also takes time (believe me as I work in the industry I am very familiar with the timescales of fixes to technically complex issue & developing new products). I therefore disagree with the "pretty rude" comment...it is not as if Webroot have promised the feature to be included and then not delivered it! They are having a serious issue with it. That is life/business.

Either way @LLiddell, elsewhere, has advised that the solution is close at hand. She has not been able to say officially as to precisely when but reading between the lines end of Feb/beginning of March may not be to far off the mark. But we shall have to wait and see.

But as I said...I much understand the frustration...I have a problem with lengthy scan times, which is taking an age to fix/figure out...but I will not be expecting Webroot to take down an advertising that advises that WRSA scans are lightening fast (as I know they are or at least for me have been until the issue struck).

It is about a balanced view IMHO...and also trust in a company to resolve issues as quickly as possible...which I do.

Just my thoughts on the topic...for what they are worth.

All the best, Baldrick
Userlevel 7
Badge +23
Doing well Baldrick, mostly agree with what you mention. Thanks for pointing out your opinion on the subject. I differ on a few items though, not looking for an argument though.

Webroot charges a price for their service. For Months upon Months they advertise the Password Manager as part of a service, yet they don't mention, nor offer a reduction in cost, considering the fact that Password Manager was, and had not worked for quite some time. Forgive me for saying but that's misleading and the misleading is still going on.

You pay for what you get but you don't always get what you pay for. Password Manager being down has been a deal breaker for me.

Also, the complete lack of communication from someone in the front office ( not the members themselves ) is absolutely uncalled for. Shit happens, but what really counts is how a Company handles the shit that has happened.

Remember the Tylenol fiasco years ago ?

Be well
Userlevel 7
Hi ROBERT1725

Glad to hear that all is well with you.

Agreed, I to do not want an argument or to start a polemic...we have enough of those going on outside the Community...in the big bad world.

Sure, I can understand that the PWM problem is a deal breaker for you, and also I agree with you that Webroot being backward at coming forward in relation to this and the fix that I understand is coming soon, is not the way one would expect of a company that one wants to trust, etc.

But I certainly would not go as far as to say that they are 'misleading' anyone per se. Naïve in their take on the situation & their response to it but not misleading. If that was the case then I strongly suspect that we would be complaining about many more companies...if we reflect back over the years.

I consider myself lucky to not be affected by the issue, and I expect that there are a lot who are not...not an excuse but rather a small point of equilibrium. And the balance to that is that I am suffering from the long scan times issue (circa 25 minutes rather than the usual max of circa 5 minutes) which I presume not many are beset with.

Anyway, as you say opinions are opinions...and by the very nature of the plurality of the term there is scope for disagreement...which is what we have here of a very considered and respectful nature.

But bottom line is that I am fervently hoping that what Lara @LLiddell has advised on the likely timescale for a fix are on the mark or thereabouts, so that the issue can be definitively resolved. Fingers crossed, eh?

Wishing you a restful & peaceful weekend, Baldrick
Badge +1
As the PW fiasco enters its umpteenth Month of non existence, has it entered the minds of the suits and skirts in the front office, just exactly how they plan on"making whole" their thousands upon thousands of paying customers who are to this day, still disgusted due to the lack of this " feature " still being touted on the Webroot website?

Offering a " feature " in a paid subscription that hasn't been available for Months is pretty rude Webroot!


Oh boy I just signed up for webroot after leaving Trend Micro. Now this, No PW manager? 364 days until a new security suite unless they fix this mess.
Userlevel 7
Hi jimke45

I am sure that Webroot will 'fix this mess' as you call it. As I said in my prior posts...we understand that a fix or resolution of this issue should be available shortly, and I am sure that the Beta group members will advise as to when they receive something to beta test re. this.

If not then you are perfectly entitled to go for the refund that Webroot offer...but hopefully you will be patient and that this will be reward shortly.

Regards, Baldrick
Userlevel 3
Badge +11
Touting a non-existent feature is commonly known as "fraud" in most of the world. And, the fact is, a lot of us paid for a feature we're not getting, and which has, in fact, caused some damage to some of us. We've been promised a fix for some time, now, and the outside estimate for when this fix is coming has arrived. It is the middle of February, 2019, and the feature has been broken for months, and completely nonfunctional for at least a month.
I'm sorry, Baldrick, but, at this point, I am NOT confident that Webroot will "fix this mess," especially when one considers that the mess now includes your company's reputation in the marketplace. Webroot has screwed the pooch so thoroughly on this issue that said pooch is in court seeking child support.
Seriously, right now, in my mind, at least, WR's credibility has disappeared below the waves. I don't know how they're going to fix that mess.
Userlevel 7
Hi jbcasler

I beg to differ with your description of "a non-existent feature"; the feature exists otherwise it could not be broken and therefore would not be requiring a fix...as there would be nothing to apply a fix to?

In my humble opinion, therefore, the mention of the term "fraud" in relation to this is unwarranted and in fact inflammatory/uncalled for. Yes, we have all paid for a feature we are currently not getting, but that most of us have made use of before the advent of the current issue (in my case for some 5 or so years...which have been trouble free).

In terms of the "has, in fact, caused some damage to some of us"...I am sorry to hear that...I was not aware that this was the case, and if you are one of those unfortunate users then I would write to Webroot customer service and complain.

In terms of a fix, etc...I have tried to explain what I know, in my response to another of your posts (HERE). But in terms of timescales for a solution what I had heard late last year was a timescale of end of February/early March.

Now, a point of correction regarding the "your company's reputation in the marketplace". Please take note that I am NOT a Webroot employee, nor am I in any way commercially affiliated with Webroot...I am purely and simply a long time user and a volunteer supporter in this Community. So Webroot is NOT my company.

Finally, yes, none of us are happy with the situation, but I for one have not given up on Webroot resolving the issue...there are still a couple of weeks in terms of the aforementioned timescale.

So I will sit tight and see what transpires over the next few weeks...hopefully resolution. But as to question of lost reputation...that I do not feel I am qualified to comment on.

As always, just my thoughts/points of view...for what they are worth.

Regards, Baldrick

Reply