There is no way to recover files deleted by Webroot?

  • 2 January 2018
  • 4 replies

I am hoping this isn't true - when Webroot decideds to delete files, there is no way to recover them? Can that possibly be true?

4 replies

Userlevel 7
Badge +62
Hello DOHwebroot2018,
Welcome to the Webroot Community,
I am sorry to hear of this issue that you are having. This is always hard to deal with losing your files.
If you used the right-click option "Permanently erase with Webroot" then I highly doubt that you can get them back.
There are some recovery utilities out there like "Recuva", but I'm not sure it will help.
These utilities can recover files if the space has not been written over already, but in this case, I think Webroot does rewrite over the space,
Were you using Secure Erase? Or did you run System Optimizer? Do you have any backups? Do you use or have Backup and Sync?
All I  can  say is you can Submit a Support Ticket and see if they can assist. This is a free service with your Webroot Subscription.
Hope this helps?
Now, this answer is not really helpful. Not helpful at all I will dare to say.
I am facing the same issue as the OP here.
I have a program, which I ran in the past on a mutlimplidute of systems. On systems, protected by Norton, Kaspersky (Or whatever it's called), and our corporate antivirus - never an issue. Totally legid program written by me for my convenience, no viruses of any sorts.
In a new company, I got a new machine, with WR pre-installed, and 1st time I tried to run the program, WR, with no warning, deleted it from my memory stick (making it arguably easier to recover than from the same system where WR is still lurking).
Recovery of the file is no issue for me - I have the source. But, as the OP noticed, there's no (apparent?) way in WR to do so. Say, if my source was in a 5-years old compiler, and no easy way to build the app again, I'd be pissed myself.
So, the question (still unanswered) is: how to undelete a file when WebRoot vehemenly, ruthlessly, and asking no confirmations of any sorts, decides to hack it?
Userlevel 7
Hi Trueaun
Welcome to the Community Forums.
Firstly, what version of WRSA is running on the machine in question; Consumer/Home or Business Endpoint? As you say "In a new company, I got a new machine, with WR pre-installed" I am guessing it is the which case the behavior that you are describing may be related to the rules set by whoever administer WRSA for your company.
If it is the Home/Consumer version then I am assuming that you have checked in Quarantine (PC Security gear symbol > Quarantine tab) to see if anything has been placed therein?
If you have and still not joy then I would Open a Support Ticket, with a link to this thread, and raise the question with the Support Team.
Would also be grateful if yo would share any answer you get from them on this topic.
Hope that helps?
Regards, Baldrick
Userlevel 7
Badge +19

I am hoping this isn't true - when Webroot decideds to delete files, there is no way to recover deleted files? Can that possibly be true?
In addition to recuva, easeUS, Disk Drill, iCare Data Recovery, PhotoRec Data Recovery, anyrecover are all using a large number of data recovery tools. I don't know if it's useful for restoring webroot, but anyrecover does restore other files I deleted.
Oh, make a correction: don't use recuva, even if it's free. Many people say that it is useless.

Well they're wrong I've used Recuva for several years and it's always recovered any files if they are in a recoverable state, if they've been securely erased then you'll be unlikely to find anything that will recover them.