Turning off the firewall?

  • 27 August 2013
  • 22 replies
  • 216 views

I am running a fantastic hardware firewall on my network.  I do not lke to use redundant firewalls by having software firewalls on my computers as well.  I noticed that if I turn the firewall off in WSA that the notification bar button will contanstly show the warning exclamation point because a security feature is turned off.  Is there a way to prevent the icon from doing that while having the firewall turned off?

22 replies

Userlevel 7
Badge +56
You can use WSA's firewall as it's a firewall extender for outbound only and with Windows firewall on then you have inbound protection I also have a hardware Firewall Router and it works very well and turning WSA's firewall off doesn't use any less resources so I would say just leave it on. Please read here: https://detail.webrootanywhere.com/agenthelp.asp?n=Managing_the_Firewall
 
HTH,
 
TH
Userlevel 7
Firewall forms an inseparable part of WSA protection modules and hence if it is disabled it warns via GUI and the systray icon. You cannot change it unless you enable Firewall back. HOWEVER, there is no reason to disable Firewall. In fact this is not a conventional firewall you are used to from other vendors. WSA Firewall controls outgoing traffic only and doesn't have any impact on a machine performance nor conflict with other firewalls (software and hardware as well).
 
OK, Daniel beat me again ... should I be surprised ... no :D
Userlevel 7
Badge +6
He https:///t5/user/viewprofilepage/user-id/5460,
As far as I'm aware, WSA does not do deep packet inspection. There is no performance overhead to leaving it on. It directly plugs into the existing Windows Firewall through the API. 
 
Working with this product across 1400 computers I have never once run across a networking problem caused by WSA. Which is a lot more than can be said for the last product we used...
 
Hardware firewalls, even if you are intensely managing them, do not completely replace a software firewall as they can't see the individual processes and actions taking place on the endpoint like WSA can.
 
However, for advanced users like it seems you are, you would likely be fine without it on. Just adding my two cents. I don't know how to turn off the complaints for turing the firewall component off.
I certainly now how to turn it off. But, I don't know if a way to do it without the notification icon showing an alert. That is an issue, because if it always is like that I may miss an important event that I would like to know about. Such as an infection or malicious activity detected.
Userlevel 7
We understand what you're saying, but the firewall itself being turned off is an event you should want to know about. Turning it off does limit your protection. Your hardware firewall cannot reach into your system and shut off outbound traffic from a WSA-detected infection. We're talking apples and oranges between the hardware firewall and WSA's outbound firewall. If you're concerned about missing an alert, it would be prudent to do the right thing with the alert you already have.
Well, I am keeping it on. Honestly, I love Webroot software. The issue that I have, specifically, is that I use a program called ShareMouse to enable the use of the same keyboard and mouse, including the clipboard, between PC and Mac systems that I use both of four work. It is a replacement for a KVM and simply needs to be on the same network and internal port to work. It is fantastic! But, the Webroot firewall blocks it from working at all of it is installed on the Mac side it won't work at all. So, I have it installed on the PC computers, but not Mac. I'm just looking for a solution.
Userlevel 7
That's interesting. Are you sure it's the firewall on the Mac side of things that's causing the issue? If you disable the Identity Shield on the Mac client, does that also allow ShareMouse to work for you? In either case, I'd suggest opening a support ticket. We can try to pinpoint what's happening there and resolve the issue for you, but we'll likely need to have a closer look at it than the community can facilitate.
The only thing that fixes it is removing Webroot from the Mac.
Userlevel 7
Please open a support case. That's not intended behavior.
Userlevel 7
Badge +56
Can you please follow Jim's advice from the Mac with WSA installed Submit a Support Ticket and support can help you find the issue and help correct this issue.
 
Thanks,
 
Daniel
 
EDIT: Jim beat me to it! ;)
I haven't tried just turning off Identity shield. Wouldn't that leave the exclamation point on also?
Userlevel 7
Badge +56
Yes it would but for Diagnoses purposes to see if it corrects the issue.
 
TH
Do you think it would be a good idea to try and add ShareMouse to the list of applications in IdentityShield to see what that does first? Would I all it and select "Allow"?
Userlevel 7
Badge +56
It's best to contact support as they would be able to look closer at your logs it might be a simple thing they can do on the back end?
 
Daniel
I have already uninstalled everything so I have no logs. I may reinstall today before my shift and try it to see what I get. I have l post keyboard sync before and kept the mouse running fine in the past. I just have to turn off ShareMouse on my PC and start it up again. That doesn't matter what I'm running; I need to contact them about that. But, if I have Webroot installed on the Mac there is no communication whatsoever with ShareMouse. The notification icons show that it is running, but not one single feature works. As soon as I remove Webroot, it's fine. There's something going on there. I may submit a ticket to get things started and see if they have seen this before, as well as contact the devs of ShareMouse.
*lost keyboard sync, not post. Sorry for the typo.
Userlevel 7
Yes, adding it to Allow would be a valid troubleshooting step. It shouldn't be interfering regardless, but it would be good to know if that helps. Please give that a try.
I can see how to add ShareMouse to a PC and allow it, but on the Mac version I only see the ability to add websites. What am I missing?
Userlevel 7
I don't believe that's possible on the Mac. I was surprised to hear you were suggesting doing so, but I assumed incorrectly that you must have seen a way to do it somehow. The support ticket is the way to go.
I sent a support ticket referrencing this thread so that I didn't have to explain it all over again.  Thanks for all you help.  I was able to turn the Identity sheild off on the Mac end, so I'll work at least the beginning of my shift like that and see what happens.
Userlevel 7
Badge +56
@ wrote:
I sent a support ticket referencing this thread so that I didn't have to explain it all over again.  Thanks for all you help.  I was able to turn the Identity shield off on the Mac end, so I'll work at least the beginning of my shift like that and see what happens.
Great that's the best way and please let us know the outcome so that it may help others!
 
Thanks,
 
Daniel 😉
I submitted a support ticket and they just responded to it asking about the Identity and Privacy Shield. I didn't see a way to reply directly to the support ticket so I thought that I would post here. I did in fact turn off that setting on the Mac and it seems to work for now. I'll have to contact the ShareMouse vendor about why the keyboard suddenly stops working and work again if I shut it down and then relaunch the program. On another positive note, the warning symbol in the menu bar on my mac does not show the warning icon, but the regular one with the current settings.

Reply