Solved

App Store is super slow

  • 30 June 2018
  • 6 replies
  • 989 views

Userlevel 2
Hi, hope you are all having a great Saturday!
 
I'm reaching out to see if there are any other Mac users out there that is experiencing App Store loading really, really slow atm...?
 
I've cleared App Stores cache with help from all different guides with no success. Anyone who knows what may cause this issue? Since Webroot caused my Photoshop to not work properly (which I've got help with) I'm now starting to be suspicious if it is Webroot again that is preventing my App Store to not work as it should? I'm doubtful though, but as I can't find any help about this issue anywhere else, this post is my last hope!
 
Thanks in advance folks.
icon

Best answer by Fors 27 July 2018, 13:58

My App Store is now working again. I don't know what caused it to be that slow though. Either has Apple fixed the problem or it was something wierd with my internet settings which prevented only App Store from working correctly. So that's unfortunately my best advice for someone else experiencing it, switch internet connection and see if it gets any faster.
View original

6 replies

Userlevel 7
Badge +55
Hi @,
 
Sorry to hear of this issue. Also sorry for the delay. I just got online with my Mac.
 
I am not having any slowness, with the spinning beach ball going round and round, with the Apple Store opening on my El Capitan system.
 
To find out if Webroot is the culbrit try shutting down Webroot in the upper right hand side. Then open up the Apple Store. Does the Apple Store open quickly? Let me know if this is the case.
 
Otherwise have you seen this here http://osxdaily.com/2011/08/07/fix-a-slow-mac-app-store/
 
Please get back to us.
Userlevel 2
So sorry I haven't replied to you earlier than this. Haven't actually had the time to sit down at my computer until now...
 
But that was maybe good in that point that we now can exclude any temporary issues at Apples own servers, my App Store is still super slow, frustrating. I managed though, after I posted this on Sutarday having the patience to wait for whatever action i did in App Store to load. So I downloaded the latest update of MacOS (which was my purpose in the beginning of opening App Store) but the funny thing was that it almost took longer to click into the "update" menu than the actual update itself took.
 
Today I tried shut Webroot down and it doesn't seem to be causing the issue, App Store is still slow.
 
I've seen that link, and I've already tried the cache method, that didn't work. The other method is a bit confusing as I can't find the “Preferences” in the Keychain Access menu. I've looked at several Youtube videos and I can't hint any tab that says "Preferences" on their computers neither. So I'm wondering if that tab has been removed in the latest updates since that guide is from 2011, or is it visible to you @? If so, where?
 
I'm currently using High Sierra Version 10.13.5 on my Mac Pro ("beginning 2015").
 
Thanks in advance for your awesome support, take your time in replying, as I did 😉
Userlevel 7
Badge +55
Sorry Fors,
 
I'm not at my Mac right now and won't be for a few days and I'm not running High Sierra sorry to say. I found another link that might help to find Keychain. 
https://discussions.apple.com/thread/8109842?answerId=8109842021#8109842021
 
Hope this helps..
Userlevel 2
Thanks @ for your assistance.

It's totally fine, vacation times I guess, enjoy summer :)
 
I'll look at the link, thanks! Anyways, if that doesn't fix it, I'm not so much in need of the App Store atm so I'll just have some more patience and see if Apple maybe will mention anything about it. If I figure it out, I'll post the solution here.
 
Wishing you a good weekend!
Userlevel 2
My App Store is now working again. I don't know what caused it to be that slow though. Either has Apple fixed the problem or it was something wierd with my internet settings which prevented only App Store from working correctly. So that's unfortunately my best advice for someone else experiencing it, switch internet connection and see if it gets any faster.
Userlevel 7
Badge +55
Hello @,
 
Welcome to the Webroot Community,
 
The lastest Mobile Webroot paid version is noted here https://community.webroot.com/t5/Product-Releases/Product-Update-Android-version-5-0-1-18697/m-p/323574#M1025
 
You can uninstall your version of Webroot and install the updated version from here.
 
Hope this helps?

Reply