Full Disk Access Problem

  • 29 April 2020
  • 16 replies

Webroot Secure AnyWhere ver. installed Web Filtering Package ver. keeps cancelling my scans after I recently updated the program.  I followed all the instructions when a window popped up saying to open system preferences, click full disk access in privacy tab an open up the application folder.

I did all of the above multiple times to no avail.  Anyone know how to fix this?  I would be very grateful.  Tried contacting webroot support several times but got no answer.



wmausa ( Please do not post email as this leads to Spam)

Edited by ssherjj 


16 replies

Userlevel 7


Hello @wmausa 

Welcome to the Webroot Community  

Sorry to hear you are having this issue. Have you tried submitting a Support Ticket? This is a free service with your Webroot Subscription.

If you have already submitted a Ticket do not Submit another one because this will put you back to the end of the line with Support.

Let me ping our Administrator and see if he can fine anything out for you. @khumphrey ..

Userlevel 6
Badge +17

@wmausa ,


Can you please go through these instructions fully and let us know your results:



Community Specialist -- please try to follow these instruction on a MacBook Pro computer.  Your instructions (followed exactly) do NOT allow the Scan to complete.  Thus, my Webroot installation is USELESS on my MacBook Pro.. I’m using the newest macOS, Catalina Version 10.15.4.   Please correct the problem (it is on YOUR end) and email me with new instructions or tell me when a new version of the WEBROOT Virus Protection Software for the MAC is ready to download.  In the meantime, I’ve uninstalled the version I downloaded today -- it is useless.  Sincerely, Jeff Philbin, ~snip Removed your email address snip~, Albuquerque, NM. 

P.S. I’m using WEBROOT on my Window 10 computer (a Dell Laptop) and it works fine on that machine.   

Userlevel 1

Same problem here… Even after a complete clean install of MacOS 10.15.4. Every other app installed without a problem but Webroot ( will not scan despite having full disk access. 

And… so far no response from Webroot customer support either. First contacted them 6 days ago.. not a word… hmmm…

Works ok omg my Parallels partition.

Same issue!  Frustrating that we are paying for a subscription that is totally useless on my Mac right now.  In this world of remote work and distance learning, we are desperate to maintain security on our systems.  

Userlevel 1

Here’s my response from Webroot - trouble is it was working on Catalina BEFORE I upgraded to WRSA with a renewed subscription. So WR are saying this is Apple’s fault and won't be resolved until there’s a fix from Apple (maybe in 10.15.5). 

Still not very happy about renewing my subscription and coughing up more $$$ for a product that doesn’t work as advertised. While WR might think it’s working correctly, their product also keeps saying “Scan Cancelled” instead of “Scan Complete”. Not exactly inspiring confidence that the level of protection is up to scratch!


Thank you for contacting technical support. My name is XXXX, and I'm a Sr. Global Escalation Manager. The issue you are encountering is one that we have passed up to our developers. The behavior is the result of additional requirements imposed by Apple with the release of Catalina. 
However, with this additional requirement, Apple did not provide an API that allows us to query our status in the control panel via an Operating System request. We will continue to work on a better solution to the behavior, and have opened a request with Apple to provide a method that permits us to query the entry more directly. 

In either scenario, a resolution would come in the form of an update to the OS, and a corresponding update to the Webroot Agent. Until then, we are unable to provide a direct work around, or resolution outside of recommending a change to the policy that hides the GUI from the target machine. 





I'm a bit confused, the software is indeed working correctly, given the environment it is running within. The application has been granted full disk access, however, absent a mechanism for the Webroot software to validate this fact (something that should be provided by the Operating System vendor) it's unable to confirm. As a result, it displays the message continually. 


I am in the same boat on this. I have not been getting much assistance from support other than to acknowledge there is a problem and they are looking into it. Until then our I have no protection on my Mac. This has been going on since mid-April. 

Thank you for bringing the issue you are experiencing to our attention. The Webroot Development team has been notified of this issue and is currently working on a resolution. We expect to address this issue in an upcoming software version release, which will be downloaded automatically to your device and installed when it is available. Once the newer version has been installed, check to see if the issue you reported is still occurring. If it is, let us know and we will check the status of the issue. 

Userlevel 1

I had a remote session with the support guys yesterday.  They have collected some data following an aborted scan and the ‘full disk access’ request to help them understand why the prompt keeps recurring.   Sounds like they are working on a resolution. Hopefully it won’t take long.

Adding a reply in the hopes there will be an update to this thread….since there hasn’t been an update to the other couple of threads of people complaining about this.  I’m astounded that they just gathered info a day ago since this has been going on for over a month.  

Userlevel 1

Adding a reply in the hopes there will be an update to this thread….since there hasn’t been an update to the other couple of threads of people complaining about this.  I’m astounded that they just gathered info a day ago since this has been going on for over a month.  

I got the impression collecting my data was not the first case. Working on it but no estimate of a timeframe. Seem WR has had nothing but problems with Catalina from the beginning. There must be some underlying incompatibilities that have been exposed by Apple’s security tightening. 

If/when there’s a solution I’ll post it on this thread if possible.

Userlevel 1
Badge +2

This issue was opened over 3 weeks ago, there are other topics in this forum for the same issue. Still no resolution. 

This problem with the several month delay to get Webroot working in Catalina gives me a strong impression that the general quality of the MacOS development team in Webroot is subpar. 

This type of lazy and 100% non-proactive product development proves how their marketing of being a next generation anti-virus made for the modern age and thereof modern companies is misleading at best.

Userlevel 2
Badge +3

Any resolution yet re: full disk access issue?

Userlevel 1

I am also having this issue, and it’s nagging me at least once a day, sometimes a couple times.  It’s getting really annoying.

I do not accept the excuse that Webroot has no way of determining if FDA has been granted.  Worst case scenario, you try to access a file/directory you should have access to and see if it works.  If it doesn’t, you know FDA isn’t active.  Literally no other software vendor is having this issue.

Userlevel 1
Badge +1

I use gDrive on Catalina 10.15.5. Webroot complains & seems to scan anyway. Maybe it skips files. I’m reporting a support case because no progress on this thread or this.

Userlevel 1

I’m reporting a support case because no progress on this thread or this.

I’ve also submitted a ticket.  Their answer was “We are aware people are experiencing an issue but we do not yet have an ETA on a solution.”

I’m currently managing webroot on ~130 computers.  Given that it’s been 2 months since this issue has been raised, it seems like maybe it’s time to revisit our purchase.

Userlevel 6
Badge +21

Not sure if this is getting out to this thread, but an update is being released this week to subdue the erroneous FDA popups. Keep an eye on the agent updates in the next week as it gets pushed out. Will only be for Catalina and will be version - Hope that helps!:grinning: