Product Update: WSA for macOS Catalina

  • 2 October 2019
  • 92 replies
  • 26736 views


Show first post

92 replies

Userlevel 3
Badge +5

WR!  I went to finally install for Catalina and of course I downloaded a version that was … ummmmm … magical!

No matter how many times I shut it down, in 5 seconds it came back and deleting it was impossible!

I had to invite WR in and fix that hot mess.

 

I really need to ask a question here … for all the persons running Catalina 10.15.1 … have u noticed how absolutely well Catalina is???

 

I think I need more info on the secure wifi!

Userlevel 3
Badge +5

Update on this WR that is for Catalina 10.15.1 … ROTFWLMAO

It is a joke … I get more practicality and functionality out of a picture hanging on the wall!

  • it does absolutely nothing but occupy space
  • running optimizer does nothing and it actually shows the exact same issues as last scan before Catalina killed it
  • it does not empty nor clean trash
  • it does not clean cookies
  • upon download (5 times now), the first time WR tec came aboard n had to manually force it in by DOS like scripting it in … and now I am in the process of having to fix that hot mess … thanks a lot; GROWL!
  • upon setting it up either with their defaults or my doors closed way, it slows down the computer soooo bad, its like being on the old fashion DLS!

My Conclusion … I firmly believe as if all WR did was Copy and Pasta everything with  just enough tweaking to allow it to be downloaded!  NOT GOOD WR!  I mean I would rather have waited for a FUNCTIONAL product then to have sunshine blown!!!

I am going to stop here, because I am extremely PO’d!  I hate deception! 

 

Badge +1

So glad to read message that Updated product available! So happy to find a viable link and easy download.

Not so glad but not disappointed when the Update for Catalina does exactly same as pre-catalina release: ICON shows in dock and does NOTHING.

I didn’t expect that the problem would be corrected within three weeks when the company had already failed to deliver prior to Catalina release, right ? I am not confident that a compatible version will, in fact, be compatible, and am expecting that it too, will be a colossal cock-up

So I filed support ticket. Support replied that current version of Secure Anywhere is incompatible with Catalina and company is working to resolve this. REALLY ? REALLY?

I suppose product manager and product development team are working diligently but sure looks to Mac owners like “...something close to nothing, but different from day before…” and support team, well they’re doing some good things to be sure. They might consider communicating with product development team and manager so that the departments are on the same page, communicating same message. 

Yeah, I’m a bit unhappy but I can resolve that easily enough with purchase of another company’s product.

Userlevel 3
Badge +5

 Yeah, I’m a bit unhappy but I can resolve that easily enough with purchase of another company’s product.

 

I am sending u a pm. 

Userlevel 5
Badge +9

[...]  So I filed support ticket. Support replied that current version of Secure Anywhere is incompatible with Catalina and company is working to resolve this. REALLY ? REALLY?   [...]

@RogerIII 

 

Please excuse the follow-up question; I just want to confirm that I understand your post correctly.

 

Earlier this week, Webroot officially announced that their software had been updated, and that it was compatible with Catalina. This announcement can be found here.

 

Your post appears to contradict this announcement from Webroot. To clarify, did Webroot ‘support’ tell you that their latest version, the version released earlier this week, is incompatible with Catalina?

Userlevel 3
Badge +5

WR did release something that can be downloaded on ur Mac running Catalina … wether by forced manipulation or not!

Mine was nothing more than the ghost remnants of pre-Catalina that did absolutely nothing!

Userlevel 3
Badge +5

I have just now gone back a few pages and read the post on this thread and others …

 

Shame Shame Shame

 

This is a Community built to help persons tec savy and those not so much only! 

This community is not built for persons to come in n bash those helping you nor others … PERIOD!

 

If u r having issues, like the rest of use running Catalina … by all means, come on in, explain and vent all u want about Webroot, but DO NOT come in here, this Community bashing those trying help you understand!

We r all adults, we r all getting ran over by WR running Catalina, so why r you biting the hand that is helping explain???

 

I have been with WR since they were WR Window Washer … I too am effected by this n I too am angry, but at WR … especially about this farce of a ‘download’ that WR knows darn well does not work!!!

 

So if you all r done venting and can not contribute anything that can help all of us collectively help all of you collectively … please put ur fingers on pause and keep those fingers off the keyboards!

 

Thank you

Userlevel 3
Badge +5

I sent a private msg to another WR victim, to not stir the pot until I could remove all WR from my Mac n repeat the install (many times), just to be sure it was not a bad install …

 

My Conclusion n the facts from the process ...

 

***

RogerIII wrote:
Yeah, I’m a bit unhappy but I can resolve that easily enough with purchase of another company’s product.


To be honest ... Apple constructed Catalina so well, I would not waste ur monies!

It took 12 steps n 3 reboots for the WR tec to try to install it forcefully! I would just have a senior tec at apple help u, if u r not familiar with how, to lock ur system well from outside crap getting in ... locations notification, encrypting, etc... and clear history every time u r done/off, u will be fine!
Unless of course u r a clicker of everything out there, then u 'may' eventually come across some malware in downloading a file.

I am going to purchase VPN/WiFi security from WR and get a refund for almost 300 days of WR Complete.

***

 

I am going to wait until WR codes a new product just for Catalina … because I refuse to use anything subpar that does nothing; on any machine that cost so much.

Userlevel 3
Badge +5

I need to also say …

 

WR is a great company n they have come very far from window washer.

So why in the heck they refuse to admitting uncle with Mac/Catalina n to take as long as they can to code an entire new product; its going to come back n take a huge chunk from their butts!

WR running in Windows has been fabulous and I do believe they need to pat themselves on the back for doing an awesome job in Window's products!!!

Every product out there has customer service in a foreign country that ‘may’ speak n comprehend second grade English at best, n the many hrs to just get them to partially understand was draining!

Tis a major reason I will never use anyone else but WR, but they need to own up to their crap!

Thank you for listening

Userlevel 5
Badge +9

[...].  WR is a great company [...]

@seahorse 

 

I respectfully disagree.

 

Webroot WAS a great company, and I sincerely hope that they will be again in the future. However, their current performance is lacking.

 

Like you, I am a long-time Webroot customer, and want them to succeed. Notwithstanding, their recent actions surrounding Catalina have been disappointing, to say the least.

 

Bluntly, they have to do better.

Badge +1

Webroot Support (Nov 14, 2019 10:16)

RE:Webroot does not open.

Hello, 

Thank you for contacting Webroot Support. 

At present we're still working with Apple in order to provide a compatible version of Webroot for Mac Catalina 10.15. 

The best way to keep updated is by visiting a href = "https://community.webroot.com/webroot-secureanywhere-for-macs-18/product-update-wsa-for-macos-catalina-340517" target = "_blank"this page/a for more information and updates. 

Kind Regards, 

The Webroot Support Team

I believe this clarifies. 

Userlevel 5
Badge +9

@RogerIII 

 

It certainly does clarify the issue. Thank you for sharing this information. 

 

Based on this post, I was planning to change my ‘protection’ back to Webroot. However, it appears that they have not yet successfully resolved their incompatibility issue with Catalina. So, I will just ‘stick’ with the ‘protection’ that I currently have installed. 

 

You saved me some time, and aggravation. I appreciate it.

 

Best of luck on restoring your ‘protection’.    

Userlevel 3
Badge +5

BurnedByCatalina (in essence Catalina helped u),

This is just me speaking here … but if Apple wants to code/create a software that makes it extremely difficult to hack, Catalina … ummmmm … this is a good thing!!!

Why would anyone want to spend monies not needed!

I made a conscious choice to go with Apple because I am tired of having to pay good monies for a product and having to pay more monies to keep said product n me private n safe.

So Apple came out of left field n developed an awesome kick butt program Catalina n everybody, including me, freaked out, because we had no idea just how great Catalina is … and OMG … CHANGE; we have to change our habitual ways of doing n thinking … yes!  Sometimes change and modern technology can be a good thing!

 

WR has VPN … secure up ur WiFi … take those extra monies n spend elsewhere like… thinking of an Oreo Thin Mint Shake, this is soooooo good!

Userlevel 5
Badge +9

@seahorse 

 

You clearly believe in the ‘protection’ Catalina promises to provide. I hope that Apple delivers on this promise. Time will tell. 

 

I still plan to run third-party ‘protection’ software on my Catalina machine. At some point, I hope it is again Webroot. In short, I consider it cheap ‘insurance’ against constantly evolving threats.

 

Best of luck to you.

Badge +1

So this thread is very much TLDR and seems to go way off topic.  What is the status of this topic?  When am I going to be able to get WR installed on a Mac Catalina machine and communicating properly with the console?

Thanks

Userlevel 5
Badge +9

@MountainMatt 

 

Welcome to the forum. 

 

This post from yesterday address your question.

 

Good luck.

Badge +1

I fully removed and reinstalled the latest Webroot SA on our MacBook Pro after Catalina broke it. It worked, but every day or two (sometimes twice/day)  Catalina began locking the Desktop, Docs, Downloads, Mail and Safari cache directories (a new security capability of Catalina (!) until we restarted the laptop.

A few days ago I tried to delete Webroot SA again, but got an error message popup that I did not have permission to access some of its files (even with with admin rights) . I had to boot in safe mode and delete everything manually with help from Spotlight search. After deleting W-SA files this laptop behaved normally. Yesterday I installed 10.15.2 update and all is still good. I’m going to wait another month before trying W-SA again (my spouse gets loud and angry when the MBP does not work perfectly, just like some here).

Catalina does bring MAJOR changes and security improvements to the macOS. I’m still waiting for Drive Genius 6 and a new version of Disk Warrior, so Webroot is not the only good company working hard to update their complex software. 

Reply