Webroot and Apple

  • 23 April 2020
  • 3 replies
  • 102 views

I installed Webroot after buying my Mac Pro 8 months ago.  Since then Apple has rolled out 3 updates.  Each one of them have broken Webroot to some degree or another.  After spending several hours on the phone with the Geek Squad they said they have seen a lot of instability with Webroot and Apple OS X.  They suggested I may want to switch to Trend Micro as it seems to be much more stable with Apple. 


3 replies

Userlevel 1
Badge +11

Interesting suggestion. I remember that someone posted at Apple suggested running Mac without any antivirus program :) But I agree that Webroot seems to have problems with Mac. I am also a bit worried, and could not answer if Webroot is still protecting MacOS as “normal”. I see multiple Webroot installation on Mac now have yellow exclamation marks, and clients keep asking why?

 

Userlevel 6
Badge +17

Hey there @joslynre ,

I’m sorry that you’ve been experiencing some instability when using Webroot on your Mac. Admittedly there have been some issues since the release of Catalina, but most of these issues have been patched. Have you spoken to the official Webroot Support yet? They have far more tools to help you with Webroot than GeekSquad support. 

Please submit a support ticket or call them via the phone number listed. 

Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue.

 

Thanks,

Keenan

Userlevel 6
Badge +17

@hungpham ,

The yellow exclamation mark is a visual glitch that the engineering team is aware of. There should be a patch rolled out soon.

-Keenan

Reply