Solved

Webroot for Mac causing 100% CPU Usage

  • 7 April 2020
  • 4 replies
  • 1158 views

Badge +1

When running Webroot on my Mac the WSDaemon consistently uses 100% of the CPU. The fans spin up and the system slows to a crawl even when doing basic tasks like web browsing. If I kill the process or reboot the machine everything is ok for ~15 minutes and then WSDaemon goes back to 100% CPU usage.

I’ve attempted uninstalling / reinstalling Webroot and that hasn’t helped. In addition I can’t get the Webroot window or menu bar icon to show up.

macOS version: 10.15.4 (19E266)

icon

Best answer by TripleHelix 7 September 2021, 17:12

Hello @Flippo 

 

I would recommend contacting Webroot Support. When sending a Support Ticket a copy of Webroot's log gets sent automatically. 

Webroot Support:

Submit a ticket

Call 1-866-612-4227

Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue.

 

Thanks,

View original

4 replies

Userlevel 7
Badge +63

Hello @Flippo 

 

I would recommend contacting Webroot Support. When sending a Support Ticket a copy of Webroot's log gets sent automatically. 

Webroot Support:

Submit a ticket

Call 1-866-612-4227

Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue.

 

Thanks,

Userlevel 7
Badge +62

Hello @jordanshute 

Welcome to the Webroot Community,

Sorry to hear you are having these issues with high CPU usage on your Mac. Would you please Submit a Support Ticket which is free of charge with your active Webroot subscription and they can get to the bottom of this for you?

 

Hope this helps somewhat?

If Webroot is using significant CPU, such as 100% or more, shouldn’t I be seeing Bytes Read increasing at a steady rate?  I’m seeing “Bytes Read” increase at maybe 0.02 GB every 2-3 minutes.  Seems very very slow for such extreme CPU usage.

Userlevel 7
Badge +17

Hey @jordanshute ,

I reached out to our support team about this and they said the following:

“you could see a higher CPU usage from WSDaemon if the agent is in the midst of running a scan. Macs are also kind of funny in the way they calculate CPU usage percentages. In Windows 100% of the CPU is representative of the calculated processing power of the CPU, whereas on Mac, you'll have processes sometimes running at over 100% CPU. This is a result of how Mac systems present CPU usage, as it's really looking at the usage on a single core as opposed to the usage across all cores at once. So for example, on a quad-core system the max CPU percentage available would be 400% (based on how activity monitor displays usage). Dual Core would be 200%.. etc etc”

Long story short - It’s very possible that this CPU spike is from a scan. But they’d love for you to reach out to them via ticket or phone to make sure everything is alright!

-Keenan

Reply