Question

Webroot not working on MAC

  • 10 November 2020
  • 4 replies
  • 830 views

I just update my cataline and now my Webroot is not working.  I know it wasn’t supported as a 64bit software and I’m assuming thats most likely the cause. I reisntall it and see if its compatible or not. I followed the instruction but but the link brings me to the webpage to buy it. Any help on getting it back would be helpful!


4 replies

Userlevel 2
Badge +11

What do you mean when saying it’s not working? Please give more details

What do you mean when saying it’s not working? Please give more details

It’s running when you click on it, but no window actually opens. Uninstalling/installing doesn’t fix it

Userlevel 7
Badge +59

@johnbelley  make sure you have version 9.1.4.123!

 

In this thread there is a Direct download link!

 

https://community.webroot.com/home-product-releases-27/product-update-mac-version-9-1-4-123-345361?postid=361697#post361697

Hi johnbelly,

I am writing this for you, but also to others who may be reading this and not yet have Catalina on their macs.

After updating your macOS to Catalina (final version is now 10.15.7 before the release of Big Sur), you need to make sure you install the latest version of WebRoot SecureAnywhere. Please use the link provided by TripleHelix in the previous post.

 

Use support if necessary:

If installation of the latest version doesn’t work, please don’t hesitate to contact tech support, which is free with a subscription - they will help you! Please be patient with tech support, as it may take them 1 or 2 days to respond. Send just one support ticket, not multiple. Provide them with the exact version of your macOS, and the current version of Webroot SecureAnywhere installed on your computer (look under My Account). State clearly the problem. They will help fix any problems, including uninstall/install issues. They can also remotely access your computer, if necessary, to help re-install the software (as they did in my case last December).

 

Background:

The older versions from a year ago were not compatible with Catalina. Updates over the last 6 months or so fixed a range of issues and improved compatibility with Catalina and the forthcoming Big Sur (macOS 11.0). The Webroot team has done a huge amount of work to fix the issues. Many of the problems were due to the significant changes Apple made in macOS Catalina, because they switched the whole OS to a x64-bit platform… I’m guessing they did this in preparation for Big Sur, which comes out later this month or December. I won’t install Big Sur for several weeks as a precaution, until I am certain this new OS version is running properly on our macs, and that there are no major issues with SecureAnywhere.

Hope this helps.

Reply