All keyboards quit working IMMEDIATELY after install

  • 25 April 2012
  • 7 replies

Hello webroot community,
I have been trying to decide on a new antivirus product and have heard good things about Webroot throughout my reverse code engineering community. I do application/network security for a living, so I'm no newbie. I've tried installing a trial version of Webroot SecureAnywhere Essentials 2 times now. Both times, IMMEDIATELY after the install is done, my laptop keyboard and any USB keyboard stop working. I can reboot, go into safe mode, etc, but they are still completely disfunctional (even at the windows logon screen.) I am running a COMPLETELY FRESH copy of Windows 7 Home Premium on my brand new Asus Zenbook UX31E. I almost decided to just move on to another virus scanner because I didn't want to mess with the trouble of trying to get it resolved, but I am hoping that you guys may show some type of consolation (discount on my license) for all the problems. I am a computer professional, so I don't need you to baby me along. There is no virus on my computer. It is a completely fresh load of Windows 7. The only way I was able to even fix the problem, was by using a on-screen virtual keyboard to uninstall Webroot. Let me know what questions you need answered to try to assess the problem... it is a weird one (i assume it has something to do with your software managing key loggers.) THanks for your help!

Best answer by JimM 25 April 2012, 17:17

View original

7 replies

Userlevel 7
Hi Lahma,
Welcome to the Webroot Community!  :D
Many of the reported keyboard issues are now fixed in build  Can you please ensure that's what you're running?  If you're installing from an installation disc and no internet connection for instance, you'd still be running a very old version without bug fixes for that issue.  Try downloading the installer from
One thing I've noticed about reports of this issue is that many of the people who are reporting this issue do have new computers, but many of those new computers are being shipped with outdated drivers.  I've found that updating your keyboard and sometimes touchpad drivers will resolve this issue.  I've noticed this in particular on Elantech drivers.  It wouldn't hurt to visit your manufacturer's website and download the most recent keyboard and touchpad drivers with Webroot uninstalled and then reinstall it after the drivers are updated and the system has been restarted once.  I'd be interested to know if that takes care of the issue in this case or not.  Please note, it's best to do this from the manufacturer's website specifically - Windows Update unfortunately tends to get this wrong and tell you that you have the most recent driver when you really don't.
If that doesn't help, another bit of good news is that our lead developer is very interested in this type of issue and has been working hard lately to solve problems like this one.  We have confirmed that at least some of the keyboard issues reported on other makes and models of computers have been resolved.  Worst case scenario, if the issue reproduces you should open a ticket with support here so we can investigate a bit more thoroughly and get this resolved for you.
Before I installed webroot , I had already installed all of the latest drivers from asus, including my elantech touch pad drivers. Reloaded OS, updates drivers, then installed webroot. I never use driver updates from Windows Update. So should I open a ticket and explain the issue again?
Userlevel 7
There's no need to re-explain the situation. I went ahead and created the support ticket for you myself. You should be receiving an email shortly that requests you to run a logging utility so we can investigate further. We will be happy to help you out.

I'm still not entirely clear based on your reply that you were using the most recent version of Webroot though ( as of the time of this post). Again, it's worth ensuring that this is the case since we have a known issue with Elantech drivers that was fixed in that release. Please go ahead and collect the logs though if necessary, and we will continue to assist. 🙂
This just happened to me...twice.  I had to use the Task Manager to shut down the computer, came back up in safe mode and all looked good.  Rebooted normally and no mouse, no trackpad on an HP 8540W.  After about 90 seconds the Webroot welcome screen flashed on a second time and the mouse response returned.
Userlevel 7
Hello ghanson and welcome to the Webroot Community!
So... is the mouse/trackpad functioning correctly now?  It sounds like the USB driver was disrupted, which is a known thing with several AV's... it is rare but it can happen.  Usually the driver simply needs to be reinstalled, but in your case it sounds like things worked itself out on its own if things are back to working correctly.
Yes, it has apparently worked itself out.  I was rebuilding my Win 7 x64 system and reinstalled Webroot SA.  I've never had that occur before.  Now that I think about it there were a couple of Windows system updates yet to install so maybe one of those fixed the issue.
Thanks for the quick reply.
Userlevel 7
You are most welcome, and I am glad things are now working correctly.
If you do have any questions or problems, let us know, we are always happy to try to help 🙂